Page refresh



  • I use Chrome as my browser with the Duet Wi-Fi and the page refresh drives me crazy. On my PC the browser window isn't big enough to show everything on one page without any vertical scroll bars. Not typically an issue as you simply scroll down to see the other information. However, on my setup the screen jumps back top the very top, presumably doing a refresh, after about a second. What causes this and how do i stop it
    Thanks in advance


  • administrators

    Which versions of DWC and Chrome are you using?



  • Chrome Version 70.0.3538.77 (Official Build) (64-bit) and DWC Version 1.22.4. Both are the latest I believe


  • administrators

    Thanks, also which page or pages of DWC does it happen on? Does it happen even when the printer is idle?



  • It does it on any page that has vertical scroll gadgets and is the same whether the printer is printing or idle


  • administrators

    Can you check if toggling "Always show info area" on the Settings page makes a difference?



  • Interesting, turning it off seems to have done the trick. However turning it back on doesn't make it jump any more. Will see how it goes and report back



  • Works for me as well ! Thanks !
    Small observation the page refresh was not happening two months ago. I wonder if a chrome update slipped undetected and caused this "bug".



  • Is there any fix for this yet? I have the newest everything and this drives me nuts, i cannot select old gcode files to reprint as it always jumps back up. Toggling the "always show info area" does nothing



  • I don't get this behaviour in Firefox, don't have Chrome installed to test. Another option is to 'Zoom out' so everything is smaller, but fits on the page. Might not work for a long list of files in the Jobs folder, though.

    Ian


  • administrators

    I've never seen this problem with Duet Web Control 2.



  • @Foden said in Page refresh:

    I use Chrome as my browser with the Duet Wi-Fi and the page refresh drives me crazy. On my PC the browser window isn't big enough to show everything on one page without any vertical scroll bars. Not typically an issue as you simply scroll down to see the other information. However, on my setup the screen jumps back top the very top, presumably doing a refresh, after about a second. What causes this and how do i stop it
    Thanks in advance

    I use Chrome constantly with DWC1 and DWC2. I've tried to force the behavior you describe and have never seen it happen. Given several others have said this, it must be something unique to your Chrome install.

    Have you tried turning off all plugins in chrome? Re-installing? etc, etc. If you are on Windows, have you tried Edge (JUST, and I repeat, ONLY, for debugging)?



  • @Danal Yikes - this was from a year ago - lots of people have mentioned this. It's a "Feature" of the web control. Belive it was chrishamm that gave me the the solution I had to toggle Off the "always show info area" - on this very page



  • The restart post says:

    @NitroFreak said in Page refresh on 23 Oct 2019:

    Is there any fix for this yet? I have the newest everything and this drives me nuts, i cannot select old gcode files to reprint as it always jumps back up. Toggling the "always show info area" does nothing


Log in to reply