Problem with new board…



  • I am having some problems with the new board I received. Initially, I couldn't connect to the DUET WiFi server, so I upgraded to the latest firmware, which was DuetWiFiFirmware-1.17b.bin, DuetWebControl-1.14.bin, and DuetWiFiServer-1.03-ch.bin. The microcontroller had a hard time communicating with the WiFi chip and I saw a lot of trying to connect at XXXXXX baud: failed errors , but eventually it connected and the WiFi and server firmware loaded. The web server didn't initially come up, but after trying for about half a day, it magically came up all on its own. It has worked flawlessly for about 4 days, then this morning, it quit working again. I checked on git this morning and noticed a new Firmware for the DuetWiFi board and Duet Web Control, so I downloaded them and tried to install them this morning. I had no problem loading the Firmware on the Duet WiFi board, but when it came to the WiFi chip, the microcontroller just can't communicate with it.

    I have been a systems engineer for over 20 years and have a lot of experience fixing buss and communication problems with I2C, SPI, 1-wire, etc…there seems to problem with the buss or the bit banging routines. It is also possible there could be a bad (cold) solder connection under one of the chips on the SPI buss...

    I would like to hear your thought on the problems I am having,I am pretty frustrated at this point... Plaease send your responses to autodidactsavant@gmail.com

    Thanks,
    Steve Pearce.


  • administrators

    Hi Steve

    As I mentioned in the email it does appear that there is an issue with the SPI between the ESP and the MCU. You will need to contact who you bought the board from to arrange a replacement under warranty.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.