[SOLVED]Uploading gcode errors



  • Last night I started having upload errors that I have never had before. Not everytime but most of the time. When it does it it loads between 5% to 40% then stops and times out with an error. I have not changed any of my Wifi equipment or any settings. I have not changed firmware on my Duet. I have reset my router which did not help. I took the card out of the Duet Wifi and copied the files to my computer then formated the card and copied them back. Any help as to why this started occurring would be appreciated because it is a pain to get to the card under the bed of my delta.

    Here is firmware:

    Firmware Name: RepRapFirmware for Duet 2 WiFi/Ethernet
    Firmware Electronics: Duet WiFi 1.0 or 1.01
    Firmware Version: 2.01(RTOS) (2018-07-26b2)
    WiFi Server Version: 1.21
    Web Interface Version: 1.21.2-dc42

    Here is my config:
    (pardon the multiple commented out lines)

    ;Zesty Nimble PETG

    ; Communication and general
    M111 S0 ; Debug off
    M550 K250 ; Machine name and Netbios name (can be anything you like)
    M540 P0xBE:0xEF:0xDE:0xAD:0xFE:0xEF ; MAC Address

    ;*** Wifi Networking
    M552 S1 ; Enable WiFi

    M555 P2 ; Set output to look like Marlin

    M575 P1 B57600 S1 ; Comms parameters for PanelDue

    G21 ; Work in millimetres
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves

    ; Axis and motor configuration
    M569 P0 S1 ; Drive 0
    M569 P1 S1 ; Drive 1
    M569 P2 S1 ; Drive 2
    ;M569 P3 S0 ; Drive 3 Standard
    M569 P3 S1 ; Drive 3 Portescap
    M569 P4 S1 ; Drive 4
    M574 X2 Y2 Z2 S1 ; set endstop configuration
    ; (all endstops at high end, active high)

    ; delta radius, diagonal rod length, printable radius and homed height
    M665 R169.710 L330.0 B120 H559.474 X0.041 Y-0.220 Z0.000

    M666 X-0.24 Y0.50 Z-0.26 ; endstop adjustments
    M350 X16 Y16 Z16 I1 ; Stepper mode (I1 only works with 16)
    M92 X160 Y160 Z160 ; Set axis steps/mm
    ;M906 X1000 Y1000 Z1000 E500 ; Set motor currents (mA)
    ;M201 X1000 Y1000 Z1000 E300 ; Accelerations (mm/s^2) ; Was E120
    ;M203 X30000 Y30000 Z30000 E10000 ; Maximum speeds (mm/min)
    ;M566 X600 Y600 Z600 E60 ; Maximum instant speed changes mm/minute (Jerk) Was E40

    M906 X1000 Y1000 Z1000 E1200 ; Set motor currents (mA)
    M201 X1000 Y1000 Z1000 E1000 ; Accelerations (mm/s^2)
    M203 X30000 Y30000 Z30000 E10000 ; Maximum speeds (mm/min)
    M566 X600 Y600 Z600 E600 ; Maximum instant speed changes mm/minute (Jerk)

    ; Fans
    M106 P1 T50 S255 H1 ; hotend heatsink FAN1
    M106 P2 T50 S35 H1 ; extruder motor FAN2

    ; Thermistors
    M305 P0 T100000 B3950 R4700 ;L54 H-97 ; Bed thermistor ADC correction
    M305 P1 T100000 B4388 R4700 ;L54 H-97 ; First nozzle thermistor ADC correction

    M143 S285 ; set the maximum temperature of the hot-end to 285°C
    M143 H0 S120 ; set the maximum bed temperature to 120C

    M570 H0 P5 T10 ;Hnnn Heater number H0 is bed, H1 is 1st hot end
    M570 H1 P5 T10 ;Pnnn Time in seconds for which a temperature anomaly must persist
    ;on this heater before raising a heater fault (default 5 seconds)
    ;Tnnn Permitted temperature excursion from the setpoint for this heater
    ;(default 10C)

    ; PID / B1 = bit bang B0 = PID
    M307 H0 A180.3 C557.9 D2.5 B0 ; Bed
    M307 H1 A617.2 C254 D4.5 B0 ; Hot End 1

    ; Tool definitions
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 S0 R0 ; Set tool 0 operating and standby temperatures
    ;M350 E16 ; Stepper mode (I1 only works with 16)
    M350 E16 I1
    ;M92 E2660 ; Set extruder steps per mm (PETG)with M592 D0 A-0.001 B0.0026
    ;M92 E1341 ; Portescap Maker Geeks PETG .04 Nozzle Portescap
    ;M92 E1364 ; Portescap Atomic Marble PETG .04 Nozzle
    ;M92 E1350 ; Portescap Atomic Starry Night .04 Nozzle
    M92 E1320 ; Portescap Atomic Starry Night .06 Nozzle
    ;M92 E1300 ; Portescap Hatchbox Wood PLA .06 Nozzle

    ; Z probe and compensation definition
    M558 P4 A5 S0.02 H3 I0 ; Z probe is a switch and is not used for homing any axes
    G31 X0 Y0 Z-0.06 P500 ; Z value is trigger point
    M556 S78 X0 Y0 Z0 ; Axis compensation here
    M557 R75 S20 ; Define Grid For Mesh Height

    ;M592 D0 A0.006 B0.006 L0.40 ; Non Linear Extrusion MG CF PETG 230C
    ;M592 D0 A-0.001 B0.0026 L0.40 ; Non Linear Extrusion Orange PETG 230C
    ;M592 D0 A0.00035 B0.0039 L0.40 ; Non Linear Extrusion Yellow PETG 220C Portescap
    M592 D0 A0.0088 B0.0015 L0.40 ; Non Linear Extrusion Red PETG 250C Portescap
    ;M592 D0 A-0.008 B0.0069 L0.40 ; Non Linear Extrusion Atomic Marble PETG 220C Portescap
    ;M592 D0 A0.0285 B0.0021 L0.40 ; Non Linear Extrusion Yellow PETG 220C Portescap
    ;M592 D0 A0.01 B0.0019 L0.4 ; Non Linear Extrusion Atomic Starry Night PETG 230C Portescap 0.6 Nozzle
    ;M592 D0 A-0.01 B0.0025 L0.4 ; Non Linear Extrusion Hatchbox Wood PLA 220C Portescap 0.6 Nozzle

    M572 D0 S0.0 ; No Pressure advance with Kisslicer

    M106 S0 F25500 L40 X180 B0.1 ; Fan / Off / 25.5kHz / Low 15% / High 70% / 100% for 0.1 sec at start

    M208 S1 Z-0.25 ; set minimum Z
    T0 ; select first hot end

    Here is diagnostics after turning it on and trying to upload previous files that I know worked in the past:

    === Diagnostics ===
    RepRapFirmware for Duet 2 WiFi/Ethernet version 2.01(RTOS) running on Duet WiFi 1.0 or 1.01
    Board ID: 08DAM-999TL-MQ4S8-6J9FJ-3SJ6T-16B7X
    Used output buffers: 3 of 20 (9 max)
    === RTOS ===
    Static ram: 28476
    Dynamic ram: 96312 of which 16 recycled
    Exception stack ram used: 340
    Never used ram: 5928
    Tasks: NETWORK(ready,272) HEAT(blocked,1248) MAIN(running,3476)
    Owned mutexes:
    === Platform ===
    Last reset 00:05:08 ago, cause: power up
    Last software reset at 2018-10-29 17:09, reason: User, spinning module GCodes, available RAM 5940 bytes (slot 1)
    Software reset code 0x0003 HFSR 0x00000000 CFSR 0x00000000 ICSR 0x0041f000 BFAR 0xe000ed38 SP 0xffffffff Task 0x4e49414d
    Error status: 0
    Free file entries: 10
    SD card 0 detected, interface speed: 20.0MBytes/sec
    SD card longest block write time: 33.1ms, max retries 0
    MCU temperature: min 29.4, current 31.4, max 32.0
    Supply voltage: min 24.0, current 24.2, max 24.5, under voltage events: 0, over voltage events: 0
    Driver 0: standstill, SG min/max 0/164
    Driver 1: standstill, SG min/max 0/166
    Driver 2: standstill, SG min/max 0/159
    Driver 3: standstill, SG min/max not available
    Driver 4: standstill, SG min/max not available
    Date/time: 2018-11-06 20:13:22
    Slowest loop: 127.00ms; fastest: 0.07ms
    === Move ===
    Hiccups: 0, StepErrors: 0, LaErrors: 0, FreeDm: 240, MinFreeDm: 234, MaxWait: 68170ms, Underruns: 0, 0
    Scheduled moves: 5, completed moves: 5
    Bed compensation in use: none
    Bed probe heights: 0.000 0.000 0.000 0.000 0.000
    === Heat ===
    Bed heaters = 0 -1 -1 -1, chamberHeaters = -1 -1
    Heater 1 is on, I-accum = 0.0
    === GCodes ===
    Segments left: 0
    Stack records: 1 allocated, 0 in use
    Movement lock held by null
    http is idle in state(s) 0
    telnet is idle in state(s) 0
    file is idle in state(s) 0
    serial is idle in state(s) 0
    aux is idle in state(s) 0
    daemon is idle in state(s) 0
    queue is idle in state(s) 0
    autopause is idle in state(s) 0
    Code queue is empty.
    === Network ===
    Slowest loop: 127.24ms; fastest: 0.01ms
    Responder states: HTTP(0) HTTP(0) HTTP(0) HTTP(0) FTP(0) Telnet(0) Telnet(0)
    HTTP sessions: 1 of 8

    • WiFi -
      Network state is running
      WiFi module is connected to access point
      Failed messages: pending 0, notready 0, noresp 0
      WiFi firmware version 1.21
      WiFi MAC address a0:20:a6:19:5c:cb
      WiFi Vcc 3.42, reset reason Turned on by main processor
      WiFi flash size 4194304, free heap 17160
      WiFi IP address 192.168.1.100
      WiFi signal strength -45dBm, reconnections 0, sleep mode modem
      Socket states: 0 0 0 0 0 0 0 0
      === Expansion ===

  • administrators

    I can't see anything wrong with the M122 report, and the WiFi signal strength looks good.

    • Has it improved since you reformatted the SD card?
    • Have you acquired any new wireless devices recently? not necessarily WiFi, because other wireless devices work in the same band.
    • Might your router have changed the WiFi channel it is using?


  • No improvement after reformat.
    No new wireless devices since 3 months ago.
    Don't know about the channel, will see what channel and turn off the router and see what other signals are on the channel it is on. The printer sets in the same room as you can tell by the signal strength.
    I do have the router set up to give a reserved static IP to the Duet.
    Same errors happened when I tried from my phone and from a tablet.
    Funny that the web interface still works fine except when trying to upload a gcode file.



  • I would suspect something with my server since my computer is on an isolated network from wan (where the router is) which is filtered through the server, but the phone and tablet are direct to the router.



  • Same happens with mine 2.2 rc3 and latest DWC,
    First upload of the day is nearly always ok subsequent uploads I often get errors and really slow uploads at a rate of a few kB/s which may or may not error out.



  • Well, I don't know what to say.....just got back to the printer this afternoon and uploaded 30 or so files without a hiccup. Guess I'll call this solved (although I don't know how) unless it does it again.



  • This may be a windows problem, had to reinstall on a new ssd and the problem seems to have gone


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.