Controlling a Cetus3D with Duet3D 0.8.5



  • They used the same layout on my Up Mini 2. Doubling the heater wires to increase current carrying capability of both wires and connectors. From your picture they use the same pinout as well.



  • @fotomas thanks!

    I spend a few hours figured out, I’m a novice when come to electronic. I tried mapping out the circuit board and use thermistor to check each pair connectivity, then could identified them all 🙂

    Then, Cetus use PT100 as thermistor. Did you swap out to something else or buy PT100 daugther board?

    Also, you get new heater or not? And did you splice the wire for double heating pin, right? Still not sure how to do it right ..



  • @cookie

    I'm using the original cetus thermistor. It works well after finding the correct values for it.

    I do not think a negative B value is common.
    M305 P1 R4700 T112 B-425 C7.060000e-8


  • administrators

    @fotomas said in Controlling a Cetus3D with Duet3D 0.8.5:

    @cookie

    I'm using the original cetus thermistor. It works well after finding the correct values for it.

    I do not think a negative B value is common.
    M305 P1 R4700 T112 B-425 C7.060000e-8

    Looks like you are using a PT100 but you have connected it directly to the thermistor input. This will give you a very poor resolution and you should use the PT100 daughter board instead. However, if you want to use a direct connection then I suggest this:

    M305 P1 X501 R47000

    This says you are using a PT1000 sensor, but inflates the series resistor value by a factor of 10 to compensate for the fact that you are actually using a PT100.



  • Hi guys great thread!

    I have a couple of questions -

    Why do you think they shipped the cetus with 38 ohm steppers? Is there some reason to use high resistance motors?

    Is there any advantage to the mark 3 if you're just going to rip out the electronics?

    Thanks



  • Hello 🙂
    I'm also replacing the main board of my Cetus MK1 with a Duet Maestro.

    I'd like to run both the mainboard and the original heatbed with the original 19V PSU that came with the Cetus. The original main board did limit the current or voltage of the heatbed somehow to not overburden the small PSU. It is that way limited to around 60 °C. For 100 °C it has a connector for an external PSU with more power. As I'm fine with that temperature I want to ask you if it is possible with the Maestro to limit the current or voltage for the heatbed as well? I don't want to destroy my PSU or risk the print to fail due to an underpowered Maestro where the current is sucked away by the heated bed.

    If it is not possible, what PSU dimension do you recommend for the Cetus? I wonder if the MeanWell HLG-320H-24A is big enough, even for 100°C later on?



  • @ted said in Controlling a Cetus3D with Duet3D 0.8.5:

    As I'm fine with that temperature I want to ask you if it is possible with the Maestro to limit the current or voltage for the heatbed as well?

    It is only possible to limit the average power, by means of controlling the maximum duty cycle of the PWM signal for the bed.

    https://duet3d.dozuki.com/Wiki/Gcode#Section_M303_Run_heater_tuning
    https://duet3d.dozuki.com/Wiki/Gcode#Section_M307_Set_or_report_heating_process_parameters

    P parameter in M303 and S paramterer in M307



  • if you get an external mosfet for the hotbed its easy to use 2 power supplies. You can even use different voltages that way.



  • Thanks for the fast answers! I then will buy a new PSU. I go for a one PSU for everything solution.

    Are 320 Watts of the HLG-H320-24A enough for that small heatbed and then 100°C? Next would be 480 Watts and much more expensive. I prefer the HLG series as it works with passive cooling.



  • there is the Meanwell UHP-350-24 in between.



  • I now migrated to an Duet Maestro to using a absolute silent and not even warm HLG-H320-24A PSU.

    While I'm very happy with the basic setup I have problems with those original high impedance motors. The problem is the same as mentioned before: The motors are getting very loud when moving. For me that happens only for fast travels starting with > F270 movements (G1 Z50 F270 S1 at 256-microsteps and 1359,68 step/mm). Altering the relevant depending values this is regardless of microstepping mode (1-256) and current (200-1400 mA) chosen.

    With command G1 Z50 F270 S1 the movent can't be heared at all.
    With command G1 Z50 F273 S1 it is a random mix of loud and absolute silent movements intervals.
    With command G1 Z50 F275 S1 it is a loud all the time.

    I've attached my config.g to this post: 0_1556283965533_config.g

    My motors have something about 30-31 Ohm per phase.

    Do you have any idea?



  • M350 X256 Y256 Z256 E16 I1 do you really need this? this might put quite a high strain on the cpu. 16 with interpolation should be fine in most cases

    M203 X1000 Y1000 Z1000 E1000 Thats a very high z speed.

    You Probably want to adjust the Hybrid Threshold V for the motors to not go into spreadcycle at higher speeds
    see https://duet3d.dozuki.com/Wiki/Gcode#Section_M569_Set_motor_driver_direction_enable_polarity_and_step_pulse_timing



  • @veti said in Controlling a Cetus3D with Duet3D 0.8.5:

    Hybrid Threshold V

    Was hard to find out what you meant what you meant with Hybrid Threshold V but found the relevant parameter. It is working now – In absolute silence! Thanks a lot for the hints! 😘

    I set the threshold to 100 (whatever unit this is) by extending the already in my config existing command M569 P0 S0 to M569 P0 S0 V100 for all my axes (P0 up to P4).

    I not completely understood how this threshold works. Especially I'd like to know why someone would want to switch to Spread Cycle for higher speeds? Higher torque?



  • @ted said in Controlling a Cetus3D with Duet3D 0.8.5:

    I not completely understood how this threshold works. Especially I'd like to know why someone would want to switch to Spread Cycle for higher speeds? Higher torque?

    if you enter M569 P0 you will see the speed at which the driver switches from stealthchop to spreadcycle.
    however at high speed (i think above 60mm/s) the switch can cause layer shifts.

    to enable spreadcycle all the time use the D2 option



  • i did the conversion as well with a maestro.it took me a long time to figure out the trick with the V value;-) now i have a question. i set my V values below 100. can this cause a problem? right now im impressed how quiet the printer is!

    M569 P0 S0 V70 D3
    M569 P1 S1 V70 D3
    M569 P2 S1 V120 D3
    M569 P3 S1 V120 D3
    M350 X64 Y64 Z64 E32 I1
    M92 X320.00 Y320.00 Z320.00 E232.00
    M566 X1200.00 Y1200.00 Z1200.00 E1200.00
    M203 X30000.00 Y30000.00 Z1500.00 E1500.00
    M201 X3000.00 Y3000.00 Z500.00 E500.00
    M906 X400.00 Y400.00 Z500.00 E500.00 I60

    @fotomas thanks for this entry it helped a lot!!!


  • administrators

    @2rad said in Controlling a Cetus3D with Duet3D 0.8.5:

    i set my V values below 100. can this cause a problem?

    Yes, also you may get missed steps spurious short-to-ground errors reported. The stealthChop mode doesn't work well at high speeds.

    Another cause of noisy motors is running out of motor voltage at high speeds. The motor EMF calculator at reprapfirmware.org will tell you the speed at which you start to suffer loss of torque. The motors will become noisier above that speed too because the driver can't implement microstepping properly.



  • @fotomas I've successfully tested the Cetus by heating up hot end to 240c and heated bed to 90c to 2 hours .. and it seems stable now.

    Now it's time to level the bed and test printing. However, I found that the end stop for Cetus is at the top, so Z = 0 cm is at the highest level and Z = 18+ cm is at the bed level.

    So, how did you config the Duet with Cetus flipping Z?

    0_1557842210970_IMG_7189.jpg

    Update 1:
    I have changed endstop location to "At High End" and flip z motor direction and the machine can home successfully .. then when I try to move in -Z nothing happened but when I try +Z it keep going up against the end stop! But after that stuttering I can move in -Z about 2.5cm and that's it.

    0_1557845803046_Configurator Problem 03.jpg

    Update 2:
    I've found the solution by editing "homez.g" in setting:
    ;G92 Z0 ; set Z position to axis minimum (you may want to adjust this)
    to
    G92 Z180 ; set Z position to axis maximum

    0_1557846947945_Configurator Problem 04.jpg

    Thanks,
    Cookie



  • @cookie
    I am using an IR sensor so I have z 0 at bed.
    But what you need to do is set that the end stop is at the high end of the axis and in the homing file home to Z 250 mm.

    The exact commands maybe someone else can help with?



  • @dc42 said in Controlling a Cetus3D with Duet3D 0.8.5:

    Yes, also you may get missed steps spurious short-to-ground errors reported. The stealthChop mode doesn't work well at high speeds.

    what i have found is that with 24v stealthchop2 works ok at high speed.
    what does not work at high speed is hybrid mode. Switching from Stealhchop2 to Spreadcycle at higher speeds will cause layer shifts.

    so i have set my hybrid mode to 200 so that it does not do the switchover and it seems to work.


  • administrators

    @cookie said in Controlling a Cetus3D with Duet3D 0.8.5:

    Update 2:
    I've found the solution by editing "homez.g" in setting:
    ;G92 Z0 ; set Z position to axis minimum (you may want to adjust this)
    to
    G92 Z180 ; set Z position to axis maximum

    It's better to remove the G92 command completely. Set the M208 upper Z limit to the height at which the endstop switch triggers.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.