heater fault troubles



  • @dc42

    After your message I went to look again for all possible electrical interruptions, and found the sensor wire or the E3D connector to be faulty. Probably it just had too much of a beating from assembling it many times.

    Capacitors removed. All set. Thanks again!

    Michiel



  • Hmmm, seems it's not so easy after all. Had another failure today.
    Wondering if there is a debugging method, like logging temperature.



  • I have had those on both my printers. In both cases I had seepage, so an extra thermal bridge formed by schmutz between heat sink and heat block. FYI


  • administrators

    @vandermeulen said in heater fault troubles:

    Hmmm, seems it's not so easy after all. Had another failure today.
    Wondering if there is a debugging method, like logging temperature.

    There is currently no temperature logging except for the graph displayed by DWC (which covers a limited time window), also if you have M929 logging enabled then any heater fault events should get logged to the SD card log file.



  • @dc42 The graph is very helpfull, but for longer prints I cannot babysit the printer.
    For now I will try if better ground between power supply and heater block will improve the situation. And I will bypass / solder the E3D Molex connector, to eliminate a failure point.



  • One other possibility is that the cartridge thermistor is not making proper contact with the extruder hot end. I also had the same problem...I changed the thermistor cartridge....had the same issue. I did the same wiggle test to see if there was a problem with the wiring and it seemed like the temperature corrected while wiggling the wire. I then tried to tighten the screw on the thermistor cartridge and everything started working again. I had a look at the old one that I removed and it looked like there was some Corrosion which would make for a thermal barrier between the hot end block and the sensor...Just a thought



  • Hi,

    There could another reason aside from hardware.

    I was pulling my hair out trying to discover what was causing sudden dips in the temperature while printing the 20x20x20 test cube model. I wrote the forum about the problem 4 or 5 months ago prior to a 3 month hospital stay.

    The problem, apparently, turned out to be caused by additional temperature codes that were generated by slic3r. That program for some unknown reason inserted (174) additional codes that increased the hotend temperature by 10°C or more from the starting PLA temperature of 210°C. The inserted code was 'M104'.
    https://duet3d.dozuki.com/Wiki/Gcode#Section_M104_Set_Extruder_Temperature

    "Example: M104 S190"
    Set the temperature of the current extruder to 190°C and return control to the host immediately (i.e. before that temperature has been reached by the extruder)."

    My Printed Solid "Daily PLA" filament temperature (200°C ~ 220°C), I had set it for 210°C, but because the slic3r code periodically changed the the temp to 220°C or higher, apparently caused the 'program' to throw a heat fault, which paused the printing. It seems, that the heat rise period was taking too long which threw the fault! There could another reason for this? Such as perhaps the print-fan running too fast thereby causing the temperature of the heat block to slowly rise?

    Removing the (174) additional M104 codes seemed to fix the problem. I seriously thought that the DUET-E controller had failed.

    My hacked up AnyCubic Linear + delta printer now has what may be a vibration problem, I think?, as there is a recurrent 'lump' printed on one side of the test cube. However, beyond that issue, the printer appears to be working very well. No more faults!!

    Lots of fiddling...hope this helps..

    3mm


  • administrators

    Temperature adjustments commanded by M104 don't normally cause heater faults, assuming that the heater is capable of reaching the new temperature. However, it might be that commanding a new temperature before the current one has been reached would provoke a fault.



  • @dc42

    Thanks for the reply...

    My setup:
    DUET-E (EtherNet) HW: V1.02
    DUET-E FW: DuetEthernetFirmware-1.18.1
    Panel DUET FW: 1.20 (15b1)
    Smart Effector:



  • 3mm 9 Dec 2018, 19:07

    @dc42

    Thanks for the reply...

    My setup:
    DUET-E (EtherNet) HW: V1.02
    DUET-E FW: DuetEthernetFirmware-1.18.1
    Panel DUET FW: 1.20 (15b1)
    Smart Effector: E3D HotEnd + Silicon Sock
    350W Switching Power Supply.

    I have printed several objects recently, which were relatively flawless and without any hot-end heater faults being thrown. Last night, I put in some new PLA filament (Printed Solid brand, "Daily", turned off both fans, and heat bed, dialed in 210°C on the E3D hot-end and about halfway (145°C), it threw a heater fault, emitting something like, "Temperature rising too slowly, etc". I ran the heater fault reset, attempted to attain target temperature again, and it threw a faul again.

    The Vin display on the WebControl is depicting 11.3Vdc, yet using my 5 digit Fluke lab DVM, measuring directly on the input Voltage terminals, shows 12.1Vdc. Something seems amiss there? I presume that there is a reference source somewhere for the ADC, perhaps that might be cause of these apparently random heater-faults? I've been trying to find the cause for these for a long time. It comes and goes. I've checked all my wiring, I've done pull tests on the connectors, I use 'bootlace' wire terminators. In my mind the problem behaves as a intermittent controller. In addition to throwing heater faults, the controller frequently disconnects, yet there are only two devices on the network, the pc and the DUET-E controller, aside from the switch, and its a pass-through switch.

    Got any suggestions?

    thanks

    3mm,
    ps the above post, was posted when I pressed the space-bar, which caused the edit to post?? I can't find the 'edit' after post function on this bulletin-board? Does it have that feature?



  • I may actually have found the heater fault problem source. It certainly did appear to be a controller problem, but in rechecking the config.g code again, I found a chunk of code that un-did (so-to-speak) the heater auto-tune parameter instruction above the chunk. I removed that chunk, re-auto-tuned, plugged in the parms, and now things are/seem to be working much better, eg., I'm printing sans any error codes. Only time will tell. However, the wiki guides have proven to be very helpful.

    Other issues...

    M665 = Diagonal 288.120, delta radius 140.174, homed height 217.376, bed radius 111.8, X 0.457°, Y 0.512°, Z 0.000°

    M666 = Endstop adjustments X-0.60 Y0.21 Z0.39, tilt X0.00% Y0.00%

    G29 97 points probed, mean error 0.001, deviation 0.032
    Height map saved to file heightmap.csv

    The numbers above change occasionally, especially the end-stop numbers? Also the delta-radius??

    Performing the bed auto-tune, requires multiple passes to cause convergence, sometimes as many 4 or 5. The below numbers don't seem to be too good, are they? Can 'they' be better with more precision tweaking?

    G28 (home)
    G32 = Calibrated 6 factors using 17 points, deviation before 0.034 after 0.031
    G32 = Calibrated 6 factors using 17 points, deviation before 0.035 after 0.034

    Also the mesh compensation, seems to need better calibration? I'm including a screen grab of the mesh graphic..

    G28 (home)

    0_1544523552550_97pts mesh comp plan - 12-11-2018.jpg

    0_1544522364138_97pts mesh comp elevation - 12-11-2018.jpg

    Test-Cube Anomaly

    25,4mm x 25,4mm x 25,4mm Test-Cube print artifact anomaly:

    As for the bump or bulge on the test-cube, my 'X' tower, there's an anomaly on the first couple of layers, and then a few layers up, on each subsequent layer change the anomaly becomes more evident. While observing the 'X' tower linear-rail carriage I can see a small fast up/down 'stutter' motion, on the corner of the test-cube exhibiting the bulge.

    0_1544522930819_Test Cube Evolution 12-11-2018.jpg

    Also, the bottoms of the test cubes seem strange, as illustrated in the 2nd to last on right, although both of the silver cubes appear the similarly...it seems that this could be an artifact of the nozzle height not being propperly dialed-in.

    The other two prints illustrates the evolution of my printing successes! Heh heh, I just love that one on the left...six months of fiddling around!! Hee hee hee...

    DC42, thanks for all your good help in the past!

    Any advice is appreciated..

    Thanks in advance, 3mm


  • administrators

    The seam generated when you change layer is a function of your retraction settings and pressure advance. Please share those settings.



  • @dc42

    @dc42 said in heater fault troubles:

    The seam generated when you change layer is a function of your retraction settings and pressure advance. Please share those settings.

    Where are those controls stored? I looked around in the \sys\config.g but I see nothing up that sleeve?

    I ran: M572 D0
    M572 D0 <cr>
    Extruder pressure advance: 0.000, 0.000, 0.000, 0.000, 0.000, 0.000, 0.000, 0.000, 0.000

    Thanks...



  • @3mm
    It looks like you aren't using pressure advance at the moment. See this link for an idea of where to start.

    https://duet3d.dozuki.com/Wiki/Pressure_advance

    Your retraction settings are probably defined in the slicer, but they can also be controlled by firmware if you tell the slicer to let it.

    https://duet3d.dozuki.com/Wiki/Gcode#Section_M207_Set_retract_length

    https://forum.duet3d.com/topic/5993/firmware-retraction-tuning-with-macros


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.