Flipped Features during print



  • I'm not sure if this is the right place to post this, but here goes. I ran a long print yesterday (overnight) and this morning when I checked the print, I noticed that all of the features (cuts/holes) in the print were mirrored on the wrong side of the part. Has anyone experienced this before? Pics below.

    0_1542802311644_Enclosure.PNG

    0_1542802506812_IMG-3966.JPG



  • what kind of printer do you have?

    check the movement in the web us. if you move in x and y direction does it move correspond to that?



  • Its a Folgertech FT-5 with Duet Ethernet 2 board. It responds fine to moving the X and Y via web interface and touchscreen.



  • Hi. Seems that you have y axis flipped in your slicer.



  • Thanks for the input. I am using Simplify3D and I am not sure how I change that. I am using Simplify3D on my Prusa MK2S as well and do not encounter this issue.


  • administrators

    Does +X movement move the print head to the right, and +Y movement move either the print head away from you or the bed towards you?



  • @aidar I found that setting ( called flip build table axis) in the G-Code tab. The Y axis was in fact checked, although I am not sure why or how unless I clicked it on accident and didn't notice. I am going to run a smaller part and see if this solved the issue.



  • @dc42 X- moves the print head to the right. Y+ moves the print head away from me. Should this be reversed?


  • administrators

    @jtrobbins1 said in Flipped Features during print:

    @dc42 X- moves the print head to the right. Y+ moves the print head away from me. Should this be reversed?

    Yes, you have set up your printer to have a left-hand coordinate system You should reverse the direction of either X or Y. I suggest you reverse the direction of X. Don't forget that the X homing switch (endstop) will change form a min to a max one, or vice versa.



  • @dc42 I did what you suggested and reversed the X axis and end stop. This caused the printer to want to home in the wrong direction. The home position on this machine is the back right corner (see pics). I will post the settings I have in the firmware, in order to home the tool in the correct position.

    I made a small test part with a cut to the left side and printed it to see if it would flip the cut like on the previous file. It DID NOT. It printed exactly how it was positioned in S3D.

    So, I deleted the .stl of the original part that I had issue with and tried again. Its still oriented incorrectly. I have taken some pictures that will hopefully help. Could this somehow be an issue with just this one part file?

    0_1542818629192_Mirror Test.PNG

    0_1542818651449_Mirror Test.JPG

    0_1542818691640_Enclosure Orient.PNG

    0_1542818712446_Enclosure Retry.JPG

    0_1542818863874_Firmware Settings.PNG


  • administrators

    Did you leave the S3D settings the same as they were before? S3D is unusual in that it seems that you have to leave "flip Y axis" selected to get it to generate correct GCode.



  • @dc42 Yes. The "flip Y axis" setting is selected. This is the first chance I have had to get back to this issue since the holidays. I will try turning that setting off and see if it solves the issue.



  • Still no luck. Even when it shows the part oriented correctly in S3D, it still flips the features. I have played with the "flip X, Y, Z" settings and tried about every combo available with the same results. Im stumped on this one.


  • administrators

    Did you sort out the X axis direction and X homing?



  • @dc42 In order to get the print head to home in the correct position (back right corner), I have the following setting in my firmware (picture).

    With these settings, X+ moves the print head to the left. Y+moves the print head towards the back of the machine. Z+ moves the bed down, away from the print head. If I change the firmware settings for Drive 0 (X) to go forwards, it moves away from the end stop.

    So, I understand that this is inverted somehow, but I am not sure what combination of Drives/End stops settings I need in order to home the print head in the right direction. Here is a screenshot of that section in my firmware setup.

    0_1543415247164_Firmware Settings 1128.PNG


  • administrators

    @jtrobbins1 said in Flipped Features during print:

    @dc42 In order to get the print head to home in the correct position (back right corner), I have the following setting in my firmware (picture).
    With these settings, X+ moves the print head to the left. Y+moves the print head towards the back of the machine. Z+ moves the bed down, away from the print head.

    So you still have X+ moving in the wrong direction. You need to fix that. Reverse the X axis (M579) and change your M574 command and your homing files to suit a high-end X axis endstop. See https://duet3d.dozuki.com/Wiki/ConfiguringRepRapFirmwareCartesianPrinter, and/or use the configurator at reprapfirmware.org.



  • Okay, there are a few possibilities.

    First off, ensure that you are getting correct movement of the mechanics. Normally, if you use X+, as you are facing the machine, the print head should move to your right. If you use Y+ the print head should move away from you (Or the bed should move towards you.)

    What you are describing seems to be opposite motion for the X axis, which will indeed flip your model.

    Assuming that drive 0 is X, drive 1 is Y, drive 2 is Z, and that Y and Z are moving as expected...

    Change that line to:

    M569 P0 S1         ; Drive 0 goes forwards
    

    Then you need to change your homex.g and homeall.g files:

    The following are mine, based on a printer that has the home switches at X=245mm, and Y axis=280mm

    Note that this opposite for your Y axis, so you would change the homeall.g from this to send the head in the negative Y direction. You'll also want to change the size of the move to endstop according to the motion limits of your printer.

    homex.g

    ; homex.g
    ; called to home the X axis
    ;
    G91              ; relative positioning
    G1 Z5 F6000 S2   ; lift Z relative to current position
    G1 S1 X235 F1800 ; move quickly to X axis endstop and stop there (first pass)
    G1 X-5 F6000     ; go back a few mm
    G1 S1 X10 F360   ; move slowly to X axis endstop once more (second pass)
    G1 Z-5 F6000 S2  ; lower Z again
    G90              ; absolute positioning
    

    homeall.g:

    ; homeall.g
    ; called to home all axes
    ;
    G91                   ; relative positioning
    G1 Z5 F6000 S2        ; lift Z relative to current position
    G1 S1 X245 Y280 F3000 ; move quickly to X and Y axis endstops and stop there (first pass)
    G1 X-5 Y-5 F6000      ; go back a few mm
    G1 S1 X10 Y10 F300    ; move slowly to X and Y axis endstops once more (second pass)
    G90                   ; absolute positioning
    G1 X110 Y137.5 F3000  ; center print head
    G30                   ; Use Z probe to home Z
    G1 X220 Y275 F3000    ; Go to axis maximums
    

    edit: Mucked up the homeall.g. Oops, and @dc42 ninja'd it in,


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.