Problems with adapting Duet to 3D Kreator Motion 3D printer



  • I've finally recieved my Duet and PanelDue 7i.
    Because my CoreXY is still existing mainly on paper, I've decided that for the time being I'll adapt my old printer.
    After changing connectors and lugging everything into Duet, I've run configuration tool and uploaded results to printer.
    Unfortunately when I try to home any axis, only Z moves (and smashes into head). All motors are wired the same. The current on motors is present (they are holding).
    Extruder motor works as expected.

    This printer is 200x200x190mm.
    0.0.0 position is with Z all the way up, head is in upper right corner, as seen from above. It has mechanical endstops on all three axes (I've tried to use them, as well as stall detection to no effect), also there are RGB LED's and bed leveling mechanism (similar to Zortrax M200, when nozzle touches one of four corners printer "knows" that it's on Z=0. I have no idea how to use it with Duet).
    Does anyone have any idea what I'm doing wrong?
    Also, I have two fans that I want to connect to Duet (old ones from this printer, 40x40x10mm one and small turbine). They don't have any markings on them. Is it safe to connect them to a Duet?
    PSU is 24V (original one), board was proprietary, based on Atmega 2560.

    O, I've checked old PCB, fans are 12V, but Duet has 23Von it;s fan connectors. Do I need DC-DC buck converter on each fan, or is there some way to change it in FW?



  • There was a three pin fan voltage selector on the Duet Ethernet I had a few months back. Look at the wiring schematic and you'll be able to remove the jumper and feed one of these pins with the voltage you require.


  • administrators

    Test the axes by jogging them before you attempt homing. You can send M564 H0 to allow them to be jogged before they have been homed.

    Regarding the fans, see https://duet3d.dozuki.com/Wiki/Connecting_and_configuring_fans#Section_Using_12V_fans_when_VIN_is_24V. Or buy 24V fans, they don't cost much.



  • Ok, I'll buy new fans 🙂

    Jogging works ok.
    Sould the endstop light be off when triggered or on? Mine are constantly lit, and going off whe they're triggered. I've tried to flip tem in configurator tool, and they're stil not working.
    Is there any additional steps to enable sensorless homing apart from setting this in config?



  • Homing is not working.
    No matter if I set NO or NC, or use stall detection. It just keeps banging head against the frame
    Ok, I have this sorted: my printer now homes perfectly!

    @dc42 Another question:
    Is there a way to use Z sensor that close circuit between bed and nozzle on specific points ( 4 corners and in the middle of front and back)?

    Old board had this semi-automatic bed leveling, where it was positioning itself over the corners of the build plate and flashed RGBW LED's when nozzle was touching the bed.
    It would be nice to have this in Duet, also, is there a way to control RGB LED's?


  • administrators

    @ov_darkness said in Problems with adapting Duet to 3D Kreator Motion 3D printer:

    Sould the endstop light be off when triggered or on? Mine are constantly lit, and going off whe they're triggered. I've tried to flip tem in configurator tool, and they're stil not working.

    That's normal if you are using NC switches, which is the recommended way of using microswitches. Use S1 in the M574 command in config.g. That's S1 in the M574 command in config.g.

    Test the endstops as described at https://duet3d.dozuki.com/Wiki/Connecting_endstop_switches#Section_Test_endstop_switches.

    Is there a way to use Z sensor that close circuit between bed and nozzle on specific points ( 4 corners and in the middle of front and back)?

    Yes, that's possible. connect the two contacts to the two outer pins of the E0 endstop input. In your M558 command select mode 4 (P4) and also use the I1 parameter.



  • @dc42
    I've found a while to work on this project, but documentation is somewhat unclear to me and I don;t want to damage my Duet.
    If I read this right I need to remove V_FAN jumper, then connect DC-DC converter IN to always on fan output (so I lose one out).
    then I need to connect DC-DC V_OUT to middle pin of V_FAN and leave the GND_OUT unconnected as this is common negative?

    Can I use 24V out from my PSU instead of always on Fan?


  • administrators

    @ov_darkness said in Problems with adapting Duet to 3D Kreator Motion 3D printer:

    Can I use 24V out from my PSU instead of always on Fan?

    Yes, in fact that's the correct way to do it.



  • Printer works as expected 🙂
    Thank you for your help @dc42
    Soon I'll be putting together much bigger and faster machine with Duet.
    It'll be heated chamber COREXY.



  • @dc42
    I have problems using G32.
    I keep gettion [code]G32
    Error: G29: No valid grid defined for bed probing[/code]
    My bed.g file looks like that:
    [code]
    ; bed.g
    ; called to perform automatic bed compensation via G32
    ;
    ; generated by RepRapFirmware Configuration Tool on Sun Nov 25 2018 14:50:03 GMT+0100 (czas środkowoeuropejski standardowy)
    M561 ; clear any bed transform
    G28 ; home all axes
    G90 ; Back to absolute positioning

    ; Probe the bed at 6 points
    G30 P0 X2 Y1 H0 Z-99999
    G30 P1 X100 Y1 H0 Z-99999
    G30 P2 X195 Y1 H0 z-99999
    G30 P3 X195 Y195 H0 Z-99999
    G30 P4 X100 Y195 H0 Z-99999
    G30 P5 X2 Y195 H0 Z-99999

    G29 S0 ;Probe the bed and save height map to file
    M374 ; Save calibration data. Default is sys/heightmap.csv
    [/code]
    and my heightmap.csv is empty.



  • Do you have an m557 command in config.g to define your grid to probe?


  • administrators

    Your bed.g file probes 6 point, then does nothing with that probing and runs G29 instead. Was it really generated exactly like that by the online configuration tool? If so then we need to get that fixed.

    I suggest you edit bed.g to contain just this command:

    G29 S0 ;Probe the bed and save height map to file

    and add a M557 grid definition to config.g. See https://duet3d.dozuki.com/Wiki/Using_mesh_bed_compensation.



  • @dc42 no, it was edited by me.
    I have M557 defined in Config.g


  • administrators

    @ov_darkness said in Problems with adapting Duet to 3D Kreator Motion 3D printer:

    @dc42 no, it was edited by me.
    I have M557 defined in Config.g

    If you already have a M557 command in config.g and you are getting the "No valid grid defined" message, then that M557 command failed. Try sending exactly the same M557 command from the GCode Console to see what the error is.


Log in to reply