DWC pin (override) fan speed doesn't do anything



  • Pinned or unpinned, the fan speed changes with the g-code in the print.



  • Firmware and DWC version?

    Did it work previously?

    Which slicer?

    What does your fan setup line look like in config.g?



  • @phaedrux

    Firmware: RC3
    DWC: 1.22.4

    M106 P0 S0.0 F100 I0 H-1 L0.3 ;Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off, Minimum fan value 0.3, Speed 100%
    M106 P1 S0 I0 F100 H-1 L0.3 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned off, Minimum fan value 0.3, Speed 100%
    M106 P2 S0 I0 F100 H-1 L0.3 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned off, Minimum fan value 0.3, Speed 100%

    Slicer is slic3r,
    Fan speed for PLA is set off for first layer then 100% at the second layer and never gcoded again.

    I was printing PETG when I noticed this. I wanted the fan on, but the default behavior is for the slicer to algorithmically determine how much cooling is needed based on size of the layer, like if your printing a thin spire, you need a lot of cooling, but regularly, just a little. So with PETG, there are many fan gcodes sprinkled within the file.



  • I've noticed before that when the gcode gets sent from the file to change the fan speed when the DWC has it pinned it will briefly change, and then change back to the pinned value. Does that not happen?

    I guess you could try upgrading to the latest firmware RC and DWC and seeing if the behaviour remains.

    I'm about to start a print so I'll see if I can duplicate it.



  • Oh geez, I was wrong, it works. The buttons like 3d inversed. With the pin unselected, the button is pressed down, with the pin selected, the button is sticking up.

    Every other button-ee interface I've seen that uses buttons on that arrangement uses the down button as selected.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.