Auto sleep didn't work



  • Hi,

    I had a M81 S1 in the end Script of s3d.
    Tooked that out and added it in sleep.g

    Then, i started a Job and enabled Auto sleep.

    After the print was finished and all temp controlled Fans were off, the printer Shut not down.

    Am i missing something?



  • You have to keep your browserwindow open and running. So your PC needs to stay on, and the DWC window active (needs no focus though).



  • Oh, ok. That was the problem. Then i have to put the M81 back to the end Script of s3d.

    Thanks!


  • administrators

    @torro said in Auto sleep didn't work:

    Oh, ok. That was the problem. Then i have to put the M81 back to the end Script of s3d.

    Thanks!

    Or you can put it in stop.g, and make sure that is a M0 command at the end of your S3D end script. It's stop.g that gets run when a print finishes.



  • it makes no difference. i have to decide before the print starts, if i want a shutoff or not. isn´t there a possibility, that the duet/firmware/macro remembers the enabled auto-sleep, when i close the web interface?


  • administrators

    If you set the hot end heatsink fan to run thermostatically, then if you start a print, wait until the fan is running and then send M81 S1, it should turn the printer off at the end of the print. I suggest you also enable logging, because a heater fault could also cause the print to be terminated.



  • Ok, i'll try



  • @torro said in Auto sleep didn't work:

    isn´t there a possibility, that the duet/firmware/macro remembers the enabled auto-sleep, when i close the web interface?

    Yes it would be nice to have the webserver handle the "enable auto sleep" function instead of the DWC browser-window. If a print takes longer than I anticipated and I want to go to bed, I like to enable auto-sleep. It is not something I already decide while slicing 😉 For now, I'd rather have my PC running continuously instead of my printer.


  • administrators

    @deltacon said in Auto sleep didn't work:

    @torro said in Auto sleep didn't work:

    isn´t there a possibility, that the duet/firmware/macro remembers the enabled auto-sleep, when i close the web interface?

    Yes it would be nice to have the webserver handle the "enable auto sleep" function instead of the DWC browser-window. If a print takes longer than I anticipated and I want to go to bed, I like to enable auto-sleep. It is not something I already decide while slicing 😉 For now, I'd rather have my PC running continuously instead of my printer.

    You can do that by sending M81 S1 after the print has started and a thermostatic hot end fan is running.



  • @dc42 said in Auto sleep didn't work:

    You can do that by sending M81 S1 after the print has started and a thermostatic hot end fan is running.

    Yes, the sad truth is that I have a v0.6 Duet and have no thermostatic hotend fan...
    I have myself to blame, because I went for a 0.6 even after the WiFi came out 😉


  • administrators

    @deltacon said in Auto sleep didn't work:

    @dc42 said in Auto sleep didn't work:

    You can do that by sending M81 S1 after the print has started and a thermostatic hot end fan is running.

    Yes, the sad truth is that I have a v0.6 Duet and have no thermostatic hotend fan...
    I have myself to blame, because I went for a 0.6 even after the WiFi came out 😉

    You can pretend that you have a thermostatic fan, because the Duet 06 runs the same firmware as the 085 which has a second fan (fan 1). But you won't know for sure that your virtual thermostatic fan is running.



  • That is a brilliant idea. Maybe I will work that out some time when I have more time at hand.


Log in to reply