DuetWifi selectively not loading gcode files



  • Hi All;

    My duetwifi just started behaving this way today, it was working fine before.

    When I upload a new *.gcode file there's a 50/50 chance that the G-Code Files interface won't load the parameters of the file to let me print it. I've tried updating the firmware, web control, and server, but it hasn't fixed the issue.

    I'm slicing with simplify3d, saving to the normal gcodes folder through the web interface. Hardware diagnostics reports everything as normal, including the sdcard. I can control the machine remotely, I just can't seem to print some files(files that worked fine yesterday). It doesn't seem to correlate to the file size as I've tried varied size files and still have the same success rate. I haven't made any changes to the output of simplify3d either.

    Any idea what's going on?



  • Did you try using a different browser ?


  • administrators

    The Duet doesn't need to load the parameters of the file in order to print it, it just needs to be able to read the file. Perhaps the SD card is corrupted or on the way out?



  • I plugged the sd card into my computer and it reads fine from there. I also tried using a different sdcard in the duet, the issue seems to persist.

    It definitely looks like the board is having trouble reading, but I'm not sure it's the card that's at fault.



  • Just a quick update, it seems like the web interface for the g-code files might be the issue. Sending 'm32 filename.gcode' prints any of the files, including the ones that only show up as 'loading'. Thoughts? I've tried updating the web interface, server, and firmware to no avail.

    Trying different web browsers hasn't had an effect either (Chrome, Explorer, Firefox).


  • administrators

    Try pressing control-shift-J when a file gets stuck on Loading in case there has been an exception in DWC.



  • Looks like it, here's the error code.
    dwc.js:2 Uncaught Error: Syntax error, unrecognized expression: #table_gcode_files > tbody > tr[data-file='Ben's Test sizing1.gcode']
    at Function.ga.error (dwc.js:2)
    at ga.tokenize (dwc.js:2)
    at ga.select (dwc.js:2)
    at Function.ga [as find] (dwc.js:2)
    at r.fn.init.find (dwc.js:2)
    at r.fn.init (dwc.js:2)
    at r (dwc.js:2)
    at dwc.js:2468
    at getFileInfo (dwc.js:2116)
    at updateGCodeFiles (dwc.js:2462)


  • administrators

    Perhaps it's objecting to the single-quote in your gcode file name.



  • That was it, thanks for your time!


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.