Fallback procedure #3 = DuetWifiServen.bin not found



  • Hi,

    Out of a sudden, my new motherboard stopped connecting to the wifi. I had installed the latest firmware prior this happening.
    I tried to connect the motherboard to the PC, nothing happened.
    It turns out the SDcard failed, I tried connecting the card to PC, nothing appeared, so I spent 9€ and got me a new one.

    Now, I followed every step on Fallback Procedure #3, I downloaded SamBa,
    downloaded DuetCombinedFirmware 2.02 version, send the file to SD card via SamBa.
    Then I open YAT, hit M997 S1 command and get

    M997: File DuetWiFiServer.bin not found.

    Am I missing something here???



  • @cozyp DuetWiFiServer.bin is not in DuetCombinedFirmware.bin. It's further down this page: https://github.com/dc42/RepRapFirmware/releases



  • Okay. I grabbed the DuetWifiServer.bin file from an earlier version, removed the version and renamed it as DuetWifiServer.bin. The same error occurs.

    I tried installing an earlier version 2.01 and 2.00. Sent the CombinedFirmare.bin via SamBa, reset the motherboard, insert SD card, copy DuetWifiServer.bin file ( if the file name was had the version name, I deleted it and renamed it exactly as it is supposed to be ). I put SD card back, reset, YAT, hit M997 S1, same....

    Faulty motherboard???


  • administrators

    @cozyp, the DuetWiFiServer.bin file needs to be in the /sys folder.



  • The SD card does not have any folders, even after I send the Firmware via the SamBa. Do I need to create folders???



  • I am currently stuck. On the fallback procedure it doesn't mention anything regarding SD configuration..... It just says hit erase button, use Samba and YAT to command.....



  • OK. I downloaded the entire ZIP file from latest firmware.
    Extracted the SD image folder to SD card.
    I renamed an the folder sys - Fisher to sys.
    Copy - Pasted the Combined2Firmware and DuetWifiServer.bin.
    Hit M115, firmware installed.
    Hit M997 S1, ''not found''


  • administrators

    If you send M20, does it report that the SD card is mounted?
    If you send M503, does it echo the config.g file in /sys?



  • Magically, I changed the USB port into another one, repeated the procedure and it worked.
    I will never understand electronics.....

    Thank you for your replies DC42!!!! Will create another post on bed leveling piezo issue I was having. Hopefully, I will solve that as well!!!!


Log in to reply