IDEX Issues



  • So i've finally had chance to get the BCN3D Sigma setup and near enough working apart from one issue. I can't use the right extruder to print!

    It will move fine using G1 U30 etc… and it will home as expected.

    When i try to print with the right extruder it will extrude the filament as it's printing but it just won't move, it heats fine aswell.

    My config:

    ;;;;;; General preferences ;;;;;;
    
    M111 S0                                               ; Debugging off
    G21                                                   ; Work in millimetres
    G90                                                   ; Send absolute coordinates
    M83                                                   ; but relative extruder moves
    M555 P2                                               ; Set firmware compatibility to look like Marlin
    
    M584 Y1 E3:4 Z5 X0 U6                                 ; Driver Mappings
    
    M208 U0 X-48 Y-3 Z0 S1                                ; Min
    M208 X209 Y294 Z286 U257 S0                           ; Max
    
    ;;;;;; Endstops ;;;;;;
    
    M574 Y1 S0
    M574 Z0 S0
    M574 X1 S0
    M574 U2 S0
    M574 E1 S0
    
    M558 P5 X0 Y0 U0 Z1 H5 F120 T6000                     ; Set Z probe type
    G31 P500 X0 Y0 Z0 U0                                  ; Set Z probe trigger value, offset and trigger height
    
    ;;;;;; Drives ;;;;;;
    
    M569 P0 S0                                            ; X
    M569 P1 S1                                            ; Y
    M569 P6 S0                                            ; U
    M569 P3 S1                                            ; E0
    M569 P4 S0                                            ; E1
    M569 P5 S1                                            ; Z
    
    M350 X16 U16 Y16 Z16 E16:16 I1                        ; Configure microstepping with interpolation
    
    M92 X80 U80 Y80 Z1600 E492.45:492.45                  ; Set steps per mm
    
    M566 X600 U600 Y600 Z60 E120:120                      ; Set maximum instantaneous speed changes (mm/min)
    
    M203 X6000 U6000 Y6000 Z680 E1200;1200                ; Set maximum speeds (mm/min)
    M201 X1000 U1000 Y1000 Z1000 E250:250                 ; Set accelerations (mm/s^2)
    M906 X950 U950 Y800 Z900 E1000:1000 I30               ; Set motor currents (mA) and motor idle factor in per cent
    
    M84 S30                                               ; Set idle timeout
    
    ;;;;;; Heaters ;;;;;
    
    M143 S280                                             ; Set maximum heater temperature to 280C
    M570 S150                                             ; Set maximum heating time to 150s
    M305 P0 T100000 B4138 C0 R4700 L0 H0                  ; heater 0
    M305 P1 T100000 B4388 C0.0000000000000000 R4700 L0 H0 ; heater 1
    M305 P2 T100000 B4388 C0.0000000000000000 R4700 L0 H0 ; heater 2
    
    M307 H0 A64 C371.6 D5.6 B0
    M307 H1 A344.7 C122.8 D5.5 B0
    M307 H2 A344.7 C122.8 D5.5 B0
    
    ;;;;;; Tools ;;;;;;
    
    M563 P0 D0 H1 X0                                      ; Define tool 0
    G10 P0 X0 Y0 U0 Z0                                    ; Set tool 0 axis offsets
    G10 P0 R0 S0                                          ; Set initial tool 0 active and standby temperatures to 0C
    
    M563 P1 D1 H2 X6                                      ; Define tool 1
    G10 P1 X0 Y0 U0 Z0                                    ; Set tool 1 axis offsets
    G10 P1 R0 S0                                          ; Set initial tool 1 active and standby temperatures to 0C
    
    ;;;;;; Network ;;;;;;
    
    M550 PBCN3D Sigma                                     ; Set machine name
    M552 P0.0.0.0 S1                                      ; Enable network
    
    ;;;;;; Fans ;;;;;;
    
    M106 P0 S0.3 I0 F500 H-1 
    M106 P1 S1 I0 F500 H1 T45 
    M106 P2 S255                                          ; Board fan
    M106 P5 S255                                          ; LED
    M106 P6 S255                                          ; LED
    M106 P7 S255                                          ; LED
    
    

    Any ideas? I've had this working before on the BIG printer so i know it's something i'm doing wrong, i just can't put my finger on it.



  • My mistake was:

    M563 P1 D1 H2 X6                                      ; Define tool 1
    
    

    Should have been:

    M563 P1 D1 H2 X3                                     ; Define tool 1
    
    

    I presumed X was the drive number, not the axis number!



  • So, how is Duet working out on the Sigma?

    That printer has a lot of vibration when in full flow: can imagine you might see some improvements in print quality?



  • It's cut the noise down no end 🙂

    Prints are a lot lot better



  • This was printed at 80mms. It looks a little rough due to the glitter in the filament.



  • 😄

    well done, looks like you have yourself a dream machine!

    the standard BCN has a neat levelling setup: what are you doing for levelling now?



  • Well for the Z offsets i do it manually. It's fairly easy to do. To get the bed level i use the same method as BCN3D do by using both Z microswitches and working out the difference. It's manual in respect to working out which knob to twist but it's not a big issue.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.