DuetWifi - Duex5 expansion, BLtouch never triggers



  • I've read through a bunch of threads with people having issues getting the BLtouch to work with the Duetwifi and haven't found a solution to my specific issue. I'm running a DuetWifi with a Duex5 expansion and have wired the BL touch into the suggested 5pwm channel. When I power on the board, the red LED illuminates solid and the probe extends and retracts twice. I can extend and retract the probe with the normal M280 commands, M401 & 402 do nothing, however it always triggers as z0, never z 1000. I've swapped my wiring a few times and tried switching active high/low in the firmware, no change. I have two BLtouch probes, one with a metal pin and one newer one with plastic, they both react the same way. What am I missing here?

    Config.

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X900 Y600 Z1000 S0 ; Set axis maxima

    ; Endstops
    M574 X1 Y1 S1 ; Set active high endstops

    ; Z-Probe
    M574 Z1 S2 ; Set endstops controlled by probe
    M307 H7 A-1 C-1 D-1 ; Disable heater on PWM channel for BLTouch
    M558 P9 H5 F120 T6000 ; Set Z probe type to bltouch and the dive height + speeds
    G31 P1000 X200 Y200 Z2.5 ; Set Z probe trigger value, offset and trigger height
    M557 X150:800 Y150:500 S35 ; Define mesh grid



  • Have you seen this?

    https://duet3d.dozuki.com/Wiki/BLTouch_Troubleshooting

    https://duet3d.dozuki.com/Wiki/Connecting_a_Z_probe#Section_BLTouch

    What firmware version are you using?

    Do you have those M280 commands to deploy and retract in your deployprobe.g and retractprobe.g macros? You'll need that for M401 and 402 to work.

    Change G31 P1000 to P25

    How do you actually have it wired right now? You say PWM channel 5, but you have M307 H7 in your config. So is it pin 5 or pin 7?

    If you're using the pins for the Duex, I think you need to NOT invert the signal.

    Duet 2 WiFi/Ethernet with Duex 2 or Duex 5 expansion board
    First, you need to allocate an unused heater expansion channel to reconfigure as the servo control for the BLTouch. For example, if the E2Heat output is unused, you can use heater 3 which corresponds to the PWM1 connector.

    Connect the BLTouch as follows:

    Duet ZProbe connector pin DueXn PWM connector pin BLTouch pin Colour
    IN Out White
    GND GND Black
    +5V +5V Red
    PWM Control Orange
    GND GND Brown

    In the M280 commands (see below), you must invert the servo signal using “I1” in the M280 commands if you connect the BLTouch servo input to the expansion header pins, but not if you connect the BLTouch servo input to a Duex.



  • I do have deploy and retract commands, I think I just found the issue though. I'm running 1.19.2, I thought the board was updated to 1.2 already. I'll give that a shot.



  • @armatus 2.01 is the later full release. 1.21 is quite old at this point. 2.02 is right around the corner.



  • I've updated to what I think is all the latest settings. I've been switching the H pins between 5 and 7 to try to get proper triggering, so far I'm having the same issue. The pin now extends and retracts on M401 and 402 commands, but the Z probe sensor always says 0.

    0_1545514022805_Screen Shot 2018-12-22 at 4.20.05 PM.png

    ; Configuration file for Duet WiFi (firmware version 1.21)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2 on Sat Dec 22 2018 12:17:53 GMT-0500 (Eastern Standard Time)

    ; General preferences
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves

    ; Network
    M550 P"Zeta-1" ; Set machine name
    M552 S1 ; Enable network
    ;*** Access point is configured manually via M587
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Drives
    M569 P0 S1 ; Drive 0 goes forwards
    M569 P1 S1 ; Drive 1 goes forwards
    M569 P2 S0 ; Drive 2 goes forwards
    M569 P3 S0 ; Drive 3 goes forwards
    M569 P4 S0 ; Drive 4 goes forwards
    M569 P5 S1
    M569 P6 S1
    M569 P7 S1
    M584 X5 Y0:1 Z2:3:4 U6 E7 E8
    M350 X16 Y16 Z16 E16:16 I1 ; Configure microstepping with interpolation
    M92 X161.00 Y161.00 Z1060.00 E420.00:420.00 ; Set steps per mm
    M566 X900.00 Y900.00 Z5.00 E120.00:120.00 ; Set maximum instantaneous speed changes (mm/min)
    M203 X2000.00 Y2000.00 Z300.00 E1200.00:1200.00 ; Set maximum speeds (mm/min)
    M201 X300.00 Y300.00 Z8.00 E250.00:250.00 ; Set accelerations (mm/s^2)
    M906 X1000.00 Y1000.00 Z2000.00 E800.00:800.00 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X900 Y600 Z1000 S0 ; Set axis maxima

    ; Endstops
    M574 X1 Y1 S1 ; Set active high endstops

    ; Z-Probe
    M574 Z1 S2 ; Set endstops controlled by probe
    M307 H5 A-1 C-1 D-1 ; Disable heater on PWM channel for BLTouch
    M558 P9 H5 F120 T6000 ; Set Z probe type to bltouch and the dive height + speeds
    G31 P25 X200 Y200 Z2.5 ; Set Z probe trigger value, offset and trigger height
    M557 X150:800 Y150:500 S35 ; Define mesh grid

    ; Heaters
    M140 H-1 ; Disable heated bed
    M305 P1 T100000 B4138 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S280 ; Set temperature limit for heater 1 to 280C
    M305 P2 T100000 B4138 R4700 ; Set thermistor + ADC parameters for heater 2
    M143 H2 S280 ; Set temperature limit for heater 2 to 280C
    M307 H7 A-1 C-1 D-1

    ; Fans
    M106 P0 S0.3 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H-1 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P2 S1 I0 F500 H-1 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned off

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C
    M563 P1 D1 H2 ; Define tool 1
    G10 P1 X0 Y0 Z0 ; Set tool 1 axis offsets
    G10 P1 R0 S0 ; Set initial tool 1 active and standby temperatures to 0C

    ; Automatic saving after power loss is not enabled

    ; Custom settings are not configured

    I haven't cleaned up my wiring at the board yet, excuse the mess. I'm holding the BL touch wires.
    0_1545514243432_IMG_8615.JPG



  • It will only flash triggered on the DWC zprobe display very briefly due to the way it triggers and immediately releases, so that's not a very reliable way of testing the BLTouch.

    Does it stop the bed from moving if you go through the test procedure here: https://duet3d.dozuki.com/Wiki/Test_and_calibrate_the_Z_probe



  • Solved! I was afraid to try the live stop test when I couldn't see any readings, everything is working now. I should be doing my first print on this IDEX monster within the hour 😄

    0_1545516513330_fullsizeoutput_aaf.jpeg

    0_1545516578067_IMG_8613.JPG

    Thanks for your help!!



  • That is a monster! Take video.


  • administrators

    That's very good for a first print ☺



  • https://youtu.be/pFfbQU_8RHI
    First print!

    It's overextruding like a pig, I can't figure out why. I've turned down the extruder steps in the config, M92 E2.00 all the way from E60, seemingly not much change. First layers are alright, then it pushes much to fast for second layers and causes skips.

    My changes in the config seem to be doing nothing, the machine panel details remain unchanged
    0_1545620448392_Screen Shot 2018-12-23 at 9.56.24 PM.png



  • @armatus have you calibrated the extruder e steps?



  • I'm making progress, had to reconfigure the firmware from scratch and re-upload. I still have a lot of settings to tweak and an additional axis to wire up and get working, but I do have one nozzle printing now 🙂


Log in to reply