add second heater bed



  • hi every one
    I try to add second heater bed but I can't add the second heater bed in web interface or reading temperature
    I have pt100 and thermocouple boards: MAX31856
    I add first heat bed without any problem I can read and run the heater
    what I want to do is read the temperature from second sensor and then turn on and off each bed split the heater bed is keenovo 220/750W so I think the thermo type K
    so please help
    this is me config is Duet Web Control 2.0.0-RC2 / RepRapFirmware 2.02(RTOS)

    ; Configuration file for Duet WiFi (firmware version 1.21)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2 on Tue Dec 11 2018 13:08:00 GMT+0300 (Arabian Standard Time)

    ; General preferences
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves

    ; Network
    M550 P"My Printer" ; Set machine name
    M552 S1 ; Enable network
    ;*** Access point is configured manually via M587
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Drives
    ; M569 P0 S0 ; Drive 0 goes forwards=0 BACKWARD = 1 0==X
    ;M569 P1 S1 ; Drive 1 goes forwards=0 BACKWARD = 1 1==Y
    M569 P2 S1 ; Drive 2 goes forwards=0 BACKWARD = 1 2==Z
    M569 P3 S0 ; Drive 3 goes forwards=0 BACKWARD = 1 3==E
    M569 P4 S1
    M569 P5 R1 T2.5:2.5:5:0
    M569 P6 R1 T2.5:2.5:5:0
    M569 P7 R1 T2.5:2.5:5:0
    M569 P8 R1 T2.5:2.5:5:0

    M584 X7 Y8

    3M350 X16Y16 Z16 E16 I1 ; Configure microstepping with interpolation
    M92 X321 Y260 Z396.03 E500.00 ; Set steps per mm
    M566 X400.00 Y400.00 Z12.00 E420.00 ; Set maximum instantaneous speed changes (mm/min)
    M203 X2500.00 Y2500.00 Z1000.00 E1200.00 ; Set maximum speeds (mm/min)
    M201 X50.00 Y50.00 Z20.00 E100.00 ; Set accelerations (mm/s^2)
    M906 X1800.00 Y1800.00 Z800.00 E500.00 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X475 Y265 Z645 S0 ; Set axis maxima

    ; Endstops
    M574 X2 Y2 Z2 S0 ; Set active LOW =0 ACTIVE HIGH = 1 endstops

    ; Z-Probe
    M558 P5 H30 F120 T6000 ; Set Z probe type to switch and the dive height + speeds
    G31 P495 X0 Y0 Z30 ; Set Z probe trigger value, offset and trigger height
    M557 X15:195 Y15:195 S20 ; Define mesh grid

    ; Heaters
    M305 P0 T100000 B4138 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; Set temperature limit for heater 0 to 120C
    M305 P1 T100000 B4138 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S280 ; Set temperature limit for heater 1 to 280C
    M305 P100 T100000 B4138 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H2 S120

    ; Fans
    M106 P0 S0.3 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Automatic saving after power loss is not enabled

    ; Custom settings are not configured


  • administrators

    If heater 2 is your second bed heater, use this in config.g to enable the second bed heater:

    M140 H0:2



  • I add this line
    but still bed 2 not shown
    0_1545832169750_69.jpg



  • this the line I add
    M305 P101 T100000 B4138 R4700
    M140 H0:2 s 120


  • administrators

    I'm sorry, I gave you the wrong command. The correct command to enable the second bed heater is:

    M140 P1 H2

    P1 means bed heater 1 (the original is bed heater 0), and H2 means use heater 2 for it.

    To get it to show up in DWC I think you will need to give heater 2 a heater name in its M305 command.



  • @dc42 said in add second heater bed:

    M140 P1 H2

    witch channel is this port
    because second sensor connect with this port
    thermo type K

    0_1545834090353_69.jpg



  • I Add this code to define the Bed 2
    M305 P101 S"Bed 2 "
    but how to get thermo redding
    0_1545837044105_bed_2.jpg


  • administrators

    The channel numbers for the first MAX31856 based thermocouple interface are 150 and 151.



  • @dc42 said in add second heater bed:

    150

    I add this lines
    M305 P101 X150 S"bed_2"T100000 B4138 R4700
    M140 P101 H2 S120
    but I got on screen not correct reading

    0_1545840232776_bed_2.jpg


  • administrators

    Use P2 in the M305 command (heater 2) and P1 in the M140 command (bed heater 1).


Log in to reply