Odd Stepper Behavior



  • All,

    I have been experiencing some odd behavior from my Steppers and have run out of ideas for troubleshooting. I was hoping some of you could help.

    My machine
    Is a Seemecnc Rostock V3 (a Delta style Printer) which I have upgraded with: stepper dampers, Duet, Panel Due, FSRs, and an E3D V6 Nozzle (removed the original z probe entirely). I also put this machine in an enclosure with the top (area with Duet) open on one side and a similar thing with the bottom (where power supply is).

    Problems
    So I have been printing on this machine with few issues until the past few days. I started the machine up and tried homing it and I got a loud grinding noise from the Z axis and no motion from that axis (X and Y axis seem fine). So after plugging the Z motor in the Y driver the Z motor ran fine. Next I found and decided to just map my one Z motor to E1 since I do not use it. The Code I used to do so:

    M584 X0 Y1 Z4 E3

    Afterwards the machine homed with out issue. So next day I started the machine and homed it fine, but when I went to change out my filament (E0) the stepper made noise and jiggled back and forth some but did not move the filament. After commenting the M584 code and trying it again it worked with out issue, I tired putting the Z in its normal spot and it still acted how it did. I tried updating to 2.02 and the problem is the same.

    I do not exactly know where to go from here. I assume the issue is something with the Duet hardware or software , but I do not know what to look for. Attached is the config.g file I am using. Any help is appreciated.

    0_1546274745180_config.g

    Thanks,
    Masock


  • administrators

    It sounds as though the Z driver may have developed a fault, or possibly one of the 2 jumpers on the unused Z motor output is not making good contact. But as the issue with the extruder motor came and then went, that sounds like a bad crimp connection at the end of the motor cable, or possibly a power issue. Check that the VIN terminal block screws are still tight.



  • @dc42 Thanks for the response. I confirmed a bad crimp on the Z motor, so I believe as much as I have used the printer (before this behavior developed), I probably messed up the Z driver. However, the E motor did not have a bad crimp. In an effort to get all the information I thought helpful for troubleshooting, I probably made the issue with the E0 motor more confusing. I also confirmed the power wires were still tight.

    With the E0 motor, it worked fine before switching the Z motor to E1, but not after adding the M584 command to the Config.g file and putting the Z motor in for E1. It then worked as expect after commenting out the M584 command. I have not tried another motor in its place but with the crimps and pins being good, I believe the issue is a mistake I have made in the use of M584. I am open to that not being the case however. As far as using M584, that is the only thing I changed to try to use the E1 driver for Z. The printer was originally setup to E1 and E0 for extruders (I have not got around to experimenting with dual extrusion so I am OK with losing that possibility for now to gain a working print again). Any ideas?

    Thanks,
    Masock


  • administrators

    Now that you have fixed the bad crimp, what is/isn't working on your Duet?

    The M584 command must be put earlier in config.g than certain other commands. See the GCodes wiki page for details.



  • The Z driver is still acting how it did before. The E works with the M code commented out, but not when the M code is active. The M code is at the top of the config.g file and is only preceded by the network setup.


  • administrators

    Your new M584 command defines just one extruder driver, but you are providing parameters for two in some of the commands in config.g. For example:

    M92 E91.0:91.0 ; Set extruder steps/mm

    Change that line to: M92 E91.0

    M906 X1200 Y1200 Z1200 E1200:1200 I50 ; Set motor currents (mA) and idle current %

    Change the E parameter to: E1200

    To check for others, send:

    M98 Pconfig.g

    and watch for error messages.



  • Alright that seems to have fixed it.

    @dc42 Thanks for all your help!


Log in to reply