Issues with v1.17a+ on CoreXY



  • Hey folks,

    I'm a little baffled by what is going on, so I'm hoping you guys (dc42?) can help me.

    The printer is a scratch-built CoreXY based on the C/D-bot designs. It has a DuetWifi controller, E3D titan and v6 hotend, and runs on 12V.

    In a nutshell, with v1.17 everything was working great, but with any of the later 1.17 releases (e.g. a, b, c, d), I'm getting some very strange behavior. Going back to v1.17 always resolves the problem.

    Rather than try to explain what is happening in words, I made a video showing v1.17 and v1.17a with the same config.g, printing the same model, with the same filament, etc. The only thing I changed was the firmware version. While not included in this video, I've also run this same exact test with 1.17d and it is the same as 1.17a.

    https://youtu.be/kJTdyUmy5HM

    In the second "scene", it looks like in the curved corners of the skirt it slows way down and extrudes way too much filament. If you listen, you can hear the extruder grinding a bit as it is trying to push filament into the puddle building up in the corner. Please take a look and let me know if you see anything I've done wrong or any other tests I can try to help find the root cause.

    Again, I want to say that I did not change the config file between prints, nor did I change the model file. Here are the two files used in the video:

    Thanks!



  • There was an issue with relative versus absolute extruder coordinates with 1.17c & c+1 but 1.17d doesn't have the issue for me.


  • administrators

    Yep upgrade to 1.17d



  • @T3P3Tony:

    Yep upgrade to 1.17d

    he said he has already upgraded and tried 1.17d and its the same

    edit: side note I have a very similar printer(corexy C-bot family) and i dont have this issue but i have always used relative extruder moves never absolute.

    side note: What do you use for your bed?


  • administrators

    Sorry I missed that you had tried 1.17d

    Ok not sure how it works properly in 1.17 because from the files you posted you have your config set to relative extruder moves (M83) bit your gcode is sliced with absolute extruder moves (see the e numbers increasing).

    Try changing to M82 in your config, or at the beginning of the gcode print file.



  • @T3P3Tony:

    Sorry I missed that you had tried 1.17d

    Ok not sure how it works properly in 1.17 because from the files you posted you have your config set to relative extruder moves (M83) bit your gcode is sliced with absolute extruder moves (see the e numbers increasing).

    Try changing to M82 in your config, or at the beginning of the gcode print file.

    Thanks, I'll take a look at that.



  • Just wanted to add that I'm experiencing a similar problem, but it's no-longer as extreme as PProvost's issue.

    My setup is a CoreXY D-Bot with Titan Extruder and E3D 24v hotend. I'm currently running 1.17d but I've been having issues since I built the printer (one of the v1.16beta's was the first version I used).

    Initially I thought the problem was caused by a long bowden tube (600mm) so I moved the extruder to the gantry and now have a 60mm tube between the extruder and hotend. This change made a significant improvment, but as you can see from the photos below there's still over-extrusion at the start of each line and on sharp corners.

    Here's some examples of the problems I'm having at the moment:


    My config file: https://jakeblatchford.com/3dprinting/config.g.txt

    I don't have an example gcode file to-hand but I get the same results regardless of slicer used.


  • administrators

    That does look rather extreme. I'd like to see one of the gcode files. Are you using absolute or relative extruder coordinates?

    Try increasing the X and Y accelerations (M201) and/or enable pressure advance (M572).



  • @jakeblat. Comparing your config.g with mine (I have a coreXY but with somewhat larger build volume) the thing that really sticks out is your jerk setting for the extruder. I have E3D Titans (3 of them in fact feeding a Diamond hot end) and use 300 for instantaneous speed changes whereas yours is set to 24. Bearing in mind that it's mm/min, that seems awfully slow. Also your extruder steps per mm are vastly different - about double what one would normally use with a Titan. I'm assuming that you must be using a 0.9 degree stepper which begs the question why? Also as DC pointed out, you could try increasing X and Y accelerations which are quite a bit lower than my very heavy X and Y axes but I also note that your motor currents are set to 1 Amp so maybe the torque available is not that great? HTH
    Ian



  • @dc42 I'm using relative extruder coordinates. I've just done a test print, here's gcode file and photo of the print:

    https://jakeblatchford.com/3dprinting/xyzCalibration_cube.gcode

    Next to a red cube printed on my Duplicator i3 (stock electronics)

    I've bumped my acceleration up 1200mm/s for Z and Y axes but that doesn't appear to have made any difference.

    @deckingman

    I've increased my jerk speed for the extruder to 300, I must have set that really low at some point during my troubleshooting.

    I am using a 0.9 degree stepper motor as that's what came with the Titan Extruder (specifically a 42BYGHM208P4.5-15-X2 & 0.9deg/step as noted on http://wiki.e3d-online.com/wiki/Titan_Assembly)). I used the calculation on that wiki page to reach a value of 837 steps/mm.

    I noticed that the current for my X/Y/Z motors were set too low, I've increased them to 1428mA as the motors are rated at 1.68A.

    Here's my new config file:

    https://jakeblatchford.com/3dprinting/config-revised.g.txt

    After making the above changes I printed a new test cube and it looks identical to the first pink one. Anything else I might have missed/misconfigured?



  • Nothing is jumping out at me from your config.g file. The settings look OK - perhaps a little on the conservative side speed and acceleration wise but that's no bad thing. It might be an idea to tune the steps per mm for the extruder rather than rely on the default setting. I ended up with a setting of 405 for mine which would equate to 810 for a 0.9degree stepper (surprised that E3D supply 0..9 degree steppers TBH) but every extruder will be slightly different. Even with that, I usually run with an extrusion multiplier of 0.9 for best results. What size nozzle is it? That could have an effect too. Also, temperature. If it's too high you could expect some oozing which would explain the blobs at the start of every move as well as the bulging corners. Again, it's something that is machine specific and depends a lot on how the heat is transferred to the filament so what works well with one machine, may not work so good with another. Have you tried the same file on the other machine? If it comes out the same or similar then it might be you slicer.
    I doubt that it's anything to do with the electronics or firmware - just a case of getting the printer dialled in.



  • Hi Jake,

    Just a few thoughts, do you get any of these issues with 1.16 firmware, assuming all other variables are constant?

    What speed are you printing at?



  • At this point I do think it's something machine specific rather than a firmware issue, I definitely had some settings wrong to start with and after a lot of tweaking recent prints have been at a good quality. It's the first printer I've built so I suspect there will be mechanical issues where I've not got everything lined up perfectly. In the future I might replace the printed corner brackets with metal ones to increase the rigidity of the printer as it does shake a bit more than I'd like at the moment.

    I'm using a 0.4mm nozzle at the moment but also have a 0.6mm. In my previous tests the larger nozzle showed much more exaggerated over-extrusion at the start of each line/layer. I think this was primarily caused by a slicer setting I had enabled "Adjust printing speed for layers below x sec" which paused at the start of each layer when printing small objects.

    I've decided to leave to the extruder value at 837 for now and just tweak the multiplier in Simplify3D, I get good infill and top layers with 98% extrusion with this particular filament so it's very close.

    The only settings I change for my other printer in Simplify3D are retraction speed, retraction distance and temperature (around 20 degrees higher due to the hotend and dodgy electronics that don't maintain temperature accurately) . I think this eliminates the as a slicer issue but I will do another test print on my other printer to make sure.

    I have printed a temperature tower recently with this filament (FilaPrint Premium PLA) and I've got it set at 202 degrees. Oozing is definitely more of an issue with the E3D hotend compared to the Micro Swiss All Metal Hotend I have on my other printer, which is why I've tried to keep the temperature down.

    My printing speed is normally 40-50mm/s depending on what I'm printing, I'm usually after a reasonably good finish rather than speed.



  • @jakeblat

    A couple of suggestions to try. I use the same filament quite a bit and get good results at 190 deg C. Of course, my machine is completely different (I use a diamond hot end and a PT100 sensor) but it might be worth dropping the temperature another 10 deg C just to see if it makes a difference to your corners. Also try upping the speed. I know that goes against what most people say but I get better results at 70-80 than 40 -50 and my default "day to day" setting is 90. My theory is that if ooze is an issue, then the less time the print head "dwells" on corners and short moves, the better. May be right, may be wrong but it works for me. You could also try playing around with pressure advance (M572). I haven't had much success with it myself but that may be because I use a mixing hot end with 3 extruders. Others have reported good results though. HTH


  • administrators

    @PProvost:

    @T3P3Tony:

    Sorry I missed that you had tried 1.17d

    Ok not sure how it works properly in 1.17 because from the files you posted you have your config set to relative extruder moves (M83) bit your gcode is sliced with absolute extruder moves (see the e numbers increasing).

    Try changing to M82 in your config, or at the beginning of the gcode print file.

    Thanks, I'll take a look at that.

    Did you get this working? You are using absolute extruder coordinates, and your video using 1.17a shows exactly the problem that was fixed in 1.17d.



  • I'm seeing this same problem using firmware 1.18.1 (2017-04-09) using absolute using cura 2.5 on cartesian

    edit: NM, needed M82 in start code


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.