Cura 3.6 problems



  • Hi
    It has been a while since I tried Cura. So I wanted to give it a go but I'm gettign strange g-code when setting the printer to reprap. When I import the g-code in Cura or repetier host i looks strange and the print is cancelled after 1mm
    0_1546718484362_Cura_3.6_reprap.PNG
    I tried different models all with the same effect.
    When I set g.code flavor to Marlin the imported G-code looks fine
    Any idea what that could be?



  • Can you post the gcode in question? I've been using Cura 3.6 lately and haven't seen anything like that and I am using reprap flavour.



  • @alexlin I've seen this on Cura and Slic3r. If I recall correctly, this is thin wall detection or something of this sort. It usually happens for me when this feature is on and I'm printing something which has significantly thinner walls than the configured extrusion width.

    Either that or there's a bug with the coasting feature.



  • Hi
    I found out that NOT enabling "Relative Extrusion" fixes it.....Which is strange since we need that don't we?



  • @alexlin That is a weird problem. Can you save the whole Cura platter to an 3mf file and post it here? That will export your entire printer config, settings, model, and gcode so that we can see exactly what's going on.



  • Yes, please save the project and attach the resulting .3mf file so we can take a look. Thanks.



  • 0_1546808633192_CFFFP_Cylinder_2_20.gcode

    0_1546808750847_CFFFP_Cylinder_2_20.3mf.gcode

    Thanks in advance for the advice and time spent on it. Please remove the gcode extension from the 3mf file (cannot load 3mf files)
    Note:the image above is of the re-imported G-code in Cure.The layer view after slicing looks OK.



  • Thanks for the files. Looking at the gcode, the line segments are very short and so the required extrusion amounts are very small. Depending on resolution (steps/mm) of your extruder, it is possible that the amounts are actually less than can be resolved. I believe that RRF may recently had a fix in it's handling of very small extrusion amounts in relative extrusion mode. So perhaps using the latest RRF may solve the problem. It would also be a good idea to increase the length of line segments used in the model so that the extrusion amounts are not so small.


  • administrators

    @AlexLin, the issue that was fixed in firmware 2.02 affected relative and absolute extrusion equally. So if you are certain that just changing from relative to absolute extrusion fixed it, then I suspect a bug in Cura. Are you sure you didn't change anything else?



  • Thanks for the clarification re the bug fix, @dc42.

    Back to the OP's problem, it just looks to me that the line segments are too short (around 0.3mm typically).



  • 0_1546813917641_Screenshot_2019-01-06_22-14-15.png


  • administrators

    @burtoogle said in Cura 3.6 problems:

    Thanks for the clarification re the bug fix, @dc42.

    Back to the OP's problem, it just looks to me that the line segments are too short (around 0.3mm typically).

    Short line segments combined with low extruder steps/mm triggered the problem that was addressed in firmware 2.02. The work around in earlier firmwares was to increase microstepping.



  • This is not a duet problem. I tried to print it once and it failed. Then I imported the gcode in repetier hist and cura and saw this strange effect. So either it is a cura bug..... But people are using cura 3.6..i have used cura before... I think 3.2....so I guess I have a wrong setting...
    Or is the gcode OK but k
    Cannot repetier host and cura not visualizer relative extrusion files....... And the file is fine? It stopped print after the first infill layer... Which is where the code visualisation starts to look funky

    For now I think is I have something setup wrong or it is a cura bug and people don't set the relative extrusion option.....

    I will try the Facebook group maybe they have an answer..... I'll just keep using slic3r



  • @dc42 well I updated cura from my previous version... Sliced the cylinder and this was the result... I inticked relative extrusion, which I had set in the previous version and it looks OK....
    I will try to set up the printer profile from scratch and reset everything in Cura



  • Hi @AlexLin , what steps/mm are you using with your extruder? Thanks.



  • @burtoogle I think something like 830 per mm for my titan extruder, but that is not something the slicer cares about.....I have printed fine with Cura slices before and I still print fine with Slic3r. This is not a RRF/Duet problem. It is either a bug in Cura (behaviour of relative extrusion) or I have Cura configured wrong.
    The printer works fine, just not with files sliced by Cura 3.6 with 'relative extrusion'enabled. I see M83 in the g-code...but is doing something funky...



  • @alexlin, that's understood. Well, I'll take another look at the gcode and see if I can spot what's going wrong.



  • I found the problem, the pause at height script is leaving the extruder in absolute mode.



  • The pause at height plugin appears to unconditionally add an M82 to the end of the script. That's a bug!



  • @burtoogle O sh*t I must have used that once a long time before and it survived the upgrade to 3.6. I will disable it and see whether that works and report it as a bug to Cura/plugin. Thank you very much for your efforts!Greatly appreciated!


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.