strange artefacts on the surface - delta kinematic [solved]



  • Hi guys,

    I'm at the point not to know what I can do next to get rid of the following problem:

    0_1546854852055_IMG_20190107_103044.jpg

    As you can see I have this strange artefacts on the surface in x and y direction. Maybe some knows what to do.

    My latest setup:

    • delta printer
    • 0.9° motors
    • bondtech extruder
    • very high quality pulleys and smooth idler pulleys and belts (HTD 3m from Maedler Germany)
    • running at 24V
    • original Hiwin linear rails
    • precision piezo bed leveling sensor

    What I tried:

    • varying speed, jerks and accelerations settings
    • tried different layer hights
    • tried other belt tensions
    • changed extruder to titan
    • tried other extruder microstepping
    • tried other axis micorstepping
    • run auto pid tuning for bed and extruder
    • calibrate non linear extrusion
    • calibrate pressure advance
    • changed belts and pulleys from GT2 6mm width to 9mm width and then to HTD 3M
    • tried other filaments
    • checked if bed or joints are loose

    I'm very into 3d printing and I think I know what I do but now I am at a point where I do not have any other ideas. It is not my first delta printer.

    I'm not shure if it is a hardware or a software/electrical problem. At this moment I guess I have these problem since the 2.0x firmware update. The prints before doesn't have these artifacts, only the normal small ones which comes from the delta kinematic.

    I'm grateful for every tip!!

    Best regards
    Cai!


  • administrators

    If you think that artefacts only happened after the firmware update, please can you test using firmware 2.0, 2.01 and 2.02 to see which is the first version that has this problem. There was a bug fix in firmware 2.02 that affects extrusion, so it's not impossible that the artefacts you see are a consequence of that.

    What layer height are you using? It's usually best to choose a multiple of the full step distance. This will be 0.1mm if you are using 20-tooth pulleys, or 0.08mm if you use 16-tooth pulleys - although my delta uses 16-tooth pulleys and I find that 0.2mm works well.



  • It does not depend on the firmware version. I did print the same gcode with 2.0, 2.01, 2.02 and all look the same and all does have these artifacts. I used a layer height of 0.24mm. Is that correct when I am using 14 teeth htd 3m pulley?

    Here is my config.g, maybe there is something wrong.

    0_1546867397765_config.g

    Best regards and thanks for the help so far

    Cai



  • I'm not sure if it matters, but you seem to have a lot of extra spaces in some of your commands.

    M350	X16	Y16	Z16		I1				; Configure microstepping with interpolation for axis
    M350				E32	I0				; Configure microstepping with interpolation for extruder
    M92				E1630					; Set steps per mm for extruder 825
    

    Actually, all of your spacing looks a little strange, are you using tabs instead of spaces? Or is it just multiple spaces in places?



  • @phaedrux
    I'm using tabs, but with the new dwc it doesn't work anymore. For me it looks more clean.


  • administrators

    Does the pitch of the Z banding relate to any physical properties of your machine, for example a whole motor revolution, or 4 full steps of a motor?

    Does the horizontal pitch of the diagonal banding relate to anything ni the extruder, for example a whole revolution of the motor, or a whole revolution of the hobbed gear?

    I don't think it's a firmware issue, but to make sure, you could try reverting to the firmware you were running before these artefacts started appearing.



  • @dc42

    I'm pretty shure you're right. In 1 out of 10 cases it's not an hardware related problem. I will print some pulleys and idler pulleys just to see if that change the pattern of the artifacts. I drilled the hole thrue the pulleys by myself and that is not the best way.

    BTW is there a known internet shop where I can buy HTD Pulleys with a hole of 5mm? My dealer could drill the holes but that is 180€ without taxes for 6 pulleys 😞





  • I changed the idler pulleys to printed ones and as aspected, the artifact are less visible and look different. So I have to change the pulleys. They have a wobble. Thanks guys, I will try the ones from robotdigg.


Log in to reply