Improving Mesh Bed leveling with smart effector



  • As everyone is aware, the smart effector highjacks the power from the Hotend Fan, which I find a good idea. However, if it runs at 100% vibrations or sensitivity increase to such an extent that I do not get a reliable mesh bed leveling heightmap, as the probe triggers early even tough the recover time is set to 0.4.

    Of course there is the possibility for adjusting the recovery time, however I do not see how this will effect the smart effector triggering the z probe signal in the uppermost position, if I am understanding correctly.

    So there are really just two options:
    A) Decrease sensitivity (eg.M672 S105:60:195)
    or
    B) Lower the speed of the fan. (eg.M106 P1 S0.3 I0 F500 H1 T45)

    My first question is which one is the way to go. Is it wise to lower the sensitivity? Or will i just reduce precision in the long run as well as increase nozzle and bed wear.

    Or is it better to reduce the speed of the hotend cooling (fan0 i think it was) fan? I know this is playing with fire as heat unavoidably creeps up the Aluminium-Cooler, but with manually overriding the speed, mine has always survived that short period it needs to probe the bed (195C-250C).

    Last but not least: The "bed.g" allows for easily manipulating the "Auto Delta Calibration". Is there a way to adjust the G29, Mesh Bed Leveling the same way? In this case I would just temporarily lower the fan speed and set it back to normal afterwards.

    Would be great to hear everyone's thoughts... and maybe a verdict by David as well! 😉


  • administrators

    My immediate thought is that your hot end fan is generating too much vibration, or it is generating a magnetic field that is interfering with the strain gauge amplifier. The E3D hot end fan doesn't normally cause these problems, so are you using a different fan?

    Check that the fan wires are not running close to the components on the Smart Effector.



  • Hi David!

    Yes I am using a different Fan. I switched to a 24V one. It was hard to find an appropriate one that size and have settled for a "3D sway -. DC Brushless Fam - Model: JD3010M24 - DC24 0.12A".

    Is there a better choice you would suggest instead? I was looking for a long time solution compared to using a 12V at half power.

    Nevertheless: I was trying to figure out whether I can input a gcode after the G29?



  • Instead of calling G29 directly, using a Marco could be an option where you lower fan speed, do the G29, go back to full speed.... just an idea.

    You can also do a retract of the filament if you want to feel safer while the bed is probed.
    Reason for the fan (please correct me if I'm wrong) it to ensure that the filament does not melt in the upper part, but in the hotend itself


  • administrators

    @deltasquare said in Improving Mesh Bed leveling with smart effector:

    Yes I am using a different Fan. I switched to a 24V one. It was hard to find an appropriate one that size and have settled for a "3D sway -. DC Brushless Fam - Model: JD3010M24 - DC24 0.12A".

    Maybe you should buy a 30mm 24V fan from E3D or one of their distributors. I use it on my Smart Effector and it doesn't cause any problems. I've kept the fan wires away from the strain gauge PCB.



  • @crynool That is correct! Retracting the filament can solve the problem.
    However, I have had a couple of situations when the retraction was over 6mm and than jammed inside the hotend (yes its a legit e3d), so I avoid to do more retract than 6mm. But this does not get the filament out of harms way and it may expand and therefore block the coolerblock. Last but not least, I want to avoid not cooling the cooler block for the time of the probing, as I already had the problem of a failed fan at the HE resulting in magic smoke at the effector...

    However the alternative with the script sounds feasable. Thank you.
    Is there a way that I can make the web-surface point towards the script instead of the command directly? I suppose the button just runs a script anyway.


  • administrators

    If the problem occurs only while the fan is powered (not when it is spinning down), you could try setting Z probe type P9 in your M558 command, as if you were using a bltouch. That will cause the firmware to run deployprobe.g and retractprobe.g for each individual probe move. You could turn the fan off in deployprobe.g and on again in retractprobe.g.

    The Smart Effector only "hijacks the fan power" to power the illumination LEDs.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.