Start Gcode



  • Hi all:

    With your generous help I have my Duet 2 Wifi working (Mostly) on my Tronxy X5SA 3D printer.

    I'm running my first new part now.

    I need to tweak my start code a bit so that it auto lowers my print bed before heating the bed and nozzle. Also my bed leveling isn't working.

    I've set up bed leveling in bed.g and tried to call it up from my start gcode. Here's a snippet.

    I'm using Simplify3D.

    Home all did work though.

    Any ideas?

    G90
    M82
    M106 S0
    M140 S60
    M190 S60
    M104 S190 T0
    M109 S190 T0
    M98 P/MACROS/HOMEALL.G
    ;G28 ;Home
    M98 P/MACROS/BED.G
    ;G29 ;auto level
    G1 Z15.0 F6000 ;Move the platform down 15mm
    ;Prime the extruder
    G92 E0
    G1 F200 E3
    G92 E0



  • Found the problem, and it was my mistake.

    I didn't need the path to the macros. Just:
    M98 P<macro_name>

    I just restarted a print which filed, and the start gcode worked perfectly.



  • You don't even need to use M98 to call those macros. Bed.g in the sys folder is called by G32, and homeall.g in the sys folder is called by G28.



  • @phaedrux

    Sweet. I'll make those changes.

    I'm on my second print now.

    My first print using PLA was successful but very stringy.

    I was printing with the bed at 60c and the nozzle at 190c. Typical cooling fan settings, retraction distance of 1mm.

    My printer has a bowden style extruder so on the second print I've set retraction to 2mm to see if that helps, and raised the nozzle temperature to 200c.

    I need to tune up my nozzle heating, it's slower than the software likes and often errors out due to taking too long to reach set temperature. I'll do that after the current print, likely not until tomorrow though since I've been working on this with only a few breaks for over ten hours today.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.