Probe does not work with 2.02a + DWC 2.0.0 RC3



  • Today I upgraded my Duet Wifi from 1.22 RCx (I believe it was RC3) to 1.22 and switched to DWC 2.0.0 RC3.

    I use a capacitive probe which alway worked for bed leveling. Now suddenly my probe does not work any more.

    The probe triggers (LED turns on) and the board recognizes it as well (LED on the board turns on too).
    DWC shows 0 for the Z-Probe and G29 crashes into the bed.

    Have not found anything in the upgrade notes that would explain this.
    Help would be appreciated. Thx!



  • Any reason why you've not moved to the 2.something firmware?



  • Is the WifiServer now on the 1.22 (which was released very recently), or is it the main RepRapFirmware that is now only on 1.22 (which is currently stable at 2.02)? DWC2.0.0 RC 3 should not be compatible with anything earlier that RRF2.02.



  • Oh my, just realize this now... I mixed some numbers.

    Firmware is 2.02(a) including WifiServer 1.22
    DWC is 2.0.0 RC3

    Sorry for the confusion. The problem persists.

    This is really strange. I did not make any changes to the hardware.



  • Does the probe work for homing the printer?



  • I don't use the probe for homing.


  • administrators

    Please share your config.g file and tell us how you connected the capacitive sensor to the Duet.



  • It's connected to E0 Stop. Here is the config.g:

    ; General preferences
    M111 S0                                   	; Debugging off
    G21                                       	; Work in millimetres
    G90                                       	; Send absolute coordinates...
    M83                                       	; ...but relative extruder moves
    M555 P2                                   	; Set firmware compatibility to look like Marlin
    ; Automatic saving after power loss is not enabled
    
    M667 S0                                   	; Select CoreXY mode: Cartesian
    M208 X-26 Y-18 Z0 S1               		; Set axis minima (E3D V6)
    M208 X225 Y210 Z230 S0				; Set axis maxima (E3D V6)
    
    ; Endstops and Probe
    M574 X1 Y1 Z1 S1                    		; Set active high endstops (original end stops)
    M558 P4 B1 H3 F120 T6000 I1               	; Set Z probe type to switch and the dive height + speeds (inversed)
    G31 P600 X-40 Y0 Z2.43                		; Set Z probe trigger value, offset and trigger height (left side probe with E3D V6)
    M557 X20:177 Y20:177 S78.5                  	; Define mesh grid (left side probe with E3D V6)
    
    ; Map Drives
    M584 X0 Y1 Z2:4 E3				; X:0, Y:1, Z:2+4, E:3
    
    ; Drives
    M569 P0 S1                                	; Drive 0 (X) goes forwards
    M569 P1 S1                                	; Drive 1 (Y) goes forwards
    M569 P2 S0                                	; Drive 2 (Z1/U) goes backwards
    M569 P3 S0                                	; Drive 3 (E) goes backwards (Bowden)
    M569 P4 S0                                	; Drive 4 (Z2/V) goes backwards
    
    M350 X16 Y16 Z16 E16 I1           		; Configure microstepping (interpolated)
    M92 X100 Y100 Z400 E100         		; Set steps per mm (interpoloated)
    M566 X1200 Y1200 Z18 E1200          		; Set maximum instantaneous speed changes (mm/min) (Jerk)
    M201 X3000 Y3000 Z100 E30000  			; Set MAX accelerations (mm/s^2)
    M203 X48000 Y48000 Z480 E3000     		; Set maximum speeds (feedrate) (mm/min)
    M204 P800 T1000                         	; Set accelerations for print and travel moves (mm/s^2) <- faster
    M906 X850 Y850 Z850 E850 I30    		; Set motor currents (mA) and motor idle factor in per cent
    M84 S60                                   	; Set idle timeout
    
    ; Pressure Advance
    M572 D0 S0.4                            	; Set pressure advance
    
    ; Heaters
    M305 P0 T100000 B4138 C0 R4700            	; Set thermistor + ADC parameters for heater 0 (Bed)
    M143 H0 S120                              	; Set temperature limit for heater 0 to 120C
    M305 P1 T100000 B3950 C0 R4700 			; Set thermistor + ADC parameters for heater 1 (E3D V6 - 3D Freunde)
    M143 H1 S280                              	; Set temperature limit for heater 1 to 280C
    
    ; Tools
    M563 P0 D0 H1                             	; Define tool 0
    G10 P0 X0 Y0 Z0                    		; Set tool 0 axis offsets
    G10 P0 R0 S0                              	; Set initial tool 0 active and standby temperatures to 0C
    
    ; Network
    M550 PAnet A8 Test                        	; Set machine name
    M552 S1                                   	; Enable network
    M587 S"GarMir" P"XXXXXXX" I192.168.0.70  	; Configure access point.
    M586 P0 S1                                	; Enable HTTP
    M586 P1 S1                                	; Enable FTP
    M586 P2 S0                                	; Disable Telnet
    
    ; Fans
    M106 P0 S0 I0 F500 H-1                    	; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45                 	; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P2 S1 I0 F500 H1 T45                 	; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on
    
    ; CPU Temperature Calibration
    M912 P0 S-16.5
    
    ; Load saved Settings
    M501                                      	; Load config-override.g 
    


  • Your trigger height is very high. You should home z with the probe and (G92 Z0) in order to resolve that.

    What happens when you put the probe over the bed at some point and send "G30 S-1"?



  • @gpetropoulos The trigger height is so high because the nozzle is below bed level when homed. I home Z next to the bed using an endstop, then lift the nozzle up and calibrate using this high dive height. Worked for about one year.
    I will test this tomorrow.



  • @garv3 how did you obtain the trigger height?



  • Oh, you were talking about the trigger height - not the dive height. Believe me, the trigger height is perfect.
    This is not an issue at all. The problem is that the probe triggers (I can see the LEDs on the probe and the PCB light up) but G29 ignores it and does not stop moving down.
    G30 S-1 crashed into the bed as well! LEDs light up but Z keeps moving down.
    Btw: G31 always reports 0 - no matter if the probe is active or not.



  • Went back to:
    Firmware Version: 2.02RC2(RTOS) (2018-09-07b2)
    WiFi Server Version: 1.22
    Web Interface Version: 1.22.3
    => Bed leveling works just fine!

    So this has to be a firmware issue ☹


  • administrators

    1. Please check that you don't have any other M558 commands anywhere, for example elsewhere in config.g, config-override.g. or homing files.

    2. With firmware 2.02 running, send M558 without parameters. Check that it reports probe type 4 and input 3.

    3. Then do the static test described at https://duet3d.dozuki.com/Wiki/Test_and_calibrate_the_Z_probe#Section_Static_test_of_the_Z_probe. [I guess you've already done that because you reported "G31 always reports 0 - no matter if the probe is active or not."]


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.