USB only power; no ports connect; odd voltage readings



  • Hello,

    I'm having a problem with a new, out of the box Duet 2 Wifi, v1.04 board. Basically, I can't connect via USB. I've tried multiple USB cable, two windows machines (10 & 7), and a linux machine. None recognize that the Duet is plugged in to USB. No components (except USB) are connected. I was trying to do a 1st time Wifi setup, but couldn't talk to the board at all.

    Both the 5V LED and 3.3V LED are lit. The Vin LED is dark. Nothing but USB connector is plugged into board.

    Checking the voltages, I got 3.3 V on 3.3; 4.3 on 5V, and (surprisingly!) 1.7V on Vin at the green terminal connector.

    No parts feel like they are getting hot. Processor and wifi are above room temp, but not hot--can leave my finger on them indefinitely.

    Can anybody help me or does the board have to be exchanged?

    Thanks!



  • Have you tried a different USB cable?


  • administrators

    When you connected to the Windows machines, did you check that in Device Manager the Duet didn't show up either under Ports - COM & LPT, or as an Unknown Device? If so then it sounds to me that you've done all the right things, and your Duet is either faulty or it doesn't have any firmware loaded. Either way, if it's a genuine Duet, please ask your supplier to exchange it. Or you could erasing the firmware to see if the Bossa port appears - see https://duet3d.dozuki.com/Wiki/What_to_do_if_your_Duet_won't_respond.

    The 1.7V reading on VIN is probably the result of the 3.3V supply back-feeding to VIN through the voltage sense resistor, so nothing to worry about.



  • @mudcruzr Yes. Tried 3 different ones.



  • @dc42 Yes. It does not show up at all (no COM or LPT ports at all on one machine--even when 'hidden' devices were enabled to be shown.) Also no unknown devices on either machine.

    I was hoping to avoid erasing the firmware... but since the 1.7v looks to be back-feeding... I'll give it a try. Thanks for you help.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.