IR Probe and the Fan !?!



  • Currently i have two issues that are probably related.
    The first one is related to the IR sample. After the printer was set up and adjusted, I installed the fan for the components.
    Since my IR Probe still works conditionally. I must switch on the fan first after switching on the printer, only then the IR probe flashes and is activated. If I do not do that, the Hotend goes to bed because the IR does not respond. When restarting the same.
    The second problem is Auto Mesh Bed Compensation, where at the end no graphic but an error message is displayed.
    0_1547825956879_Fehlermeldung Mesh Bed.jpg


  • administrators

    @michael-suberg said in IR Probe and the Fan !?!:

    The first one is related to the IR sample. After the printer was set up and adjusted, I installed the fan for the components.
    Since my IR Probe still works conditionally. I must switch on the fan first after switching on the printer, only then the IR probe flashes and is activated.

    That's a very odd problem, and I can only think that the cause is a short circuit or a wiring error. Make sure that the fan wires and the IR sensor wires are completely separate from each other, and the back of the IR sensor cannot short against anything behind it. See the fitting instructions for how to insulate it if the IR sensor is fitted just in front of the heater block.

    The second problem is Auto Mesh Bed Compensation, where at the end no graphic but an error message is displayed.

    Are you able to use the "View height map" function of DWC, or does that give the same error?



  • I'll check the mosfets, I can rule out a short circuit, because the fans have been working for a while.
    I have looked at the datasheet of the Mosfets, these only go up to 30V, but when the fans are switched off, voltages above 24V (My supply voltage) can occur.
    Maybe that's the cause?

    When i use the height map, there is the same problem


  • administrators

    Apart from the DWC message, are there any messages to suggest the the G29 mesh probing failed? If you reload the web interface, are there any error messages in the GCode Console?



  • There are no messages in the GCode Console after rebooting



  • Can anybody help me further???


  • administrators

    Please post photos of how the IR sensor is mounted and wires to the Duet. Also check that the soldering of the 3 terminals pins on the back of the IR sensor is complete. I suspect a break in the VCC or GND connection to the IR sensor.



  • Found a mistake. This only occurs with my ubuntu 16.10 notebook.
    With the phone and windows pc crashes and can show everything.
    The wiring and solder joints are great.


  • administrators

    @michael-suberg said in IR Probe and the Fan !?!:

    Found a mistake. This only occurs with my ubuntu 16.10 notebook.
    With the phone and windows pc crashes and can show everything.
    The wiring and solder joints are great.

    Did you mean "With the phone and windows pc no crashes and can show everything."?



  • @dc42
    Yes, with Windows PC and my Iphone it works well. Mesh Bed works well


  • administrators

    May I mark this as solved then?



  • @dc42 said in IR Probe and the Fan !?!:

    May I mark this as solved then?

    Yes gladly


Log in to reply