Finally setting up print cooling fan



  • I don't print a lot of PLA, but I decided to put a print cooling fan on my coreXY machine just in case.

    I have the print cooler plugged into the fan0 port, and it's configured as P0 (M106 P0 S1 I0 F500 H-1), and I can control it using M106 P0 Sxxx just fine via DWC.

    When I use Slic3r to slice with auto cooling enabled, the gcode contains "M106 Sxxx" statements without the P0 designator, and would presumably default to P0, but it isn't working. If I just send M106 Sxxx (the same as the Slic3r statements) via the DWC the fan does nothing.

    Any ideas?

    Thanks!



  • @mrehorstdmd That's odd. Your set up is almost identical to mine - the only difference is that I use a different "F" value but that won't be relevant. M106 Snnn (without any "P" parameter) works fine for me - both in Slic3R gcode files and from DWC. I guess that is a bit like a Microsoft answer - factually true but singularly unhelpful ☺

    Long shot but have you by any chance got anything in your tool definition (M563) that re-maps some other fan?



  • Change notes for 2.02 have the following

    • Previously, you could omit the P0 parameter when configuring fan 0. The P0 parameter is now compulsory when configuring fan 0. The only parameters now recognised in M106 commands with no P parameter are S and R.

    May want to check your config to ensure you call out the P0 when setting the initial values.

    Also as deckingman says you may need to check M563 to bind fan0 to your tool. Because the g-code from Slic3r does not include the P0 parameter the M106 will default to whatever fans you have mapped to the tool. It should default to 0 anyway but doesn't hurt to make it explicit.



  • That was it. I had F2 in the M563 statement for some reason. Thanks!


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.