Keep Hotend off until AFTER Bltouch finishes bed leveling?



  • Hi I'm just wondering as I'm one of those people that like to to a bed level before every print (I know it's not needed but :P) In Marlin for example I can do something like this:

    G28 ; home all axes
    M104 S0 ; set nozzle to ensure 0 temp while auto bed leveling
    M140 S[first_layer_bed_temperature] ; set bed temp
    M190 S[first_layer_bed_temperature] ; wait for bed temp
    M104 S0 ; set nozzle to ensure 0 temp while auto bed leveling
    G4 S60 ; Dwell for 60 seconds or 1 minute to ensure bed gets evenly heated
    G28
    G29 ; auto bed leveling (It would be G32 for Duet Wifi I believe can't remember right now)
    G1 Z5 F300 ; lift nozzle
    M104 S[first_layer_temperature] ; set extruder temp
    M109 S[first_layer_temperature] ; wait for extruder temp
    G1 Z0.3 X1 Y1 F6000 ; move to prime position

    I'm using Simplify3d for my 1st HEVO and am wondering would this above code also work for my HEVO? I found out what was causing the issue with my Bltouch randomly "detect" the bed and it was the heater cartridge was literally like 3mm from the bltouch wires or closer which would cause obvious interference I've moved it away but would also like to turn nozzle off (NOT the bed) while bed leveling to prevent any more interference. But yeah would the above code work? Thanks!



  • @iamthebest22 You can modify your M558 command in config.g to include B1 to disable the heaters while doing a probing move. That should cut down on any electrical interference. It will re-enable them as soon as the probe move is complete to get back to temp.



  • Hi Phaedrux thanks for the response, the problem is B1 turns off the BED, I want the Bed to be at printing temp (60 to 80C) and the NOZZLE/Hotend be the one that's off until ABL finishes, at least if I didn't read the wiki wrong:

    Bn If 1, turn off bed heater while probing, default (B0) leaves heater on. (RepRapFirmware 1.21 and later)



  • That's right, but it only turns it off for the brief moment that the probing move is being carried out, a couple seconds at most, before turning back on and regaining temp.



  • OHHH I see what you mean so I misread it, so basically the moment it goes to probe, it turns off both the bed and nozzle so no interference , and then back on when it's moving to the next point, then off just before probe, and rinse and repeat, correct? wow that's great then so my current M558 is this:

    M558 P5 X0 Y0 Z1 H5 F100 T2000 ; Set Z probe type to unmodulated, the axes for which it is used and the probe + travel speeds

    would I just change it to
    M558 P5 X0 Y0 Z1 H5 F100 T2000 B1 ; Set Z probe type to unmodulated, the axes for which it is used and the probe + travel speeds

    like that?

    EDIT: there's a problem though, that's for firmware 1.21 and after, I'm still on 1.19 and don't want to update just yet in case anything happens, is there another way ?



  • That's right.

    You can also remove the X Y Z values from M558, since they are deprecated in recent firmware releases. The endstop configuration takes care of identifying you have a probe now.



  • yeah I just realized the problem that's for firmware 1.21 and after, I'm still on 1.19 and don't want to update just yet in case anything happens, is there another way ?



  • I think you should make a backup of your configs, read the release notes, and upgrade to 1.21 and then to 2.02. 😉



  • Your slicer start code should still work though.



  • Oh okay so my slicer start code will still work? Cause while it's not my only printer (I have quite a few) but this is my really high quality printer 😄 so I will update it for sure just gonna have to wait until the Spring Break (I'm a teacher full time and 3d printer is my part time/hobby) so if anything goes wrong I can have time to fix it immediately.

    Thanks Phaedrux, so I'll try the starting gcode I've posted as a temporary measure until I upgrade firmware.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.