Calibrate Z probe Trigger Height



  • The gap is too high when the print starts.

    I'm attempting another print now but it sounds like something just went horribly wrong, let me check. Yeah, the job failed. The nozzle height was too high.

    I just cleaned up the mess, no biggy, took less than a minute.

    I ran homed all three axis and ran G30 and got 1000.

    I don't claim my g files are great but here they are.

    Config.g

    ; Configuration file for Duet WiFi (firmware version 1.17 to 1.19)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2 on Thu Jan 10 2019 19:12:59 GMT-0800 (Pacific Standard Time)

    ; General preferences
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves

    M667 S1 ; Select CoreXY mode

    ; Network
    M550 P"Tronxy X5SA" ; Set machine name
    M552 S1 ; Enable network

    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Drives
    M569 P0 S1 ; Drive 0 goes forwards
    M569 P1 S1 ; Drive 1 goes forwards
    M569 P2 S0 ; Drive 2 goes backwards
    M569 P3 S0 ; Drive 3 goes backwards
    M350 X16 Y16 Z16 E16 I1 ; Configure microstepping with interpolation
    M92 X80.00 Y80.00 Z400.00 E98.00 ; Set steps per mm
    M566 X600.00 Y600.00 Z12.00 E120.00 ; Set maximum instantaneous speed changes (mm/min)
    M203 X9000.00 Y9000.00 Z180.00 E1500.00 ; Set maximum speeds (mm/min)
    M201 X3000.00 Y3000.00 Z100.00 E10000.00 ; Set accelerations (mm/s^2)
    M906 X1100.00 Y1100.00 Z950.00 E1150.00 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X330 Y330 Z400 S0 ; Set axis maxima

    ; Endstops
    ; M574 X1 Y1 Z0 S0 ; Set active high and disabled endstops remmed by JAD 1/10/2019
    M574 X1 Y1 S0 ; Set active high X and Y
    M574 Z1 S2 ; Set Z active high Z probe

    ; Z-Probe
    M558 P5 X0 Y0 Z0 H5 F120 T6000 A1 I1 ; Set Z probe type to switch, the axes for which it is used and the dive height + speeds Modified by JAD 1/10/2019
    ;G31 P500 X-30 Y-20 Z0.31 ; Set Z probe trigger value, offset and trigger height z0.05 should be height in mm above bed.
    G31 P500 X-30 Y-20 Z0.645 ; Set Z probe trigger value, offset and trigger height jad 1/12/2019 z should be height above bed.

    ;M557 X15:315 Y15:315 S36 ; Define mesh grid

    ; Heaters
    M305 P0 T100000 B4138 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S100 ; Set temperature limit for heater 0 to 100C
    M305 P1 T100000 B4138 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S260 ; Set temperature limit for heater 1 to 260C

    ; Fans
    M106 P0 S0 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P2 S1 I0 F500 H1:0 T30 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Custom settings are not configured

    M501 ; read eeprom parameters

    homex.g

    ; homex.g
    ; called to home the X axis
    ;
    ; generated by RepRapFirmware Configuration Tool v2 on Thu Jan 10 2019 19:13:00 GMT-0800 (Pacific Standard Time)
    G91 ; relative positioning
    G1 Z5 F6000 S2 ; lift Z relative to current position
    G1 S1 X-335 F1800 ; move quickly to X axis endstop and stop there (first pass)
    G1 X5 F6000 ; go back a few mm
    G1 S1 X-335 F360 ; move slowly to X axis endstop once more (second pass)
    G1 Z-5 F6000 S2 ; lower Z again
    G90 ; absolute positioning

    Homey.g

    ; homey.g
    ; called to home the Y axis
    ;
    ; generated by RepRapFirmware Configuration Tool v2 on Thu Jan 10 2019 19:13:00 GMT-0800 (Pacific Standard Time)
    G91 ; relative positioning
    G1 Z5 F6000 S2 ; lift Z relative to current position
    G1 S1 Y-335 F1800 ; move quickly to Y axis endstop and stop there (first pass)
    G1 Y5 F6000 ; go back a few mm
    G1 S1 Y-335 F360 ; move slowly to Y axis endstop once more (second pass)
    G1 Z-5 F6000 S2 ; lower Z again
    G90 ; absolute positioning

    Homez.g

    ; homez.g
    ; called to home the Z axis
    ;
    ; generated by RepRapFirmware Configuration Tool v2 on Thu Jan 10 2019 19:13:00 GMT-0800 (Pacific Standard Time)
    G91 ; relative positioning
    G1 Z5 F6000 S2 ; lift Z relative to current position
    G1 X165 F3000 ; move x +165mm JAD 1/11/2019
    G1 Y165 F3000 ; move y +165mm JAD 1/11/2019
    G1 S1 Z-405 F1800 ; move bed up until the endstop is triggered

    ;G1 Z-0.25 ;try to adjust z offset jad 1/12/2019
    G92 Z0 ; set Z position to axis minimum (you may want to adjust this)

    ; Uncomment the following lines to lift Z after probing
    ;G91 ; relative positioning
    ;G1 S2 Z5 F100 ; lift Z relative to current position
    ;G90 ; absolute positioning

    Sorry, this is making this post stupid big.

    Config-override.g

    ; config-override.g file generated in response to M500 at 2019-01-17 20:01
    ; This is a system-generated file - do not edit
    ; Heater model parameters
    M307 H0 A66.5 C551.7 D4.3 S1.00 V11.6 B0
    M307 H1 A214.3 C77.4 D3.3 S1.00 V12.0 B0
    M307 H2 A340.0 C140.0 D5.5 S1.00 V0.0 B0
    M307 H3 A340.0 C140.0 D5.5 S1.00 V0.0 B0
    M307 H4 A340.0 C140.0 D5.5 S1.00 V0.0 B0
    M307 H5 A340.0 C140.0 D5.5 S1.00 V0.0 B0
    M307 H6 A340.0 C140.0 D5.5 S1.00 V0.0 B0
    M307 H7 A340.0 C140.0 D5.5 S1.00 V0.0 B0
    G10 L2 P1 X0.00 Y0.00 Z0.00
    G10 L2 P2 X0.00 Y0.00 Z0.00
    G10 L2 P3 X0.00 Y0.00 Z0.00
    G10 L2 P4 X0.00 Y0.00 Z0.00
    G10 L2 P5 X0.00 Y0.00 Z0.00
    G10 L2 P6 X0.00 Y0.00 Z0.00
    G10 L2 P7 X0.00 Y0.00 Z0.00
    G10 L2 P8 X0.00 Y0.00 Z0.00
    G10 L2 P9 X0.00 Y0.00 Z0.00

    Perhaps I need to delete the contents of this file? I think those lines are from my first attempts of setting up bed meshing.

    I just got bit by the spam filter, trying again.



  • Looks like some auto editing went on here. I'm really sorry that's going to make reading my post a chore, plus I used equal signs to show what lines were code and they were removed.

    I could upload the files if that would work better.



  • I think you missed homeall.g.

    If you click on the compose link in a reply you can see how the post markup works.

    Are you using a probe or just endstop switches?

    You homez looks like it's just using an endstop switch, in which case the g31 offset won't apply.

    So if you're using a probe to home you should use a g30 command instead of the g1 S1 z move.

    Also, are you sure your z axis steps per mm is 400? If you tell it to move 50mm does it move the right amount?



  • Sorry about missing home all

    homeall.g
    ; homeall.g
    ; called to home all axes
    ;
    ; generated by RepRapFirmware Configuration Tool v2 on Thu Jan 10 2019 19:12:59 GMT-0800 (Pacific Standard Time)
    ; remmed for testing M98 to call other axis individually

    M98 PHOMEX.G ; home x
    M98 PHOMEY.G ; home y
    M98 PHOMEZ.G ; home z

    ; Uncomment the following lines to lift Z after probing
    ;G91 ; relative positioning
    ;G1 S2 Z5 F100 ; lift Z relative to current position
    ;G90 ; absolute positioning

    I'm using just the inductive probe with no mechanical or optical limit switch. Not the best set up I'm sure.

    I'm sure of my z steps per mm. I printed a fan mount yesterday and it was meant to be 40mm tall, it was 40mm tall, the fan fit perfectly. I got my steps settings for x y and z from a youtube video of a X5S printer being set up using the reprap online configurator tool.

    the g30 you mention instead of g1 s1 are you referring to the calibration instructions? I'm a smidged confused.

    My markup was being messed up by me using equal signs to show where my code was. Weird.



  • Ah! You're talking about the homez.g file. I'll try that out.



  • @jamesadoty

    the g30 you mention instead of g1 s1 are you referring to the calibration instructions? I'm a smidged confused.

    I mean in your homez.g

    If you change the g1 S1 z move to be G30 I think it will solve your problem.

    You should also add a move before g30 to place the probe in the center of the bed.



  • See here https://duet3d.dozuki.com/Wiki/ConfiguringRepRapFirmwareCartesianPrinter Under the homing z using z probe section



  • @phaedrux
    Excellent.

    I made a few changes and I'm attempting to print again.



  • I think those changes may have done the trick.

    I'm printing an enclosure for my 7 inch Duet display and it's been printing for 25 to 30 minutes and looks pretty good.

    I may have to adjust the offset a bit but so far so good.

    Thanks for your help.



  • Yay! My print turned out pretty good. Still some fine tuning to do but I had excellent bed adhesion.


Log in to reply