Mesh Grid - Result is not ok



  • Hi

    i have a AM8 with Duet Wifi with Mini Ir probe
    Now i would install Auto bed leveling but the bed seems not to be linear
    0_1548151663842_Mesh Calibration.jpg

    config.g

    ; Configuration file for Duet WiFi (firmware version 1.21)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2 on Sun Jan 13 2019 14:56:09 GMT+0100 (Mitteleuropäische Normalzeit)

    ; General preferences
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves

    ; Network
    M550 P"AM8" ; Set machine name
    M552 S1 ; Enable network
    M587 S"WLAN-363335" P"luigello20101984" ; Configure access point. You can delete this line once connected
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Drives
    M569 P0 S1 ; Drive 0 goes forwards
    M569 P1 S1 ; Drive 1 goes forwards
    M569 P2 S0 ; Drive 2 goes backwards
    M569 P3 S1 ; Drive 3 goes forwards
    M350 X16 Y16 Z16 E16 I1 ; Configure microstepping with interpolation
    M92 X100.00 Y100.00 Z400.00 E100.00 ; Set steps per mm
    M566 X600.00 Y600.00 Z18.00 E300.00 ; Set maximum instantaneous speed changes (mm/min)
    M203 X6000.00 Y6000.00 Z180.00 E6000.00 ; Set maximum speeds (mm/min)
    M201 X1500.00 Y1500.00 Z100.00 E10000.00 ; Set accelerations (mm/s^2)
    M906 X500.00 Y500.00 Z500.00 E800.00 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X-33 Y-10 Z0 S1 ; Set axis minima
    M208 X220 Y220 Z240 S0 ; Set axis maxima

    ; Endstops
    M574 X1 Y1 S0 ; Set active low and disabled endstops

    ; Z-Probe
    M574 Z1 S2 ; Set endstops controlled by probe
    M558 P1 H4 F120 T6000 ; Set Z probe type to modulated and the dive height + speeds
    G31 P500 X0 Y0 Z1.125 ; Set Z probe trigger value, offset and trigger height
    M557 X20:200 Y20:200 S40 ; Define mesh grid

    ; Heaters
    M305 P0 T100000 B4388 C7.060000e-8 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S130 ; Set temperature limit for heater 0 to 130C
    M305 P1 T100000 B4388 C7.060000e-8 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S275 ; Set temperature limit for heater 1 to 275C

    ; Fans
    M106 P0 S0 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Automatic saving after power loss is not enabled

    ; Custom settings are not configured

    ; Miscellaneous
    T0 ; Select first tool

    bed.g

    ; bed.g
    ; called to perform automatic bed compensation via G32
    ;
    ; generated by RepRapFirmware Configuration Tool v2 on Sun Jan 13 2019 14:56:09 GMT+0100 (Mitteleuropäische Normalzeit)
    M561 ; clear any bed transform
    G29 ; probe the bed and enable compensation

    what i can do to solve it ?

    thanks an dsorry for my bad english


  • administrators

    Does that machine have 2 Z motors, one at each end of the Z axis? If so then it looks like they have got out of sync. You can sync them automatically, see https://duet3d.dozuki.com/Wiki/Bed_levelling_using_multiple_independent_Z_motors.



  • Yes it have 2 Z Motors

    i will check your link

    thanks



  • are you sure your x-axis height (to the bed) was equal left and right side, before you started measuring the bed? For a certain X position the z height is the same for the whole length of your Y...so it looks like your x-axis wasn't leveled.



  • @lui2004 for bed levelling you need to use 2 drivers for you 2 z motors



  • i dont understand the example from the wiki
    https://duet3d.dozuki.com/Wiki/Bed_levelling_using_multiple_independent_Z_motors

    can you give me some help

    thank you



  • New Automatic Calibration Results

    0_1548271459339_mesh.jpg

    what i can do to make it better without to buy new hardware is it possible ?

    thanks


  • administrators

    1. It looks like you had a large probing error at one particular point (the red one). Is it repeatable? Is there anything special about that point?

    2. Which firmware version are you using?



  • No nothing particular on this point

    Every mesh grid The same point

    I use the last Firmware 2.02

    I have read that i can use The E1 for a second z motor Drive? Is it correct ? So i can use The Wiki link Fromm dc42 ?



  • This is my 3dPrinter

    0_1548275198420_20190123_212454.jpg
    0_1548275224611_20190123_212508.jpg
    0_1548275240327_20190123_212508.jpg



  • Nothing?

    I dont be forward still same Problem.



  • so i have made some changed

    2 indepedet motors for Z ( ZA and E1 )

    config.g

    ; Configuration file for Duet WiFi (firmware version 1.21)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2 on Sun Jan 13 2019 14:56:09 GMT+0100 (Mitteleuropäische Normalzeit)

    ; General preferences
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves

    ; Network
    M550 P"AM8" ; Set machine name
    M552 S1 ; Enable network
    M587 S"WLAN-363335" P"luigello20101984" ; Configure access point. You can delete this line once connected
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Drives
    M569 P0 S1 ; Drive 0 goes forwards
    M569 P1 S1 ; Drive 1 goes forwards
    M569 P2 S0 ; Drive 2 goes backwards
    M569 P3 S1 ; Drive 3 goes forwards
    M569 P4 S0 ; Drive 4 goes backwards
    M350 X16 Y16 Z16 E16 I1 ; Configure microstepping with interpolation
    M92 X100.00 Y100.00 Z400.00 E100.00 ; Set steps per mm
    M566 X600.00 Y600.00 Z18.00 E300.00 ; Set maximum instantaneous speed changes (mm/min)
    M203 X6000.00 Y6000.00 Z180.00 E6000.00 ; Set maximum speeds (mm/min)
    M201 X1500.00 Y1500.00 Z100.00 E10000.00 ; Set accelerations (mm/s^2)
    M906 X500.00 Y500.00 Z500.00 E800.00 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M584 X0 Y1 Z2:4 ; two Z motors connected to driver outputs Z and E1
    M671 X-20:220 Y0:0 S0.5 ; leadscrews at left and right of X axis
    M208 X-33:205 Y0:200 ; X carriage moves from -5 to 205, Y bed goes from 0 to 200
    ;M208 X-33 Y-10 Z0 S1 ; Set axis minima
    M208 X220 Y220 Z240 S0 ; Set axis maxima

    ; Endstops
    M574 X1 Y1 S0 ; Set active low and disabled endstops

    ; Z-Probe
    M574 Z1 S2 ; Set endstops controlled by probe
    M558 P1 H4 F120 T6000 ; Set Z probe type to modulated and the dive height + speeds
    G31 P500 X0 Y0 Z1.697 ; Set Z probe trigger value, offset and trigger height
    M557 X20:200 Y20:200 S40 ; Define mesh grid

    ; Heaters
    M305 P0 T100000 B4388 C7.060000e-8 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S130 ; Set temperature limit for heater 0 to 130C
    M305 P1 T100000 B4388 C7.060000e-8 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S275 ; Set temperature limit for heater 1 to 275C

    ; Fans
    M106 P0 S0 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Automatic saving after power loss is not enabled

    ; Custom settings are not configured

    ; Miscellaneous
    T0 ; Select first tool

    bed.g

    ; bed.g
    ; called to perform automatic bed compensation via G32
    ;
    ; generated by RepRapFirmware Configuration Tool v2 on Sun Jan 13 2019 14:56:09 GMT+0100 (Mitteleuropäische Normalzeit)
    ;M561 ; clear any bed transform
    ;G29 ; probe the bed and enable compensation

    G28 ; home
    M401 ; deploy Z probe (omit if using bltouch)
    G30 P0 X20 Y100 Z-99999 ; probe near a leadscrew, half way along Y axis
    G30 P1 X180 Y100 Z-99999 S2 ; probe near a leadscrew and calibrate 2 motors
    M402 ; retract probe (omit if using bltouch)

    thats my actual height map

    1_1548450032549_map2.jpg 0_1548450032534_map.jpg



  • But here you have only performed bed level with the leads crews. Not any mesh, i.e. G29. At least I don't see that in bed.g file.
    There is something seriously wrong.... Why are the x and y coords of you sample points not in a grid? Isn't that that the plot straight from above?it must the perspective...
    Why do you deploy for the ir sensor?



  • Hi
    Thanks for your answer

    Also i have to add this code in bed.g

    ; mesh probe
    G29 S0

    My english is not The best can you give a advise



  • i think i found the problem i have insert bed leveling with mesh

    now i have only mesh

    20.00,200.00,20.00,200.00,-1.00,40.00,40.00,5,5
    0.015, 0.398, 0.325, 0.287, 0.205
    0.322, 0.352, -0.173, 0.335, 0.265
    0.342, 0.357, 0.882, 0.337, 0.280
    0.305, 0.232, 0.317, 0.285, 0.305
    0.168, 0.355, 0.245, 0.232, 0.385

    my new config.g

    ; Configuration file for Duet WiFi (firmware version 1.21)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2 on Sun Jan 13 2019 14:56:09 GMT+0100 (Mitteleuropäische Normalzeit)

    ; General preferences
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves

    ; Network
    M550 P"AM8" ; Set machine name
    M552 S1 ; Enable network
    M587 S"WLAN-363335" P"luigello20101984" ; Configure access point. You can delete this line once connected
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Drives
    M569 P0 S1 ; Drive 0 goes forwards
    M569 P1 S1 ; Drive 1 goes forwards
    M569 P2 S0 ; Drive 2 goes backwards
    M569 P3 S1 ; Drive 3 goes forwards
    M350 X16 Y16 Z16 E16 I1 ; Configure microstepping with interpolation
    M92 X100.00 Y100.00 Z400.00 E100.00 ; Set steps per mm
    M566 X600.00 Y600.00 Z18.00 E300.00 ; Set maximum instantaneous speed changes (mm/min)
    M203 X6000.00 Y6000.00 Z180.00 E6000.00 ; Set maximum speeds (mm/min)
    M201 X1500.00 Y1500.00 Z100.00 E10000.00 ; Set accelerations (mm/s^2)
    M906 X500.00 Y500.00 Z500.00 E800.00 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X-33 Y-10 Z0 S1 ; Set axis minima
    M208 X220 Y220 Z240 S0 ; Set axis maxima

    ; Endstops
    M574 X1 Y1 S0 ; Set active low and disabled endstops

    ; Z-Probe
    M574 Z1 S2 ; Set endstops controlled by probe
    M558 P1 H4 F120 T6000 ; Set Z probe type to modulated and the dive height + speeds
    G31 P500 X0 Y0 Z2.180 ; Set Z probe trigger value, offset and trigger height
    M557 X20:200 Y20:200 S40 ; Define mesh grid

    ; Heaters
    M305 P0 T100000 B4388 C7.060000e-8 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S130 ; Set temperature limit for heater 0 to 130C
    M305 P1 T100000 B4388 C7.060000e-8 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S275 ; Set temperature limit for heater 1 to 275C

    ; Fans
    M106 P0 S0 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Automatic saving after power loss is not enabled

    ; Custom settings are not configured

    ; Miscellaneous
    T0 ; Select first tool

    bed.g:

    ; bed.g
    ; called to perform automatic bed compensation via G32
    ;
    ; generated by RepRapFirmware Configuration Tool v2 on Sun Jan 13 2019 14:56:09 GMT+0100 (Mitteleuropäische Normalzeit)
    M561 ; clear any bed transform
    G29 ; probe the bed and enable compensation

    My New Result Mesh:

    1_1548530910759_mesh2.jpg 0_1548530910758_mesh.jpg



  • Does your bed surface have a bit of a reflectiveness to it? Can you try probing your bed with a piece of plain white printer paper on it? I'm thinking maybe the IR probe isn't getting a good reading from your bed surface.



  • I have The buildtak Vertex

    I will Test it tommorow

    If its reflectiveness what i can use to probing?



  • You can try adding an A and S parameter to your M558 command to try and increase probing consistency.

    M558 A10 S0.003

    this will cause the probe to probe up to 10 times if the consistency of two consecutive probe results are within 0.003mm of each other.



  • Like this

    M558 P1 H4 F120 T6000 A10 S0.003



  • @lui2004 Yes


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.