G30 code does not execute



  • Hi
    I have a diy corexy printer, which was working perfectly with my Duet Ethernet.
    I updated to a Precision Piezo probe to do away with the Z home micro switch. The problem is that G30 code does not work. This is the home all gcode.

    ; homeall.g

    G91
    G1 S1 Z5 F6000
    G1 S1 X-305 Y-305 F1800
    G1 S1 X-305
    G1 S1 Y-305
    G1 X5 Y5 F6000
    G1 S1 X-305 F360
    G1 S1 Y-305
    G90
    G1 Y150 X150 F6000
    G30

    G1 Z5
    G1 Y0 X0 F6000
    G1 Z0.05

    When I execute this everything operates as it should X and Y home and then move to the center of my bed, ie: G1 Y150 X150 F6000 then it just ignores the G30 probe code and executes the rest of the code moving the head back to Y0 and X0.

    Why is it not probing the bed with G30?
    I have searched the forum for answers but I can’t find anything relating to this problem.

    Thanks in advance for any help you can give.


  • administrators

    Have you checked the GCode Console page or DWC or PanelDue for error messages? I suspect there may be a "Z probe already triggered at start of probing move" message. If so, that's usually caused by either faulty wiring or incorrect configuration in your M558 command in config.g.

    Also see https://duet3d.dozuki.com/Wiki/Test_and_calibrate_the_Z_probe.



  • dc42 Thank you for your response.
    The DWC was showing 1000 in the Z probe.
    After reading more about M558 I changed the I parameter from I0 to I1 in the config.g file and that solved the problem.
    So a big thank you dc42 very helpful.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.