Auto Delta Calibration not stopping when triggering BLTouch



  • Hi,
    I have fully operational Anycubic Kossel Plus + BLTouch rig, that I just migrated from stock-Trigorilla to Duet 2 WiFi v1.04 (after a succesful goodbye print of the Duet mounts ;)).

    Now, all the wiring should be ok, as all the tests I made so far have passed, EXCEPT ONE: when I start the Auto Delta Calibration, and test if it stops by manually triggering the BL Touch, it does not stop!

    BLTouch is correctly wired as per what indicated here: https://duet3d.dozuki.com/Wiki/Connecting_a_Z_probe#BLTouch

    I can command the BLT to do up, down, self test and reset, and I can see the Probe state change from 0 to 1000 by performing the tests in the doc.

    Here is my config: 0_1548409538729_config.g

    What could be wrong?

    Many thanks for any help.


  • administrators

    Did you test the probe as described at https://duet3d.dozuki.com/Wiki/Test_and_calibrate_the_Z_probe ?



  • Yes I did and it all worked, resulting in Z=1.9 correction in the G31 command in config.g, that is now:

              G31 P25 X0 Y-40 Z1.9
    

    So I decided to commit and proceeded with the Auto Delta Calibration, BUT here is what happens:

    • the head stops at about 5mm before touching the BLT (deployed) probe
    • then the head moves horizontally on the virtual Y axis (towards the Z tower), but does not dynamically compensate the height during the travel (as per delta kinematics) and while it is approaching the limit, the head lowers and lowers until triggering the BLT, without stopping, and ultimately hitting the bed

    Luckily the emergency button is quick enough to stop the crash at its beginning…

    What could be causing this?


  • administrators

    The problem is that your delta calibration is a long way out. Temporarily change the H parameter in the M558 command to 40 and try again. When you have successfully calibrated the printer and saved the new M665 and M666 values, you can put is back (the default value is H5).



  • @dc42, that's exactly what I was missing: endstop adjustments!
    Auto-calibrating with a greater probe height in M558 (20 was enough in my case) allowed me to grab the resulting values to be fed into the M666 inside config.g.

    Thank you very much for your prompt support! 🙂


Log in to reply