Extruder not working on new install (upgrade)



  • My extruder stepper motor just vibrates with minimal movement of the filament. Turning the mA up from 500 to 1000 makes it vibrate with a very fast, loud clicking but the filament moves. Previously working fine on my OEM Tronxy controller at 500mA and running smooth. I tried swapping motors and got the same. Tried the motor on the X axis and it worked fine. I tried swapping wiring with the same result. So, I'm sure its not the motor or wiring. config appears to be similar to many other working setups. This is a new installation replacing a working OEM setup. Did I get a bad stepper driver? I'm no expert at checking that but no obvious physical signs of a problem. I'm struggling with setting it up as an access point as well but will start a separate thread for that.

    Machine: Tronxy X5SA
    Stepper motor for extruder: LDO Overthemoon, 1.8deg, 1A. Tried the Tronxy OEM motors too.
    Controller: Duet WiFi
    Versions: firmware 2.02a, web control 1.22.6, server 1.22

    I can't get config.g to upload due to poor internet connection so here is a text copy of my settings if it could be helpful.

    ; Configuration file for Duet WiFi (firmware version 1.21)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2 on Wed Jan 23 2019 15:02:09 GMT-0900 (Alaska Standard Time)

    ; General preferences
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves

    M667 S1 ; Select CoreXY mode

    ; Network
    M550 P"TronxyX5SA" ; Set machine name
    M552 S2 ; Enable as an access point
    M589 S"TronxyC5SA" P"--------" I192.186.2.100 ; Configure access point parameters. Set SSID, WiFi password, & IP address to use.

    ; Drives
    M569 P0 S0 ; Drive 0 goes backwards
    M569 P1 S0 ; Drive 1 goes backwards
    M569 P2 S1 ; Drive 2 goes forwards
    M569 P3 S0 ; Drive 3 goes backwards
    M350 X16 Y16 Z16 E16 I1 ; Configure microstepping with interpolation
    M92 X80.00 Y80.00 Z400.00 E418.5 ; Set steps per mm
    M566 X900.00 Y900.00 Z12.00 E120.00 ; Set maximum instantaneous speed changes (mm/min)
    M203 X6000.00 Y6000.00 Z6000.00 E600.00 ; Set maximum speeds (mm/min)
    M201 X500.00 Y500.00 Z20.00 E250.00 ; Set accelerations (mm/s^2)
    M906 X1000.00 Y1000.00 Z1000.00 E100.00 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X40 Y40 Z0 S1 ; Set axis minima
    M208 X330 Y330 Z400 S0 ; Set axis maxima

    ; Endstops
    M574 X1 Y1 S0 ; Set active low and disabled endstops

    ; Z-Probe
    M574 Z1 Z2 S2 ; Set endstops controlled by probe
    M558 P5 I1 H5 F120 T6000 A10 R0.5 B0 ; Set Z probe type to modulated and the dive height + speeds
    G31 P500 X-30 Y-40 Z5.35 ; Set Z probe trigger value, offset and trigger height
    M556 S50 X0 Y0 Z0 ; Set orthogonal axis compensation parameters
    M557 X55:330 Y65:330 S15 ; Define mesh grid

    ; Heaters
    M305 P0 T100000 B4138 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; Set temperature limit for heater 0 to 120C
    M305 P1 B4725 C7.060000e-8 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S300 ; Set temperature limit for heater 1 to 300C

    ; Fans
    M106 P0 S0.3 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Automatic power saving
    M911 S10 R11 P"M913 X0 Y0 G91 M83 G1 Z3 E-5 F1000" ; Set voltage thresholds and actions to run on power loss

    ; Custom settings are not configured

    ; Miscellaneous
    M501 ; Load saved parameters from non-volatile memory



  • I forgot to also say that I checked continuity of the motors and wires where were fine. But them working on other axis should have proven that as well. It is in a printed PLA case (Ocie's Box) with nothing anywhere near it that could be grounding it out. Unless there's something I'm missing in the firmware then I'm not sure what else to check. I don't know how to check the stepper driver itself.



  • is 100ma for the extruder correct? that seems a bit low.
    maybe you mistyped and missed a 0


  • administrators

    It looks like your E1 motor output is free. So you can try connecting it to the E1 output instead of E0, then change D0 in your M563 command in config.g to D1. Leave the heater wiring alone. If that fixes it then the E0 stepper driver is probably faulty.



  • E1 in his current configuration will also only receive 100mA. So it will result in the same problem.



  • I caught the E0 set at 100mA. It was a typo when I was trying higher settings and corrected it during my testing. My results described above were using 500mA (mA used with previous setepper driver and verified with a voltmeter) and 1,000mA.

    I'll try using E1 output when I get home tonight.



  • E1 worked the same. I decided to break down the extruder and make sure nothing was mechanically causing this because it sure had a mechanical sound. I didn't find anything wrong but when reassembled the problem resolved. Who knows what could have caused the problem at the same time I upgraded to the Duet WiFi but I sure am glad it wasn't the Duet.
    Thank you for the help. It's hard to believe the level of support for this product. I have already spread the word to almost everyone I know. I learned a little more through the process and for that I am very thankful. Now if I can solve the access point connection problem I'll be set.... until my next upgrade.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.