Strange issue when running programme on CNC



  • Hi Guys. Looking some help. I am running a Duet2 wifi with all the latest firmware on a Workbee CNC screwdriven router. All machine axis are functioning OK on jog and all previous programmes have run absolutely fine. I am currently trying to run a simple pocket programme using Vectric Vcarve & GRBL code. Its a simple programme with 3 passes to obtain the depth. 1st pass runs absolutely fine then on start of 2nd pass machine almost stops and everything appears to freeze. I have attached a photo of file log at point it stops. Not sure if its the Vectric software or the Duet but as a relative newbie would appreciate your thoughts. Trev0_1548669111239_IMG_4166.jpg


  • administrators

    I'm not a CNC expert, however I would need to see the GCode file you are using to have any idea of what is going wrong.

    The "G17 command not supported" message is harmless, because G17 selects the XY plane for G2 and G3 commands, which is the only plane that RRF currently supports for them.



  • Hi David thanks for getting back. Attached is GCode file as requested. Hopefully you can give me some direction. Tried to run file again with same result. Trev0_1548676363038_Reuben Base 2.gcode


  • administrators

    I don't see anything in that GCode that explains the problem.

    Please can you:

    1. Send M450 and confirm that it reports that the machine is in CNC mode.

    2. Run that file again. When it stops, read off the XYZ coordinates from the web interface. Also send M122 from the web interface. With luck the GCodes section of the report will say what command is being executed.



  • Hi David. I know this is a very elementary question but how do I send the codes you mention? Do I need to link with USB and use the YAT software?


  • administrators

    You can send them from the GCode Console page of Duet Web Control. See the "Send GCode" box in the screenshot you posted.



  • Thanks David will let you know



  • David when I send M450 I get "Printer Mode FFF". I assume problem is in here somewhere. Do I need to change something?



  • M122 File attached at point of stopping0_1548680231248_console.txt


  • administrators

    @trev133 said in Strange issue when running programme on CNC:

    David when I send M450 I get "Printer Mode FFF". I assume problem is in here somewhere. Do I need to change something?

    Yes, you need to use M453 in config.g to put it in CNC mode. See https://duet3d.dozuki.com/Wiki/Gcode?revisionid=HEAD#Section_M453_Select_CNC_Printer_Mode. Without that, G0 commands will execute at the same speed as G1 commands instead of rapidly.

    Note, if the M453 command declares that a heater or fan output is to be used for spindle control, you must disable the corresponding heater or fan before the M453 command, using M307 or M106 as appropriate.



  • Thanks David. Will let you know



  • Hi David
    Put M453 into config.g but it stopped any file from running. (Tried several files that had previously run OK) Got error message as attached. Had work co-ordinated established as before so i’m not sure what outside machine limits means. Removed the M453 and all was OK again. Sending M450 code I was able to confirm that machine was in CNC mode.
    Any Thoughts
    Trev
    0_1548798894543_IMG_4167.jpg


  • administrators

    The problem is the "outside machine limits" message. In CNC mode, a movement command that commands movement outside the limits you have set in config.g will terminate the job, for safety reasons. So you need to identify that command in the GCode file, for example by executing lines from the file one at a time.


Log in to reply