IDEX - U Crashing into X



  • Hello,

    For a while now I get a issue which causes U carriage to try and assume the position of X carriage (the one which i have the Z IR End stop on)
    I have not been able to totally figure out when it is going to happen but it seems to happen after using the PanelDue.
    It just happened again so I will start by documenting what i was doing before it occurred.

    This time i had done the following:

    • selected extruder 2 and heated it to 230c via paneldue

    • extruded 100mm via panel due

    • sent G28 (as part of a print start script)

    The right carriage tries to take the place of the left then moves to the triggering point for Z and of course the bed crashes into the nozzle as the IR sensor is on X not U.
    That seems to be reproducible. Its fine if i remember to select T0 before hitting home so it seems that if T1 is selected when you hit home/G28 X and U move to their limits then instead of using T0 to home Z it uses what ever the last tool used was.

    Is there a way to configure this behaviour?


  • administrators

    You are right and this is totally configurable using the homing macros.

    What you need to do is ensure that the homing macros take into account that either tool could be configured. So for example my Homeall.g on the bigbox IDEX is:

    [[language]]
    G91
    G1 Z4 F200                    ; raise head 4mm to keep it clear of the bed
    G1 X-400 Y-400 U400 F6000 S1  ; home X, Y and U
    G90
    ; Now home Z using the Z probe
    G1 X140 Y200 F6000 S2         ; move to bed centre for probing
    G30  
    
    

    The home Z is:

    M98 Phomeu.g                  ; get the U carriage out of the way
    G1 X140 Y200 F6000  ; center the X axis with the Z probe
    G91                ; relative mode
    G1 Z4 F200         ; lower bed 4mm to ensure it is below the Z probe trigger height
    G90                ; back to absolute mode
    G30
    
    

    I hope that helps.



  • It does thanks! I forgot about homing macros. Still getting used to RepRap firmware way of thinking (which is way easier or at least your implementation is).

    Surely you would have the same issue as me then (from the above macros) if the last tool selected is T1, as you just specify:
    [c]; Now home Z using the Z probe
    G1 X140 Y200 F6000 S2 ; move to bed centre for probing[/c]

    As it has not been told that the Z probe is on T0. Surely i would need to specify the tool the zprobe is on like:

    [c]
    ; Now home Z using the Z probe
    T0
    G1 X140 Y200 F6000 S2 ; move to bed centre for probing[/c]

    Am I correct? Otherwise how does the macro know to home z by moving tool 0?


  • administrators

    Instead of using the T0 command to select tool 0, you could use G2 S2 X140 Y200 F6000 S2. The S2 parameter tells it to not to apply X-axis mapping.



  • Ah S2 is what i was missing from T3P3Tony's macros. Added it and all seems well now. Thanks to both!


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.