IR sensor probe caused "diag LED" to come on



  • I am doing my final installation and just wired up the IR sensor and plugged it in. The red LED light on the IR sensor is on ( I don't think its working properly ) but was concerns me is the red diag LED light is on on the front of the Duet 2 wifi board just to the left of the SD card. Since, it came on I cannot get it to go off, nor can I get the IR sensor to work properly. I have the wires connected as follows.

    GND / GND
    VCC / +3.3V
    out / Z Probe In


  • administrators

    The DIAG led shares the signal that drives the MOD pin on the Z probe connector. So certain Z probe settings in the M558 command will turn it on. It only has a diagnostic function during start up and while upgrading firmware.



  • Thank you for the reply, Dave. Is it correct to say that if there WAS a problem that the DIAG light would be lit and also some sort of DIAG error message within webserver?


  • administrators

    @excelon said in IR sensor probe caused "diag LED" to come on:

    Thank you for the reply, Dave. Is it correct to say that if there WAS a problem that the DIAG light would be lit and also some sort of DIAG error message within webserver?

    No, the DIAG light isn't automatically lit. It's more of a debugging aid than a diagnostic light.



  • @dc42 said in IR sensor probe caused "diag LED" to come on:

    @excelon said in IR sensor probe caused "diag LED" to come on:

    Thank you for the reply, Dave. Is it correct to say that if there WAS a problem that the DIAG light would be lit and also some sort of DIAG error message within webserver?

    No, the DIAG light isn't automatically lit. It's more of a debugging aid than a diagnostic light.

    So, it is, or isnt normal for the DIAG light to remain lit 24/7 with the IR sensor coded in config.g?

    You mentioned that some programming of M558 will trigger it which makes sense but I'm trying to make sure and understand that the board, even with the DIAG light lit is ok and functional 100%. Can you please explain how I would un-comment or program the duet 2 wifi in such a way where I could test the normal functionality of said DIAG light?


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.