Duet preparing problems with Mac



  • Hi,

    I have tried seaching for this but could not find a solution.

    When preparing the Duet card via USB on my Mac for Wifi usage I get the following problems.
    using this setup https://duet3d.dozuki.com/Guide/1.)+Getting+Connected+to+your+Duet/7

    Run ls /dev/tty.*

    Give me a response of /dev/tty.usbmodemFA131

    So I then type

    screen /dev/tty.usbmodemFA131 115200

    give me this response...

    RepRapFirmware for Duet 2 WiFi/Ethernet Version 2.01(RTOS) dated 2018-07-26b2

                                                                             Executing config.g...Error: Bad command: FOR TESTING ONLY! USE https://configurator.reprapfirmware.org/ to generate configuration files for your printer!
                                                                      WiFi module is disabled
             Warning: Heater 0 appears to be over-powered. If left on at full power, its temperature is predicted to reach 275C.
    
                                                Done!
                                                     RepRapFirmware for Duet 2 WiFi/Ethernet 
    

    I then cant type anything else.

    If I restart Terminal and try it again, sometimes i get a message saying that 'resource is busy try again' and then it gives me the 'sorry could not find a PTY' so I disconnect the Duet card and plug back in again and then I either get the same message or the first message above.

    Can anyone shed any light on this?

    Rob



  • I have now tried Printrun software and this connects, however if I run M552 S1 Code it comes back with this message...

    m552 S1
    SENDING:M552 S1
    WiFi reported error: no known networks found
    WiFi module is idle


  • administrators

    I think the problem with your Mac terminal emulator is that it doesn't recognise the linefeed character (LF) as a line terminator. I know Macs used to use carriage return (CR) as the line terminator, but I thought they had changed to LF now.

    The "no known networks found" message means what it says. Did you use M587 to enter the SSID and password of your network? You can send M587 without parameters to list the known networks. Note, SSIDs and passwords are case sensitive. Unfortunately, Printrun converts everything to uppercase before sending it.



  • I have now managed to access my wifi network using m552 s0, m587 with password info and m552 s1


  • administrators

    I'm glad you got it working. I'll mark this as solved.


Log in to reply