Setup Issue



  • Hi,

    I have been setting up my Duet3D to run with my CNC Workbee. set up was going well and i was connected to the web interface prior to the final upload of system settings with the change of IP (from 192.168.1.14 to 192.168.2.14 ). However since this i cannot connect to the Duet through my ethernet on the old or new IP and when i check though YAT on the USB i get the following:

    "Network is enabled, configured IP address: 0.0.0.0, actual IP address: 0.0.0.0<LF>ok<LF>"

    Any hints as to how i can undo my last update or re-set and try again would be a great help.

    Thanks


  • administrators

    It's telling you that the configured IP address is 0.0.0.0 which means that the Duet will ask your router to allocate an IP address. If it's not connected to your router but instead you have a direct connection to your PC, or if you want to allocate a static IP address, edit the M552 command in /sys/config.g on the SD card. Example:

    M552 P192.168.2.14 S1



  • Thanks for the quick reply.

    Yes i had already changed the config.g file even amended to match you example excactly i have no change:

    ( ; Network
    M550 PWorkBee CNC Machine ; Set machine name
    M552 P192.168.2.14 S1 ; Enable network
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet )


  • administrators

    Somehow that M552 command isn't being actioned. Are you sure that there isn't another M552 command later in the file?



  • @dc42

    Not that i can see, this is a copy of the full config.g file:

    ; Configuration file for Duet WiFi (firmware version 1.20 or newer)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool on Mon Mar 12 2018 16:19:25 GMT+0000 (GMT Standard Time)

    ; General preferences
    G90 ; Sent absolute coordinates

    ; Network
    M550 PWorkBee CNC Machine ; Set machine name
    M552 P192.168.2.14 S1 ; Enable network
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Drives
    M569 P0 S0 ; Drive 0 goes forwards
    M569 P1 S1 ; Drive 1 goes forwards
    M569 P2 S0 ; Drive 2 goes forwards
    M569 P3 S1 ; Drive 3 goes forwards
    M584 X0 Y1:3 Z2 ; Apply custom drive mapping
    M92 X400 Y400 Z400 ; Set steps per mm
    M350 X16 Y16 Z16 I1 ; Configure microstepping with interpolation
    M566 X500 Y500 Z500 ; Set maximum instantaneous speed changes (mm/min)
    M203 X2500 Y2500 Z2500 ; Set maximum speeds (mm/min)
    M201 X150 Y150 Z150 ; Set accelerations (mm/s^2)
    M906 X2400 Y2400 Z2400 I100 ; Set motor currents (mA)

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X550 Y520 Z94 S0 ; Set axis maxima

    ; Endstops
    M574 X2 Y2 Z2 S0 ; Set active low endstops

    ; Tools

    ; Custom settings
    M564 H0 ; Enable jog commands when not homed
    M140 H-1 ; Disable heated bed
    M501 ; Load Stored Parameters

    and this is all the files in /sys:

    0_1549227726473_Untitled.jpg



  • How is your local network configured? Changing from x.x.1.14 to x.x.2.14 means you want to use another subnet. If you dont have some fancy router with multiple subnets, then your duet might not connect to network if gateway is in another subnet.



  • @aidar

    Network for Ethernet Connection is set up as shown:

    0_1549229117253_Untitled2.jpg



  • i see, then you address with 2.14 should be valid, so....
    Just guessing here, but maybe you should try to configure gateway in your config.g with M554?


  • administrators

    Perhaps there is a non-printing character in that M552 line. Or perhaps config.g isn't being read at all. Try sending this from YAT:

    M552 S0
    M98 Pconfig.g

    Does it produce any error messages? If not, what does YAT report if you then send M552?



  • Er....

    I ran the code M554 through YAT it came back with 0.0.0.0 again, so i deleted the line M552 and re-entered it as M554 and the rest. When i tested it through YAT it came back with the correct IP but would still not connect to the web interface. So i re-set it as M552 and tested it again with YAT just to be sure... however this time it worked!

    I have no idea what it was, but can only assume I did something foolish or as you say by deleting and re-writing i removed a non-printing character.

    In any case, i am very grateful for your help and can only apologise if i have wasted your time.

    Many thanks,

    --James


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.