Homing issue after print



  • Hi all,

    I've been having trouble lately (Duet Wifi); after a print my printer homes extremely slowly, as we can see here
    https://www.youtube.com/watch?v=g8pIcrPImBk&feature=youtu.be

    Any idea what could be causing this? Here is also my end gcode and settings, in case the problem lies there. Any help is appreciated.

    End gcode:
    G1 E-2 F100; retract 1mm at speed of 100mms
    G92 E0; set extruder value back to 0
    M104 S0 ; turn off temperature
    M140 S0 ; turn off bed
    G1 X0 ; home X axis
    G1 Y205 ; home Y axis
    G1 Z138 ; home Z Axis
    M106 P2 S0 ; turn off fan

    Settings:

    ; General preferences
    G90 ; Send relative coordinates...
    M83 ; ...but relative extruder moves

    ; Network
    M550 P"In-Vitro Printer" ; Set machine name
    M551 P"Violator007: ; Set password
    M552 S1 ; Enable network
    M587 S"arakahnlow" P"als1mmons" ; Configure access point. You can delete this line once connected
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Drives
    M569 P0 S0 ; Drive 0 goes forwards
    M569 P1 S0 ; Drive 1 goes forwards
    M569 P2 S1 ; Drive 2 goes forwards
    M569 P3 S0 ; Drive 3 goes forwards
    M350 Z4 E16 I0 ; Configure microstepping without interpolation
    M350 X16 Y16 I1 ; Configure microstepping with interpolation
    M92 X80 Y80 Z400 E92.32 ; Set steps per mm
    M566 X900.00 Y900.00 Z12.00 E120.00 ; Set maximum instantaneous speed changes (mm/min)
    M203 X30000.00 Y30000.00 Z1000.00 E2700.00 ; Set maximum speeds (mm/min)
    M201 X1200.00 Y1000.00 Z50.00 E5000.00 ; Set accelerations (mm/s^2)
    M906 X950.00 Y950.00 Z900.00 E900.00 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y-10 Z0 S1 ; Set axis minima
    M208 X205 Y205 Z138 S0 ; Set axis maxima

    ; Endstops
    M574 X1 Y1 S1 ; Set active high endstops

    ; Z-Probe
    M574 Z1 S2 ; Set endstops controlled by probe
    M558 P8 R0.8 I1 H2 F300 A1 S0.05 ; Set Z probe type to effector and the dive height + speeds
    G31 P200 X0 Y0 Z-0.35 ; Set Z probe trigger value, offset and trigger height
    M557 X0:205 Y0:205 S30 ; Define mesh grid

    ; Heaters
    M305 P0 T100000 B4138 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; Set temperature limit for heater 0 to 120C
    M305 P1 X200 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S285 ; Set temperature limit for heater 1 to 285C

    ; Fans
    M106 P0 S0 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1.0 I0 F500 H1 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P2 S0 I0 F500 H-1 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned off

    ; Tools
    M563 P0 D0 H1 F2 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Automatic saving after power loss is not enabled

    ; Custom settings are not configured

    ; Miscellaneous
    M501 ; Load saved parameters from non-volatile memory



  • Probably your last move in print file is very slow, and as end gcode does not specify new speed, thats why those G1 moves are so slow. Try adding F3000 (or more if you want it to be faster) to those G1 commands in end gcode and see what happens.



  • @arakahn said in Homing issue after print:

    G1 E-2 F100; retract 1mm at speed of 100mms
    G92 E0; set extruder value back to 0
    M104 S0 ; turn off temperature
    M140 S0 ; turn off bed
    G1 X0 ; home X axis

    You've set a feed rate of 100 with your filament retraction, and then instead of using G28 X to home the X axis, you are actually moving it there at the reduced feed rate.

    so either give the movement commands a higher feed rate, or use G28 X and G28 Y which will using your homex.g and homey.g macros.



  • That makes total sense, I figured it would be something simple and stupid. Thank you both very much gentlemen, I will change my code as suggested!


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.