Heated gets up to 60C fairly quick but won't get much higher



  • I had an issue where the heat bed was taking a significant time to heat up, something like 45 minutes to get to 60C, I checked the resistance on the heated bed and believed there is an issue because the resistance kept jumping around. So I replaced the heated bed with a MK2a bed I had as a spare. I did not change the thermistor because it appears to be working just fine. It now heats up quickly to 60C but still takes a long time to get much hotter. I wonder if I have something set wrong. Is there something I should post for maybe you to look and advise me in case something is set wrong. I did copy this from my configuration file. It is worth noting that I am using a 12Volt setup, so I know it is not an instant heat. I appreciate any insight you may have to offer.

    ; Heaters
    M143 S250 ; Set maximum heater temperature
    M305 P0 T100000 B4725 C7.060000e-8 R4700 ; Set thermistor + ADC parameters for heater 0
    M305 P1 T100000 B4725 C7.060000e-8 R4700 ; Set thermistor + ADC parameters for heater 1



  • @titanhusker It could be that 60 deg C is as much as your 12V heater can manage but without know what size the bed is, how thick the heater spreader is and what size (wattage) the heater is, there is no way of knowing. If your PSU allows you to, you try upping the voltage to (say) 13V - it might help.

    M143 without an "H" parameter will default to H1 which is normally the hot end heater. Check to see if you have an M143 H0 anywhere in your configuration files because H0 is the bed heater. From around firmware version 1.17 onwards, the default bed temperature should be around 125degC so if there is no M143 H0 in your config, you can assume that the limit is set to 125 degC (but there is no harm in adding M143 H0 S125 of some other "S" value).


  • administrators

    PCB bed heaters are generally made to very poor tolerances, and they are frequently under-powered. However, the following will reduce the heating power and make heating slower:

    • Using wires that are too thin between the PSU and the Duet
    • Using wires that are too thin between the Duet and the bed heater
    • Bad connections of those wires to the Duet, bed heater and PSU. For example, terminal block screws not tight on the Duet.
    • Power supply voltage lower than the 12V or 24V that the heater is designed to work with

    If your PSU has a voltage adjustment potentiometer, then it's possible to increase heating power by turning up the voltage a little, provided that you are not already running the PSU close to its rated power.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.