M104 used by slicers, overwrites standby temps



  • Since slicers still use M104 to set extruder temps, it interferes with the standby temperatures. This is a real problem for my chimera set-up. I've resorted to re-setting standby temps in my tool change scripts, but this still means that the entire second layer I deal with oozing.

    Does M104 really need to still set both active and standby temps?



  • This behavior was changed in Version 1.20. Prior to that only active temp was set. But don't ask me why it was changed.


  • administrators

    It was changed because some people like to let the slicer manage active and standby temperatures. In particular, Cura anticipates when a tool change is imminent and sends a M104 command to heat the inactive tool to active temperature an appropriate (according to its calculations) number of lines before the tool change command. That wasn't working when M104 was only setting the active temperature.

    RRF now takes the view that if your GCode file uses M104 and M109 commands, you want the slicer to manage the temperatures. If you want to let RRF manage the temperatures, configure the slicer to generate G10 commands instead (also M116 commands if you need them).



  • Thanks for the reply and explanation.

    It appears that the only option to "fix" this would be post-processing the gcode files, initial searching doesn't yield results for using G10 in most slicers...

    I see the benefit if using Cura with it's imminent heating (would love an RRF native way to do that, but that seems...difficult:D) If there was a way to override this M104 standby behavior in RRF, I would certainly use it in favor of the really powerful tool change macros.


  • administrators

    Some slicers have a configuration section where you can specify the temperature setting commands. In other cases, you may have to post-process.


Log in to reply