Settings for silent idle steppers ender 3?



  • I've been playing around with the T0FF settings to try and make my motors silent while idle like the wiki suggests however they are still noisy at every level when idle. Since the ender 3 is a fairly common printer I was wondering if anyone else had found a solution to this?


  • administrators

    Is this a Duet WiFi/Ethernet or a Duet Maestro?



  • @dc42 duet wifi, the most recent one


  • administrators

    If you've already tried adjusting TOFF settings as described at https://duet3d.dozuki.com/Wiki/Reducing_Stand-Still_Noise the unfortunately there isn't a lot else you can do. But I know there are several Ender 3 users who have upgraded to Duet WiFi or Duet Ethernet, so perhaps one of them can report their experiences.



  • My steppers don't make much noise at all on my Ender 3 when idle or even when held at the 30% power until I send an M84 command to turn them off. Never had to make any special adjustments on mine.



  • @jamesm could you send me your stepper settings From your config file? Maybe I have something setup wrong.



  • @bay3d
    Here's the stepper section from my Ender 3. I have a pitan extruder (printable titan) so my esteps are different for it.

    M569 P0 S1 ; Drive 0 goes forwards
    M569 P1 S1 ; Drive 1 goes forwards
    M569 P2 S0 ; Drive 2 goes backwards
    M569 P3 S0 ; Drive 3 goes forwards(changed to backwards)
    M350 X16 Y16 Z16 E16 I1 ; Configure microstepping with interpolation
    M92 X80.00 Y80.00 Z400.00 E408.30 ; Set steps per mm (gregs wade was 604 steps)
    M360 E64 ; (My change) set extruder to 64 microsteps
    M566 X600.00 Y600.00 Z60.00 E600.00 ; Set maximum instantaneous speed changes (mm/min)
    M203 X10800.00 Y9000.00 Z300.00 E3000.00 ; Set maximum speeds (mm/min)
    M201 X1500.00 Y1500.00 Z30.00 E3000.00 ; Set accelerations (mm/s^2)
    M906 X850.00 Y850.00 Z850.00 E900.00 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout


Log in to reply