Blew up the E0 input on my new duetwifi



  • Hi, I just received my duetwifi from filastruder and when hooking it up to my rostock max v2 with the HE280 hotend I blew the E0 input. I forgot they shared one of the legs of the thermistor with ground for the accelerometer board and 12V backfed from the HE280 board to the 3.3V E0 input on the atmel. The pin no longer functions as a monitor for temperature. I also tried recompiling the firmware to another pin, but it seems the entire portc might be damaged as it just floats up in temp hooked to E1. I ordered another board from filastruder, is there anyway to get this board fixed or can I buy a atmel SAM4E8E configured already to transplant? Seems a shame to throw out a $170 board for a $10.00 chip. Plus I wanted to get it out there of the possible danger to the duetwifi in this configuration. Thank You



  • Haa, I was waiting for someone else to kill their processor, In my case I put 24v down the H3 pin. The chip still worked..somewhat but not right. I ended up ordering a new processor and removing the old one and drag soldering in a new one. Not something to do without experience and patience. My board has been rock solid with the replacement CPU.

    Jeff


  • administrators

    Thanks for letting us know about this - I will add a warning on the wiki. Firstly do the other temperature inputs not work (E1, Bed)? if for you may have just blown the VSSA fuse.

    If you have damaged the SAM then you can order a replacement of the most convenient supplier then use fallback procedure #1, (or #2,'3 if required) here to reflash the firmware:
    https://duet3d.com/wiki/Updating_main_firmware

    As Jeff says it can be tricky without the right kit, especially a hot air rework station to remove the old processor. If you don't want to do it yourself the forum user W3DRK might be able to help, he is in the US.



  • When it first happened the E0 stopped working, but the bed continued to work. Stupidly I moved the E0 thermistor leads to the bed connector and that stopped wortking too. I assumed I blew the input because the bed was still working? Anyway I just tested the fuse and it was open, I jumped it and with just USB and a thermistor connected all the temps are woking? I'm still a little puzzled why I thought the bed temp was working when I first damaged it if the fuse was already blown. Thank You


Log in to reply