CIrcles Eliptcal, with fla segments on the X direction



  • ![Hi, I don't now how to address the issue. I have a Ultimaker style custom printer.
    I have used it for some time with a normal ramps board.

    Since I moved to a Duet, I got used to the web interface and the other things, but I cant quite configure the printer correctly. Recently I noticed that the circles aren't printed as they should(Not Round), not even close.

    I tried to change the jerk acceleration, tried a whole lot of things, stepper motor current, jerk, printing speeds acceleration, etc.

    The consistent behavior I get is a very jerky printing. That printer used to be very silent.
    I did check all the mechanics, belts, pulleys, etc and everything looks the same.

    I used to get normal round circles with the Duet before and no jerks, but since I updated to 1.21 I am getting this.

    Any ideas?
    1_1551153714385_index2.jpg 0_1551153714384_index.jpg

    This is what the circles look like.

    the flat spot is symmetrical along the Y axis and printing a cube the dimensions are accurate.

    1 more thing, If i print a circle with infill, the infill is perfectly round, to the point where the infill in some areas overlap the outer walls or don't even touch them.
    Thanks for the help.



  • Which duet board?
    What firmware version? 1.21 is quite old.
    Can you post your config.g and the results of an M122 diagnostics taken after the problem has occured?
    Has anything else changed?


  • administrators

    Your Y axis has backlash.



  • @phaedrux
    My config is: (The Microsteping is set to 128 because I was experimenting, but same result)

    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2 on Sat Feb 02 2019 11:07:31 GMT-0600 (Central Standard Time)
    
    ; General preferences
    G90                                                ; Send absolute coordinates...
    M83                                                ; ...but relative extruder moves
    
    ; Network
    M550 P"Custom"                          ; Set machine name
    M552 S1                                            ; Enable network
    M586 P0 S1                                         ; Enable HTTP
    M586 P1 S0                                         ; Disable FTP
    M586 P2 S0                                         ; Disable Telnet
    
    ; Drives
    M569 P0 S1                                         ; Drive 0 goes forwards
    M569 P1 S1                                         ; Drive 1 goes forwards
    M569 P2 S0                                         ; Drive 2 goes backwards
    M569 P3 S0                                         ; Drive 3 goes backwards
    M350 X128 Y128 Z128 E64 I0                         ; Configure microstepping without interpolation
    M92 X640.00 Y640.00 Z3200.00 E560.00               ; Set steps per mm
    M566 X600.00 Y600.00 Z120.00 E120.00                ; Set maximum instantaneous speed changes (mm/min)
    M203 X5000.00 Y5000.00 Z5000.00 E1200.00            ; Set maximum speeds (mm/min)
    M201 X500.00 Y500.00 Z50.00 E250.00               ; Set accelerations (mm/s^2)
    M906 X1200.00 Y1200.00 Z800.00 E1360.00 I30       ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30                                            ; Set idle timeout
    
    ; Axis Limits
    M208 X0 Y0 Z0 S1                                   ; Set axis minima
    M208 X240 Y200 Z240 S0                             ; Set axis maxima
    
    ; Endstops
    M574 X1 Y1 S0                                      ; Set active low and disabled endstops
    
    ; Z-Probe
    M574 Z1 S2                                         ; Set endstops controlled by probe
    M558 P5 H5 I1 F120 T6000                           ; Set Z probe type to modulated and the dive height + speeds
    G31 P500 X34 Y3 Z1.156                             ; Set Z probe trigger value, offset and trigger height
    M557 X15:200 Y15:185 S20                           ; Define mesh grid
    
    ; Heaters
    M305 P0 T100000 B4138 R4700                        ; Set thermistor + ADC parameters for heater 0
    M143 H0 S120                                       ; Set temperature limit for heater 0 to 120C
    M305 P1 T100000 B4138 R4700                        ; Set thermistor + ADC parameters for heater 1
    M143 H1 S280                                       ; Set temperature limit for heater 1 to 280C
    
    ; Fans
    M106 P0 S0.3 I0 F500 H-1                           ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45                          ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    
    ; Tools
    M563 P0 D0 H1                                      ; Define tool 0
    G10 P0 X0 Y0 Z0                                    ; Set tool 0 axis offsets
    G10 P0 R0 S0                                       ; Set initial tool 0 active and standby temperatures to 0C
    
    ; Automatic power saving
    M911 S10 R11 P"M913 X0 Y0 G91 M83 G1 Z3 E-5 F1000" ; Set voltage thresholds and actions to run on power loss
    
    ;Filament sensor
    M591 D0 P1 C3 S1; Filament Sensor (Extruder0)
    ; Custom settings are not configured~~~~
    
    
    
    
    M122
    === Diagnostics ===
    RepRapFirmware for Duet 2 WiFi/Ethernet version 2.02RC3(RTOS) running on Duet WiFi 1.02 or later
    Board ID: 08DGM-956GU-DJMSN-6JKDJ-3SJ6T-K9N7D
    Used output buffers: 3 of 20 (9 max)
    === RTOS ===
    Static ram: 28532
    Dynamic ram: 98576 of which 0 recycled
    Exception stack ram used: 368
    Never used ram: 3596
    Tasks: NETWORK(ready,328) HEAT(blocked,1232) MAIN(running,3564)
    Owned mutexes: WiFi(NETWORK)
    === Platform ===
    Last reset 13:54:46 ago, cause: software
    Last software reset at 2019-02-25 22:19, reason: User, spinning module GCodes, available RAM 3612 bytes (slot 3)
    Software reset code 0x0003 HFSR 0x00000000 CFSR 0x00000000 ICSR 0x0041f000 BFAR 0xe000ed38 SP 0xffffffff Task 0x4e49414d
    Error status: 0
    Free file entries: 10
    SD card 0 detected, interface speed: 20.0MBytes/sec
    SD card longest block write time: 0.0ms, max retries 0
    MCU temperature: min 28.4, current 29.8, max 34.6
    Supply voltage: min 0.4, current 12.2, max 12.3, under voltage events: 1, over voltage events: 0
    Driver 0: standstill, SG min/max 0/23
    Driver 1: standstill, SG min/max 0/247
    Driver 2: standstill, SG min/max 129/304
    Driver 3: standstill, SG min/max not available
    Driver 4: standstill, SG min/max not available
    Date/time: 2019-02-26 12:14:21
    Cache data hit count 4294967295
    Slowest loop: 2.79ms; fastest: 0.06ms
    === Move ===
    Hiccups: 0, StepErrors: 0, LaErrors: 0, FreeDm: 240, MinFreeDm: 236, MaxWait: 11132ms, Underruns: 0, 0
    Scheduled moves: 7, completed moves: 7
    Bed compensation in use: none
    Bed probe heights: 0.000 0.000 0.000 0.000 0.000
    === Heat ===
    Bed heaters = 0 -1 -1 -1, chamberHeaters = -1 -1
    === GCodes ===
    Segments left: 0
    Stack records: 1 allocated, 0 in use
    Movement lock held by null
    http is idle in state(s) 0
    telnet is idle in state(s) 0
    file is idle in state(s) 0
    serial is idle in state(s) 0
    aux is idle in state(s) 0
    daemon is idle in state(s) 0
    queue is idle in state(s) 0
    autopause is idle in state(s) 0
    Code queue is empty.
    === Network ===
    Slowest loop: 14.08ms; fastest: 0.00ms
    Responder states: HTTP(0) HTTP(0) HTTP(0) HTTP(0) FTP(0) Telnet(0) Telnet(0)
    HTTP sessions: 1 of 8
    - WiFi -
    Network state is running
    WiFi module is connected to access point
    Failed messages: pending 0, notready 0, noresp 0
    WiFi firmware version 1.21
    WiFi MAC address 5c:cf:7f:76:6e:6d
    WiFi Vcc 3.35, reset reason Turned on by main processor
    WiFi flash size 4194304, free heap 13200
    WiFi IP address 192.168.0.13
    WiFi signal strength -48dBm, reconnections 0, sleep mode modem
    Socket states: 0 0 0 0 0 0 0 0
    === Filament sensors ===
    Extruder 0 sensor: ok
    === Expansion ===


  • @dc42

    How to I check this?
    Everything looks fine, Should I replace the belts? They look tight enough.

    Any recommendations?



  • I see you're running a release candidate of 2.02rc3, which is no longer supported now that the full version of 2.02 is out. Please update to 2.02 and see if anything changes.

    You config looks out I think. Can you confirm that the problem still is present when using x16 microsteps with interpolation?



  • I will try it and post the results, I had x16 microsteping before and had the same behavior.
    Thanks for the help ☺



  • It definitely seems mechanical in nature. There are lots of pulleys and belts and rods and bearings in the ultimaker style gantry. Lots of things to go astray. Give it a really close visual inspection while it's running.



  • Well I checked all the pulleys and replaced the belts, adjusted the tension on the small bets that go from the X / Y motor to the 8mm shafts.

    Updated the firmware, and reverted the config to 169microsteps interpolated. Got the exact same result.
    Printing id very jerky, the slicer does a fast perimeter and them a couple of slow ones, the fast one is very smooth and noiseless but the slow ones are jerky and very noisy.

    My Steppers are 1.8º rated for 1.7A, but the one on the Z axis is rated for 1.2A.

    This printer used to be very very quite after I installed the duet board and gave me many beautiful prints with no problems at all and a very smooth surface finish.

    I don't know if I changed a config that did all this, but I cant find the source cause of the issue.
    I have new bearings for the sliders and Extruder cariage. Will replace those and see what happens.



  • Replaced the bearings, Even tough the problem, is not solved, I think the mechanical part of it is. The motion system moves so smooth now, I dont think it has ever been that smooth. The printing results are 50% better. But there is still the jittering. I don't understand.

    Well I will keep on investigating. Just FYI the printer has no printed parts other than the fan duct.
    I swapped the extruder carriage for a printed part in hopes the softer material would align the rods better, but same result. The previous one was a aluminum milled one.

    I will post any changes.



  • Try printing circles in multiple spots on the bed just to see if it is consistent.

    There are no moving Stepper motors are there?

    There are two times I had jittering, once was a broken stepper wire, once was when I had stepper amps too low on accident.

    If you can see if it is related to one or all axes that would be great (the jittering).

    Another thought, make certain that all your stepper pulley grub screws are tight and in the flats of the shafts.



  • Could you post a video of it in action?

    Are the rods themselves bent or grooved at all?



  • @wyvern I did a very thorough mechanical check and found one belt that was tighten on the slider side and a bit loose on the "free" side (Where it runs parallel to the slider block), As I had a new set of belts and the ones on it a very old give or take 5 years, I ended up replacing them all and adjusted tension on every component.
    The rods are straight and I think that the real mechanical problem I had where the brass bushings, that I replaced by actual ball bearings.
    That gave me a much better result.
    Another thing I did was upgrade the firmware and the config changes suggested above.
    The printer runs a bit louder, but reasonably quieter than my older printer. Probably the ball bearings.

    I will keep testing and calibrating it. Will post the results.



  • @phaedrux The Rods have no groves and aren't bent (At least to my ability to check it, I am no professional).

    The bearings slide free, and if I remove the carriage and belts, gravity alone moves the sliding blocks and the bearings.

    I will try to make a video and post it.

    Thanks for the help so far!



  • Well I was printing to make a video, but I don't know how yet the problem is gone. I assume so far that the previous 6mm bearings (Brass bushings) where the problem. Printed 6h no problem.

    Thanks for everyone that helped! Also if you have a similar printer this link will help you a lot!

    https://support.3dverkstan.se/article/23-a-visual-ultimaker-troubleshooting-guide


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.