Duet wifi configuration



  • Hello, Ive been using for a long time mks board (5xtmc2208s) with e3d v6 clone and anet a8 stock extruder. Everything worked well but I decided to upgrade my 3d printer... So I ordered duet wifi, gold e3d v6 and bondtech bmg extruder. Since upgrading Ive been having problems. Im not able to get perfect print as I used to. I think its some problem with relative/absolute extrusion as Ive read a lot about it that a lot of people are having some problems. Can you please check my config if theres everything set correctly?

    config.g

    ; Configuration file for Duet WiFi (firmware version 1.21)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2 on Mon Jan 21 2019 18:22:25 GMT+0100 (stredoeurópsky štandardný čas)

    ; General preferences
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves

    ; Network
    M550 P"Duet 2 Wifi" ; Set machine name
    M552 S1 ; Enable network
    M587 S"Rybar94" P"a5s6g1d2g5" ; Configure access point. You can delete this line once connected
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Drives
    M569 P0 S1 C65974 ; Drive X goes forwards and gets TOFF=6
    M569 P1 S0 C65974 ; Drive Y goes backwards and gets TOFF=6
    M569 P2 S0 C65971 ; Drive Z goes backwards and gets TOFF=3
    M569 P3 S1 C65972 ; Drive E0 goes forwards and gets TOFF=4 (default)
    M92 X53.33 Y100 Z400 E402.91 ; Set steps per mm (at default 16x microstepping)
    M350 X16 Y16 Z16 E16 I1 ; Configure microstepping with interpolation

    ;default reprap
    M566 X900.00 Y900.00 Z12.00 E120.00 ; Set maximum instantaneous speed changes (mm/min)
    M203 X6000.00 Y6000.00 Z180.00 E1200.00 ; Set maximum speeds (mm/min)
    M201 X500.00 Y500.00 Z20.00 E250.00 ; Set accelerations (mm/s^2)
    ; end default reprap

    M906 X1000 Y1000 Z1000 E1300 I30 ; Set motor currents (mA) and motor idle factor in percent (increments of 100mA, rounded down otherwise)
    M84 S15 ; Set idle timeout

    ; Axis Limits
    M208 X-27 Y-79 Z0 S1 ; Set axis minima
    M208 X218 Y220 Z230 S0 ; Set axis maxima

    ; Endstops
    M574 X1 Y1 S0 ; Set active low and disabled endstops

    ; Z-Probe
    M574 Z1 S2 ; Set endstops controlled by probe
    M307 H4 A-1 C-1 D-1 ; Disable heater on PWM channel for BLTouch
    G31 P500 X32 Y5 Z5 ; Set Z probe trigger value, offset and trigger height
    M557 X15:195 Y15:195 S45 ; Define mesh grid

    ; Heaters
    M307 H0 B0 S1.00 ; Disable bang-bang mode for the bed heater and set PWM limit
    M305 P0 T100000 B4138 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; Set temperature limit for heater 0 to 120C
    M305 P1 T100000 B4725 R4700 C7.060000e-8 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S280 ; Set temperature limit for heater 1 to 280C

    ; Fans
    M106 P0 S0 I1 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off

    ; Tools
    M563 P0 S"Hot End" D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Automatic saving after power loss is not enabled

    ; Custom settings are not configured

    M307 H3 A-1 C-1 D-1
    M558 P9 X0 Y0 H5 F100 T2000 ;A3 S0.07
    G31 X0 Y19 Z1.65 P25 ;Nozzle Distance from BED - Offset. Higher value, closer to bed
    M501 ; read eeprom
    T0 ; select tool 0

    Start gcode

    G21 ;metric values
    G90 ;absolute positioning
    M82 ;set extruder to absolute mode
    M107 ;start with the fan off
    G28;
    G29;
    G1 Z15.0 F9000 ;move the platform down 15mm
    G92 E0 ;zero the extruded length
    G1 F200 E3 ;extrude 3mm of feed stock
    G92 E0 ;zero the extruded length again
    G1 F9000
    ;Put printing message on LCD screen
    M117 Printing...

    end gcode

    M104 S0 ;extruder heater off
    M140 S0 ;heated bed heater off (if you have it)
    G91 ;relative positioning
    G1 E-1 F300 ;retract the filament a bit before lifting the nozzle, to release some of the pressure
    G1 Z+0.5 E-5 X-20 Y-20 F9000 ;move Z up a bit and retract filament even more
    G28 X0 Y0 ;move X/Y to min endstops, so the head is out of the way
    M84 ;steppers off
    G90 ;absolute positioning

    Im using cura 3.6 and yes I changed flavor to reprap



  • Can you give more information on what the actual problem in the print is?
    Slicer settings? Photos? Sample gcode?

    The only issue with relative versus absolute extrusion occurs if you have absolute set and try to retract at the end of the print. The difference between retract by 1mm and retract to the first 1mm of filament used is a big one.

    Internally, extruder moves are converted to relative moves anyway.

    From your config I notice is that your extruder jerk and acceleration are quite low. I'd increase them by a factor of 10. M566 E1200 and M201 E2500

    Also your max XY speed is 100mm/s which may be limiting your travel speeds?

    Are your motor currents in the range of 70-85% of the rated max for the motor?

    Your steps per mm for your extruder are on the low end of acceptable. You may get improved results by increasing your microstepping on the E axis to x32 or x64. You cn test this by simply adding M350 E32 below your existing M350 entry. Keep in mind that the higher your microstepping, the lower your max extruder acceleration and retraction speed can be without missing steps.



  • I'm also interested in this. I upgraded my prusa clone to a BMG. Is your Anet direct drive and not bowden? @Phaedrux. Those numbers seem really high. is there any drawback to running acceleration and jerk that high for a direct drive?



  • @ctilley79 said in Duet wifi configuration:

    Those numbers seem really high. is there any drawback to running acceleration and jerk that high for a direct drive?

    Not that I've found. And I use values far higher than those on my Titan Aero with 0.9 degree motor at x64 microstepping. Retracting 0.8mm at 50mm/s

    M201 X6000 Y6000 Z30 E8000  ; Set maximum accelerations (mm/s^2)
    M203 X15000 Y15000 Z300 E15000  ; Set maximum speeds (mm/min)
    M204 P1000 T4000 ; Set printing and travel accelerations
    M566 X900 Y900 Z30 E3000 ; Set maximum instantaneous speed changes (mm/min) (Jerk)
    


  • thank you for your replies, Im using 1.5A motors. My prints are not consistent... if I try to print any test cube its fine, but when I try to print cali cube with letters xyz the cube has some layers over/under extruded. Ill post some photos. What values would you recommend me to change? Im new to RRF so I have no idea. I tried Cura 3.6 and also Slic3r prusa edition... The prints from cura gcodes are worse than using slic3r. In the pictures are cali cubes, on the left from cura and on the right from slic3r. You can see some inconsistent extrusion maybe? Theres not anything wrong with my Z axis as it can look because when I print simple cube its perfect.

    alt text

    alt text



  • It looks retraction related to me.

    Have you done any retraction tuning yet?
    Have you tried the changes I posted above?
    What is your extruder?
    How much retraction are you using?
    Have you calibrated your E steps?
    Have you done a PID tuning of the heater?
    Is Cura using Coasting?



  • @phaedrux it looks same even without retraction enabled, the extruder is genuine bondtech bmg and coasting is disabled.. I havent tried the new settings yet, but I will report soon. The extruder is calibrated and I also did PID tuning



  • Changed the jerk and acceleration for Extruder and this is the result

    alt text



  • @rybar94 Something else looks like it's going on here. Check the grub screws on all your motor pulleys etc. something seems loose.



  • One thing came on my mind... couldnt be the problem line width setting in slicer? Im using 0.4mm nozzle and line width is set to 0.4mm too... I saw somewhere that this should be set to 1.2x of nozzle size



  • I get the exact same cali cube. I have an Ender 3 Pro with Duet Ethernet, BLTouch, Bondtech BMG and E3D V6 Gold Edition.

    As you can see in @rybar94 's photo, the heavy extrusion issues appear mainly in the corners of one or both directions and under or above the letters. Other than that, there are a lot of horizontal lines appearing throughout the print.



  • @rybar94 said in Duet wifi configuration:

    One thing came on my mind... couldnt be the problem line width setting in slicer? Im using 0.4mm nozzle and line width is set to 0.4mm too... I saw somewhere that this should be set to 1.2x of nozzle size

    That's debatable. You can go larger than nozzle width, and even a little bit lower, but it's going to depend a lot on the nozzle tip geometry on how the actual print quality works out. 1.2x nozzle size seems a little specific. What if my nozzle is 1.2mm? Should I really be extruding 1.44mm? Because of the circular cross section that's substantially more flow rate. Maybe 1.2x makes sense for 0.4 nozzle, but I don't think it scales well.

    Personally, I find a get best print quality when extrusion width = nozzle width. I may fine tune it up a bit for infill or inner perimeters, but outer perimeters and solid infill tend to get a bit messy when over extruding in my experience.



  • @phaedrux I did another test print, result is almost the same... so thats not the problem...



  • @larjohn did you manage to fix that? The cali cube is little bit nicer when I use slic3r instead of cura.... but far away from the quality I used to get



  • Another strange thing is that I think flow setting in cura doesnt have any effect on print... In the picture you can see cali cubes, on the left 90% flow and on the right 110%.... they look almost the same

    alt text



  • I switched back to my old board, same steps, same acceleration, same jerk and every other settings... the cube is perfect! Im done with duet


  • administrators

    @rybar94 said in Duet wifi configuration:

    I switched back to my old board, same steps, same acceleration, same jerk and every other settings... the cube is perfect! Im done with duet

    Are you absolutely certain that you are using the same acceleration, speed and jerk settings, and also the same motor
    currents? Please post your settings for Duet/RRF and for your other board.



  • I haven't managed to fix this either. I improved the result by perfecting bed leveling and extrusion and especially pressure advance. Still, the result is worse than that I had (with Klipper) before upgrading:

    • More horizontal lines
    • More ringing
    • Characteristic corner artifacts (above and below the letters)


  • @larjohn Perhaps start your own thread with your specifics to see what troubleshooting can be done.



  • I 'll find some time, possibly this weekend and start a thread with photos an configuration.


Log in to reply