BLtouch is triggering but not stopping axis from moving



  • Hey all,

    I just made the transition from Marlin finally and its been pretty easy going besides this one last issue which has been driving me absolutely crazy trying to figure out...

    On power on, the BLTouch does its self test just like in Marlin.
    The light on the probe goes off with the pin being down and when the pin is pushed in, it retracts and the light comes on as expected.

    M401 & M402 respond as intended. I have macros created to test the probes functionality and all of those also respond as intended.

    When I try to home Z, when the probe is triggered it retracts but it does not stop the axis from moving down. Instead it just deploys the pin again.

    I have reviewed this: https://duet3d.dozuki.com/Wiki/BLTouch_Troubleshooting
    I do have the BLTouch classsic and have not added the resistor but it doesn't sound like that is not the issue?

    My issue must be in my config, right?? I have it hooked up to heater 7 as seen below:

    ; Configuration file for Duet WiFi (firmware version 1.21)

    ; General preferences
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves

    ; Network
    M552 S1 ; Enable network
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Drives
    M569 P0 S0 ; Drive 0 goes forwards
    M569 P1 S0 ; Drive 1 goes forwards
    M569 P2 S1 ; Drive 2 goes forwards
    M569 P3 S1 ; Drive 3 goes forwards
    M569 P4 S1 ; Drive 4 goes forwards
    M350 X16 Y16 Z16 E16:16 I1 ; Configure microstepping with interpolation
    M92 X80.00 Y40.00 Z400.00 E415.00:415.00 ; Set steps per mm
    M566 X600.00 Y600.00 Z23.40 E120.00:120.00 ; Set maximum instantaneous speed changes (mm/min)
    M203 X12000.00 Y12000.00 Z240.00 E1800.00:1800.00 ; Set maximum speeds (mm/min)
    M201 X550.00 Y550.00 Z100.00 E250.00:250.00 ; Set accelerations (mm/s^2)
    M906 X800.00 Y800.00 Z800.00 E800.00:800.00 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; Set axis min
    M208 X295 Y277 Z295 S0 ; Set axis max

    ; Endstops
    M574 X1 Y1 S0 ; Set active low endstops

    ; Z-Probe
    M574 Z1 S2 ; Set Z endstops controlled by probe
    M307 H7 A-1 C-1 D-1 ; Disable heater 7 on PWM channel for BLTouch
    M558 P9 H5 F500 T9000 A3 ; Set Z probe type to bltouch and the dive height + speeds, try up to 3 times for each point for accuracy
    G31 P25 X9 Y-52.7 Z0.0 ; Set Z probe trigger value, offset and trigger height
    M557 X15:240 Y15:240 S20 ; Define mesh grid

    ; Heaters
    M305 P0 T10000 B3988 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; Set temperature limit for heater 0 to 120C
    M305 P1 T100000 B4388 C7.060000e-8 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S280 ; Set temperature limit for heater 1 to 280C
    M305 P2 T100000 B4388 C7.060000e-8 R4700 ; Set thermistor + ADC parameters for heater 2
    M143 H2 S280 ; Set temperature limit for heater 2 to 280C

    ; Fans
    M106 P0 S0 H-1 ; Set fan 1 value, default speed 0%
    M106 P2 S0 H-1 ; Set fan 2 value, default speed 0%

    ; Tools
    M563 P0 S"Left Nozzle" D0 H1 ; Define tool 0
    G10 P0 X9 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C
    M563 P1 S"Right Nozzle" D1 H2 ; Define tool 1
    G10 P1 X-9 Y0 Z0 ; Set tool 1 axis offsets
    G10 P1 R0 S0 ; Set initial tool 1 active and standby temperatures to 0C



  • How do you have it wired up?

    What does your homeall.g and Homez.g macros look like?

    Double check the wiring for continuity. Damaged crimps are very very common.

    https://duet3d.dozuki.com/Wiki/Connecting_a_Z_probe#Section_BLTouch

    Use the method described here to test it using G30 from the console.
    https://duet3d.dozuki.com/Wiki/Test_and_calibrate_the_Z_probe



  • @mikea702 said in BLtouch is triggering but not stopping axis from moving:

    M558 P9 H5 F500

    Unrelated, but you'll get more accurate probe results out of it if you slow down your probing speed to F100 or so. If this makes homing unbearable slow you can modify the homing macro to probe once quickly to get the probe to the bed fast, and then probe again at a slower rate for accuracy.



  • Testing it per the dynamic test described in the linked article, it failed to stop the Z axis when triggered.

    As for the wiring I mainly followed this walk-through: https://betrue3d.dk/bltouch-on-duet-wifi-duetreprapfirmware/

    0_1551485588955_IMG_20190301_160755.jpg

    @phaedrux said in BLtouch is triggering but not stopping axis from moving:

    @mikea702 said in BLtouch is triggering but not stopping axis from moving:

    M558 P9 H5 F500

    Unrelated, but you'll get more accurate probe results out of it if you slow down your probing speed to F100 or so. If this makes homing unbearable slow you can modify the homing macro to probe once quickly to get the probe to the bed fast, and then probe again at a slower rate for accuracy.

    Good advice, I'll probably end up doing a fast probe followed by a slower one as advised.. just haven't got that far yet 😅



  • Check the wiring. Especially the Z probe connector.



  • Sorry, forgot to send my homeall.g and Homez.g files but reversing the probe wires worked! I would have never guessed that. Thank you so much!



  • Glad it's working.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.