Stepper Motors make noise but don’t move



  • Hi all,
    I just set up my brand new duet 2 wifi to be use with my cartesian 3d printer.
    My problem is that if I move the motors through the “machine control” panel (after disabling the homing safety) they make a sound but don’t actually move. And this sound is forever or until I reset the board.
    How is this possible?
    Anyone’s got a similas problem/solution?

    Thanks
    Luca



  • sounds like you may have atleast one of the phases for the stepper mixed up, i actually did the same thing earlier today

    also if you send an m84 does the noise stop?



  • If there is a danger that you have miss wired the steppers turn the board off, disconnect and check them. Do not rely on wire colours. Non-colourblind people put too much trust in colour! 😉

    Read the 'Identifying The Stepper Motor Phases' on here: https://duet3d.dozuki.com/Wiki/Choosing_and_connecting_stepper_motors

    Then check the wiring diagram https://d17kynu4zpq5hy.cloudfront.net/igi/duet3d/YN2oahyGpcPNN1Pw.huge to ensure the phases are connected to the right pins.

    Check your steps per mm are correct, current limit set to about 80% of spec limit (or the limit for the duet if that is lower) and your acceleration, instantaneous speed, and max speed are reasonable.

    If all above is good then share your stepper motor specs and config.g.



  • Swap the middle wires on one side of the cable



  • @denis These boards can be fried by user error on stepper wiring.

    I would strongly advice against assuming the stepper is wired wrong and swapping wires as it may have been wired right to start with with say a far too low current setting, instant speed too high, or acceleration setting too high.

    Follow the guide in the manual and be sure. Don't chance it.



  • Finally i got it right. Actually It was right from the beginning but since I was hearing the whine noise coming from the stepper motors I thought something was upset. But by searching online I realised that it is just “normal”.
    The point is that I am coming from a dead silent Rumba with tmc2228 and I was not expecting all this noise from a duet with tmc2660.
    I tweak a bit the TOFF prameter as suggested by others but it made a very little difference.
    The printer is printing good and comparing to the rumba it seems to be more “consistent “. However the printer now is far from being silent...
    Finally I read that this noise is due to the high phase inductance of my stepper motor: 8.4mH.
    Could anyone confirm this?
    And, are your motors whining and scratching like mine?

    Many thanks
    Luca


  • administrators

    8.4mH is indeed rather high. Are you using 12V or 24V power?



  • I use 24v. So, do you think that by using a motor with similar specs but with a lower phase inductance of, let’s say, 2.8mh, the noise will reduce?

    Thanks
    Luca


  • administrators

    The motors in my 24V delta are also around 2.8mH inductance. There is a hissing sound from them when the machine is idle. When the current drops to the idle level (by default this is after 30 seconds), it is barely audible. When the machine is printing, I can barely hear any motion noise above the fans.

    So I can't promise that using lower inductance motors will reduce the idle noise, without knowing how bad it is with your current motors. The TMC2660 drivers don't have the stealthChop mode that the TMC2208/TMC2224 drivers do, so it's hard to make thee motors completely silent when not moving. OTOH, when the motors are moving I find it advisable not to use stealthChop on the TMC2224 because it increases the risks of layer shifts. So IMO, stealthChop is only really useful for reducing motor idle noise. I'm guessing that the Prusa i3 Mk3 also uses it when printing in its "slow and quiet" mode.



  • I understand, maybe I will continue with my motors since it’s actually not very bad. I’ll rather put this money on other tangible improvements.
    Thank you very much for your time and for developing such a great board/firmware like the duet!

    Many thanks
    Luca