BLTouch "ERROR: Z probe was not triggered during probing move"



  • Hardware setup:
    Duet2+Duet Expansion Breakout Board. The BLTouch is powered through H6 on breakout board and signal fed through E1 on the Duet board.

    Config setup (see attached):
    Firmware 1.19.2, however we updated to 2.02 to see if that would resolve the issue, with the added ability to use mode 9, the issue seems identical, changed nothing.
    M558 uses mode 6 (M558 P6 X0 Y0 Z1 H5 F120 T6000), we also tried mode 9 with the same wiring setup and mode 5 with the wiring changed from E1 to z-probe pins.

    The probe is able to retract/deploy through either macros or M401/402 just fine, and enter test mode through S120.

    However when G30/G30 S-1 is used, the carriage moves downwards until the z-endstop is engaged, with the following error: "Z probe was not triggered during probing move". It does this regardless if the probe is triggered during the move or forced to enter alarm mode. The P value seems to stay at 0 (P0) regardless of what is done.

    In mode 9 we get a different error "Z probe already triggered at start of probing move", the P value seems stuck at 1000 (P1000).

    We checked the signal continuity with everything being in working order, It seems like the signal is not being read.

    What could the issue be?

    The printer is a 3DP workseries 400.

    0_1551695637444_config.g


  • administrators

    @alexanderpetersen said in BLTouch "ERROR: Z probe was not triggered during probing move":

    In mode 9 we get a different error "Z probe already triggered at start of probing move", the P value seems stuck at 1000 (P1000).

    Mode 9 is correct, assuming you are still running firmware 2.02. If P is stuck at 1000 then you don't have the white wire connected to the correct pin of the Z probe connector. It should not be connected to the E endstop input. See https://duet3d.dozuki.com/Wiki/Connecting_a_Z_probe#Section_BLTouch. If deploy/retract is working then it's only the white and black wires that you need to move.



  • Thank you for the swift reply,

    I changed it to P9 and the wiring to the z probe connector, this resolved the issue of being stuck at P1000.

    However it displays the same behavior when executing G30 S-1, jogs down until the z-endstop is hit, with the error
    "Z probe was not triggered during probing move".

    The P value seems stuck at 0, regardless of what is done to the probe (testmode/retract/deplay/alarmstate).

    Furthermore after executing G30 S-1 causes the z-coordinate to be "-5"


  • administrators

    Have you run this test procedure https://duet3d.dozuki.com/Wiki/Test_and_calibrate_the_Z_probe

    The BLTouch outputs a short pulse, so it's normal that most times you don't see the Z probe reading jumping to 1000, however triggering the probe should still stop the G30 move.



  • Yeah, i have run the dynamic test quite a few times, with the same result as described earlier.

    I've uploaded a video of the issue, maybe that is of help to get this issue fixed.
    (The video is a few weeks old, and and i changed some settings so that the printer does not move up after the attempted probing move as in the video, it simply stops after the end stop is hit)

    https://youtu.be/Y14UkNjvogk


  • administrators

    Please check that you have the black and white wires the right way round in the Z probe connector, like this:

    alt text

    The white wire goes to the leftmost pin, the black wire to the next pin. Also confirm that you are still using firmware 2.02.



  • Checked the wire placement and continuity, it's as shown in the picture,
    The version is 2.02, confirmed through the web interface and M115 command.

    I have two control boxes, a wifi and ethernet version (currently in-use), both appear to have the same issues regarding the probe, making me assume that it's not a case of faulty hardware.


  • administrators

    In your video, the probe is going into the red flashing error state when it triggers. Does it do that even if you trigger it when it is doing a G30 move and is still well above the bed? If so then I suggest you try to work out why the probe goes into an error state.



  • In your video is looks like you have the pin deployed before sending the G30. The Duet will control the pin deployment automatically if you're using up to date firmware and probe type 9.



  • When the pin is pushed up during a probing move, by a slight push it doesn't retract itself, it falls down, this can be repeated. It only enters error state when its held up for a bit (For instance when it hits the bed and is pushed up continuously).

    I recorded a vid of the above, not during a probing move, but static state, the probe seems to exhibit the same behavior during static/probing move.

    VIDEO LINK

    The probe behavior when pushed/manipulated, is that directed by " deployprobe.g" and "retractprobe.g",
    or by something else? The probe is able to articulate itself just fine by M401 and M402.

    @Phaedrux
    The video was before i updated the firmware to 2.02, sorry that i did not make that clear.
    The probe does indeed deploy itself with a G30 command and mode 9.


Log in to reply