Static IP Issues



  • So I am able to connect to my wireless network. The issue is that the unit aways picks up a DHCP address and not the static IP I have configured.

    Here is my configuration...
    ; Network
    M550 P"Tronxy x5s" ; Set machine name
    M551 P"xxxxxxxxx" ; Set password
    M552 S1 ; Enable network
    M587 S"xxxxxxxxxx" P"xxxxxxxxxx" I192.168.0.229 J192.168.0.1 K255.255.255.0 ; Configure access point and IP addresses. You can delete this line once connected
    M586 P0 S1 ; Enable HTTP
    M586 P1 S1 ; Enable FTP
    M586 P2 S1 ; Enable Telnet

    Any help would be appreciated.

    Thanks.



  • Are you sure the address you're trying to use is actually free on the network?

    Do you have access to the router configuration? It's usually better to use the router DHCP reservation table to assign a permanent IP to the Duet.





  • Step 7 is where you should be setting the static IP address.

    https://duet3d.dozuki.com/Guide/1.)+Getting+Connected+to+your+Duet/7



  • It may be worth using a plain M587 to see what networks have been set up, then deleting them with M588 before starting again.

    https://duet3d.dozuki.com/Wiki/Gcode#Section_M588_Forget_WiFi_host_network

    This is done while connected via USB and once configured the wifi module remembers the settings though power cycles with no need for the lines in the config file.

    Edit: I'm guessing you followed the instructions right once to setup you duet to your network but then decided to use a static IP. You added the M587 with static IP to the config, but because the adaptor was enabled in the previous lines the M587 had no effect. The wifi module had already connected to the network with previously stored values.

    As Phaedrux says though, better to use your router for static address management anyway - it is harder to accidentally assign the same address to two devices. In this case just delete the M587 from your config and set up a reserved IP adress on your router based on the Duet's Mac address.



  • Thank you all...got it sorted.



  • Do you have config-old.g....? I haved similar issue. An after search, do you have to edit config-old. G


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.