slicer scaling behaviour... wild...



  • Hi! I need help with simplify3d scaling… I am trying to print figure as below… In the model external size (marked with red) is 29.214mm and internal circle is 6.4 mm.

    Once printed in 100% scale external is 28.9 and internal is 5.0 ☹ once I adjust scale to 101,08 external prints with tiny difference, but internal is still very small. To print internal in right size I need to use 128% scale ☹ but it drives external size far away…

    Which settings should I consider to be changed?

    Many thanks!
    0_1552907286041_5be5c66a-2bca-42fa-bae3-4dae68f3ccf6-изображение.png



  • Under Other tab on the Process settings you should have Horizontal size compensation. Change that to 0,7mm
    You should be close for the internal diameter.
    https://forum.simplify3d.com/viewtopic.php?t=2042

    But if you made the model, try increasing the dimensions.



  • That's a huge différence; you may have some over-extrusion?



  • At first I also thought of over-extrusion, but then also the outside dimension would be bigger, but it's also smaller.
    Something is not completely OK here.



  • My bad, I mis-read the outer dimensions!



  • @obeliks

    Under Other tab on the Process settings you should have Horizontal size compensation. Change that to 0,7mm

    thanks! that is a very strange parameter for me. with test i have figured out that -0.25 mm worked with my 101,08 scale.. however that ratio brought down external size 🙂 in my particular case i can live with that, but it is very and very strange...



  • Check X and Y steps/mm just to be sure.



  • slicer i guess is a crap... with settings above radial holes are tight as it should be, central one in loose.... in CAD they are all the same..



  • I'm pretty sure you have a hardware/firmware configuration issue... There is absolutely no reason S3D changes holes dimensions depending where they are on the plate.



  • CAD settings are below. as well as motor settings. printer is delta

    M569 P0 S1				; Drive 0 goes forwards
    M569 P1 S1				; Drive 1 goes forwards
    M569 P2 S1				; Drive 2 goes forwards
    M569 P3 S0				; Drive 3 goes forwards (extruder)
    
    M350 X16 Y16 E16 I1    			; Set 16x microstepping with interpolation
    
    M574 X2 Y2 Z2 S1			; set endstop configuration (all endstops at high end, active high)
    M666 X0 Y0 Z0				; put your endstop adjustments here, or let auto calibration find them
    
    M665 R102 L288.17 B75 H152		; set delta radius, diagonal rod length, printable radius and homed height
    ; H152 for standart 
    ; H142 for volcano
    
    M92 X80 Y80 Z80				; Set axis steps/mm http://prusaprinters.org/calculator/#stepspermmbelt 
    
    M906 X1250 Y1250 Z1250 E700		; Set motor currents (mA) 85% of rated
    M906 I30				; Set Idle factor to 30%
    
    M201 X1000 Y1000 Z1000 E120		; Accelerations (mm/s^2)
    M203 X20000 Y20000 Z20000 E600		; Maximum speeds (mm/min)
    M204 P500 T2000				; Maximum Print and Travel acceleration
    

    0_1552995177442_1e663d63-9649-41da-a36c-260319435c78-изображение.png



  • As @OBELIKS said, re-check M92 values. And as your printer is a delta, re-check the calibration.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.