Heater 1 displays wrong temperture



  • I have just installed my new Duet wifi board on my Ender 3. Everything works how it should (all axes homing correct....)exept one strange thing. I have not turned on the heated bed or the nozzle jet. The Current temperture for the bed displays 19.8deg. Celcius, but the Heater 1 displays a current temperture of 107.9deg Celsius. This can not be correct since it has not been turned on and also it feels cold to the touch. Does anybody know what can be wrong here and how to fix this?



  • @svdeene Need more information https://forum.duet3d.com/topic/5909/guide-for-posting-requests-for-help

    At the minimum, we need to know what settings you are using so please post your config.g file. We also need to know what type of temperature sensor you are using (thermistor, PT100, PT1000, thermocouple), how it's connected and if possible a data sheet.



  • Config.g:
    ; Configuration file for Duet WiFi (firmware version 1.21)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2 on Wed Mar 13 2019 19:55:57 GMT+0100 (Midden-Europese standaardtijd)

    ; General preferences
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves

    ; Network
    M550 P"Ender 3" ; Set machine name
    M552 S1 ; Enable network
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Drives
    M569 P0 S0 ; Drive 0 goes forward
    M569 P1 S0 ; Drive 1 goes forwards
    M569 P2 S1 ; Drive 2 goes forwards
    M569 P3 S1 ; Drive 3 goes forwards
    M350 X16 Y16 Z16 E16 I1 ; Configure microstepping with interpolation
    M92 X80.00 Y80.00 Z400.00 E93.00 ; Set steps per mm
    M566 X1200.00 Y1200.00 Z24.00 E300.00 ; Set maximum instantaneous speed changes (mm/min)
    M203 X30000.00 Y30000.00 Z300.00 E1500.00 ; Set maximum speeds (mm/min)
    M201 X500.00 Y500.00 Z100.00 E5000.00 ; Set accelerations (mm/s^2)
    M906 X400.00 Y400.00 Z400.00 E800.00 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S300 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X245 Y245 Z250 S0 ; Set axis maxima

    ; Endstops
    M574 X1 Y1 Z1 S0 ; Set active low and disabled endstops

    ; Z-Probe
    M558 P5 H5 F0 T6000 ; Set Z probe type to switch and the dive height + speeds
    G31 P500 X0 Y0 Z0 ; Set Z probe trigger value, offset and trigger height
    M557 X9.5:8 Y5:195 S20 ; Define mesh grid

    ; Heaters
    M305 P0 T100000 B4138 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; Set temperature limit for heater 0 to 120C
    M305 P1 T100000 B4138 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S280 ; Set temperature limit for heater 1 to 280C

    ; Fans
    M106 P0 S0 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Automatic power saving
    M911 S10 R11 P"M913 X0 Y0 G91 M83 G1 Z3 E-5 F1000" ; Set voltage thresholds and actions to run on power loss

    ; Custom settings are not configured

    I use the stock temperature sensor from the Ender 3 (I think it is a PT100) it is connectod to the E0 VSSA thermistor1 (just left of the E1 endstop on the wifi board)


  • administrators

    Your config.g settings look reasonable for 100k thermistors on both the bed and hot end. The sensor can't be a PT100 because that would give a reading of about 320C with those settings. I think either it's a 5K thermistor (which would be very unusual), or something is wrong.

    First, I suggest that you temporarily swap the bed and E0 thermistor connections over on the Duet. If the bed now reads 108C and the hot end reads room temperature, that confirms that the Duet temperature sense channels are working. Assuming that's the case, the most likely cause of the temperature reading being high is that there is a short between the thermistor wiring and the hot end metalwork.

    If you have a multimeter, try unplugging the hot end thermistor from the Duet and measuring its resistance.



  • Thank you verry much for the quick reply. The problem is solved. I got an other thermister from a frend, wired it in and now the readings of both thermistors are room temperture. I probably could have solved the issue with a little more patience without posting it here, so I am sorry for waisting your time. Thanks again for the quick response!


  • administrators

    No problem!


Log in to reply