What noise level is expected when the printer is inactive?



  • I have a delta-style printer that I'm slowly building and testing, and I note that even when the printer isn't doing anything, the motors make quite a hum.

    I believe that in delta-style printers, the Duet's default "off" current is set to 60% to provide holding torque so the carriages don't slip down. But, using 60% of max current when sitting there seems like a lot. Is this correct, and should it be making a very obvious noise?



  • Mine makes no noise (unless I just can't hear those frequencies). Im using 24v 0.9deg nema 17 steppers. What mode are you running the motor drivers in?

    Have you tried lower standby current? As long as the holding torque is enough to keep your carriages stationary then thats enough.



  • I'm running whatever the defaults are – I haven't changed microstepping, current, or anything. This was with 1.8 degree stock motors (I have now changed to 0.9 degree motors, but have not turned them on yet).

    I don't actually need any standby current as far as I can tell -- neither the 0.9 or 1.8 degree motors slip when the printer isn't on, though perhaps this varies with their position. So yes, I could lower it, but I was loathe to "fix" the problem that way without understanding if it was really the problem.

    The noise is not very high-pitched, so I don't think it's something that some people just can't hear. In a quiet room, I think this is something that the vast majority of people would notice. So, unless you have turned your standby current way down, it sounds like you just never had the problem.

    This supports my concern that it's not just a matter of lowering the current -- something might be wrong. But, I haven't the slightest idea what that could be. The motors moved and homed properly, so I don't think they can be miswired. I wasn't to the point of using the hot end, bed heater, or extruder, so there was nothing to cause EMI and I wasn't using more than ~2% of the power supply's capacity.

    Thoughts? Anyone else hearing things lol?



  • Hmm I see your angle here more clearly now. Not much more to add except that you want to have some holding torque to keep positional accuracy, if the motors powered off completely then you would be only to the nearest full step accurate presuming the elasticity in your moving parts, such as bowden tubes, umbilical cables etc.. are less than the detent torque.

    What motor current are you using, check your motors specs and set current to 70-80% of the motors max. If the current is too high you might expect unnecessarily noisy (and hot) motors.


  • administrators

    Which Duet is it? Are all 3 motors making a noise?



  • Idle Current is ok on mine at 30% and no audible noise above the hot end fan which is always on on mine also with 1.8 degree motors (New build will wave 0.9's) also you don't say which variant of DUET you have it may make a difference to the noise you experience


  • administrators

    Please can those of you with significant nose when using a Duet WiFi post the details here, in particular, the motor model, the motor current you have configured, the idle current percentage, and the supply voltage. There is a huge amount of control possible with the TMC2660 drivers, so we can probably provide a fix.



  • My X-Axis stepper hums quite a bit. Here are my settings:

    M906 X855 Y855 Z1080 E855 I40  ; Set motor currents (mA)
    M350 X16 Y16 Z64 E16 I1              ; set 16x microstepping with interpolation
    M92 X80 Y80 Z1600 E98                ; set axis steps/mm
    
    

    As far as I can tell they are 1.8° steppers, the one that makes the noise has this number on it: 42HS34(L)-0954JA05-D21



  • Wantai 42BYGHM809L20P4.5-17-X2
    M906 X1275 Y1275 Z800 E1000 I30
    Supply: 24V

    They are humming noticably compared to the A4988 I used before, but it's not too bad.



  • Same issue here.

    Motors are way noisier when idle than my Prusa MK2 with Allegro drivers.
    I'm using the same Jugetek 42JT47-1684A steppers and settings as the D300VS:

    M906 X1000 Y1000 Z1000 E500 I30		; Set motor currents (mA)
    
    

    Power supply is also 24V.


  • administrators

    If I ever get time, I'll experiment with different values of the chopper control register in the stepper drivers, to see if we can can reduce the noise that some users seem to experience.



  • David, we ran into this a bit in the Smoothie world, albeit with a much smaller sample size.
    I'm not sure which chopper configuration you're using presently, but perhaps the ones noted here can be of help:
    https://www.kreativ-fraesen.de/technisches/3d-drucker/stepper-driver-tmc2660/



  • So I experimented with the various chopper settings (TBL, random off time, HEND, HSTRT and tOFF), and I'm afraid to report that this has very little effect on the hum/hiss noise.

    Raykholo, the chopper register value suggested on the website has tOFF = 0, which disables the drivers.
    No wonder that a disabled driver makes no noise…

    So I don't know what to try now. My guess is that the culprits are the stepper motors, though these particular motors are used by all D300VS owners without any tweak to the chopper settings, and I've yet to see a claim they are noisy...



  • Mine have been more noisy at idle with later firmwares 1.20 onwards than before but its only barely audible for me, so not really a problem.



  • These steppers/drivers/metal delta frame are driving me crazy.
    I finally found out that the steppers are indeed near silent… when not connected to the frame.

    As soon as they are bolted to the frame, the noise is amplified a lot.
    Using Astrosyn dampers helps. When the steppers are connected to the frame with them, but without belt,
    the steppers become silent again. With the belt on, the noise is coupled and amplified by the frame, but less than
    without the dampers.

    Some numbers for reference (measured about 1m away from the printer):
    Ambient noise: 36.2 dBA
    Steppers idling (2 with dampers, 1 without): 39 dBA
    Homing: 42 dBA

    I'm really surprised nobody seems to have the same issue...



  • I have some pretty good ears, but I don't hear anything at idle. I did drop voltages after switching to 24V due to the noise the entire delta made while printing. Currently sitting at 1000mA for a 1.7A stepper and 60% idle.

    Still on 1.18, if that makes a difference.



  • I've just finished my configuration of a K8400 converted to Duet wifi on 1.20 and the stepper motors make a lot of noise in idle. The machine is silent, then you home all, then there's a noticeable whine, which drops very marginally after 30 secs until I send it M18 just to keep it quiet. Originally the K8400 was much quieter at rest than it is with the Duet, so I think my configuration values might be wrong. I've tried playing around with the idle current value and the M906 motor currents, but the noise is still there. These are the standard nema17 1.8 degree rated at 2.5A.

    [[language]]
    M350 X16 Y16 Z16 E16:16 I0                         ; Configure microstepping without interpolation
    M92 X67.36 Y67.36 Z2560 E148.7:148.7          	; Set steps per mm
    ;M566 X600 Y600 Z24 E1200:1200                      ; Set maximum instantaneous speed changes (mm/min)
    M566 X600 Y600 Z30 E20 				; Maximum jerk speeds mm/minute
    M203 X15000 Y15000 Z100 E3600:3600                   ; Set maximum speeds (mm/min)
    M201 X1000 Y1000 Z15 E1000:1000                   ; Set accelerations (mm/s^2)
    M906 X1500 Y1500 Z1500 E1500:1500 I30                   ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30             
    
    


  • 1500 may be a bit high for the motors? 80% of max as a rule of thumb. But given the motor parameters you can do some calculations to figure out what a good ballpark should be.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.