[SOLVED] Bad arg letter.... on 12864 display with Maestro board



  • Hi,

    Noob here again with problem number two. I know basically nothing about g-code, so I've used various menu files from here and I'm hoping someone has an explanation for me 🙂

    Firmware is 2.02a and the config-override.g only contains heater tuning.

    The display lights up fine, but then only the following happens.

    I have M918 P1 E2 and M501 at the end of my config.g and I tried with E4 and also excluding them, but I get the same result.

    The display only shows:

    main
    .....3
    Bad arg letter

    I tested different menu versions, but I get the same result every time except that the number 3 changes to which ever the first row is that's not commented out.


  • administrators

    Something is wrong with your root menu file, the one called 'main'. What do you have in that file?



  • @dc42

    Sorry for the delay. My buddy's car broke down, so I had to help him tow it home.

    As I hinted above I'm a novice at this, so stupid questions are to be expected 🙂
    I attached the file here (added .g for this upload only).
    I tried a few different menus that reportedly also worked for others, but get the same result for the 'main' file.
    It's from this post [https://forum.duet3d.com/topic/7609/configuring-12864-lcd-on-maestro/45] in which I think You posted it to dropbox.

    0_1553363001847_main.g



  • @dc42
    Did You have a chance to look at the file? It is called 'main' only on the printer.
    I'm guessing it was the upload that renamed it for some reason.



  • I just re checked my current menu files and they are not from dc42, but from jottesman.
    Sorry for the mix up. The uploaded 'main' is from the jottesman menu.



  • @bikerbuz
    I just tried the main file that you uploaded. I don't get the same error that you described in your first post. It appears to be mostly OK but I don't have the altmain file, etc. so I can't really test anything. Maybe you can zip all the Display files and post them here.



  • @davea

    Sure. here it is. Just rename from .g to .zip
    0_1553533540149_DUET3D_12864LCD_MenuFiles.g



  • Just tried yet another menu, but I get the same result. "Bad arg letter" on the first line thats not commented out.
    I'm getting more and more convinced that my printer is possessed by evil goblins.
    Or maybe the display only understands mandarin and the only line in english it knows is Bad arg letter 😞



  • @bikerbuz
    Well, you maybe right about your Maestro being haunted. I just loaded your files onto my board and the menu works fine. I wasn't expecting to see .g files in the menu directory instead of the macro directory but it all works. The only obvious difference is that I'm using firmware 2.03beta2 where you are on 2.02a. Maybe try to update the firmware. I did notice that the 2.03beta2 has a specific firmware file for the Maestro and that is the one I used.



  • @davea
    Ok, Thanks for the tip and for trying the menu out.. I'll try that tomorrow. I just shut everything down and I'm just about to make me some dinner and then it's netflix and chill for the rest of the night.


  • administrators

    My Maestro-powered printer is busy right now, but I'll try your menu file when it's finished its current job.



  • @dc42
    Thanks. I'm sure it's going to work perfectly on Your Maestro just as it did on DaveA's though.
    I'm almost certain that it's something wrong with my wiring or the Maestro itself. I just can't figure out how it can miss read the files and then respond with clear and readable text if the wiring is to blame, but I'll re check all that tomorrow. For now it's a printer free night for me 🙂


  • administrators

    Yes it works perfectly on my Maestro.

    Please check that you really are running firmware 2.02. You can do that by sending command M115 from DWC or over USB.



  • @dc42
    Well, I downloaded ver. 2.02a from here and installed it Without any errors. It had ver 1.something before and It now reports ver '2.0(RTOS) (2018-06-05b3' from the software information tab on the settings page. With M115 in DWC I get this:
    FIRMWARE_NAME: RepRapFirmware for Duet 2 Maestro FIRMWARE_VERSION: 2.0(RTOS) ELECTRONICS: Duet Maestro 1.0 FIRMWARE_DATE: 2018-06-05b3
    Do You mean that it could somehow be another version? Should I try installing the latest beta?



  • @bikerbuz You're still not running 2.02.

    Download this zip file https://github.com/dc42/RepRapFirmware/releases/download/2.02/Duet2Firmware-2.02a.zip
    Upload the whole zip file through the DWC and everything should get updated properly. Use M115 again to check.



  • @phaedrux
    Ok, Thanks. I had already gone to bed when You posted and I'm at work now, but I'll do that when I get home tonight.
    I reeeally hope that will fix it 🙂 This time difference is a bitch...



  • @Phaedrux
    Downloaded the file here at work and thats the exact same file that I already installed, so I guess I did something wrong (go figure) when I installed it. I'll let You know how it goes tonight 👍


  • administrators

    It might be that the version of Duet Web Control you were running initially didn't handle the case of a main firmware file being included in a zip file. If so then it might work second time.



  • @dc42

    Ahh, ok. I hope that's the issue. I've already done a couple of tests and it prints great.
    If the display starts working, that's the last "hurdle" in my rebuild of the Mecreator2. For now that is.

    The next step is to make the extruder all metal, so I can increase the temp and hopefully print nylon.
    Maybe even PC at some point as I have a couple of rolls of that stuff.
    If that works, I might try out a bowden setup so it can use all of the bed surface. Now it doesn't quite reach the front edge, due to the bulky extruder setup. An extra 5-10mm would be great for printing RC car bodies... I'll let You know tonight if things worked out 🙂



  • @Phaedrux @dc42 @davea
    Success 😄
    A big thanks to all of You for Your help and Your patience. It's greatly appreciated.
    It's a bummer that I can't return the favor. At least not any time soon...
    I'm officially retracting my claim in my first ever post on here, that I thought I understood the basics of how the Duet boards work.
    That's clearly not the case, but I hoping to slowly learn as I go along in this endeavor.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.